PDA

Visualizza la versione completa : internet con suse10 e router pirelli


drinu
05-07-2006, 21:27
ciao a tutti sono fresco di giornata con linux, ho installato la suse10 ma non riesco connettermi a internet. il router è un pirelli age uB. ho letto tutte le discussioni possibili ma non ho risolto niente. la scheda di rete viene riconosciuta da linux e il router funziona con windows e anche da solo senza pc si connette. mi date una mano? per favore scrivete terra terra. grazie

AmeDSL
05-07-2006, 21:39
Configura il router con ip statici(disabilitando DCHP)inserisci manualmente anche i DNS.In Suse,disabilita anche qui DCHP dagli un ip statico,come Gateway dagli l'indirizzo ip del router e come DNS gli stessi(DNS) del Router.Cosi dovrebbe funzionare.Fammi sapere.

drinu
05-07-2006, 22:17
allora... sono riuscito a entrare nel router da linux, mi manca solo di inserire i dns ma non trovo dove vanno messi...grazie dell'aiuto

francofait
05-07-2006, 22:35
e perchè modificheresti la configurazione del firmware se il ruter è regolarmente on line anche a computer spento e con windows.?

Devi semplicemente configurare linux x rendere attiva la scheda di rete al boot del SO

drinu
06-07-2006, 18:17
utilizzando il centro di controllo yast e aprendo schede di rete mi dice:
scheda di rete,nome del dispositivo, ip 192.168.2.3, maschera s.r.255.255.255.0 e infine dice "avviato automaticamente al boot" che è la cosa che interessa come dici tu, ma niente non naviga.

Fabiuz
06-07-2006, 19:04
devi mettere quasi sicuramente i dns del tuo provider
che provider hai?

drinu
06-07-2006, 19:14
il provider bo, comunque ho l'adsl con tinit

Fabiuz
06-07-2006, 19:41
i DNS di tin sono:

131.154.1.3

194.243.154.62

195.31.190.31

apri una console e digiti:

su -c "kate /etc/resolv.conf"
a questo punto lui ti chiederà la password di root ... tu dagliela e ti si apre kate con il file resolv.conf ...

a questo punto mi posti il tuo file resolv.conf e vediamo che cè scritto!

drinu
06-07-2006, 19:50
c'è scritto solo "domain site"
a te, molto gentile!!!!

Fabiuz
06-07-2006, 20:12
allora sotto domain site

scrivi i dns che ti ho messo in questo modo

nameserver 131.154.1.3
nameserver 194.243.154.62
nameserver 195.31.190.31

e salvi il file!

poi sempre da console e da utente root
digiti:
route add default gw IPROUTER

dove IPROUTER è l'ip del tuo router...

Loading