PDA

Visualizza la versione completa : [SMP] Non parte il secondo processore


daniele_dll
12-07-2006, 21:17
mi succede una cosa abbastanza strana, sia con windows, che non me ne frega nulla, sia con linux, che mi interessa troppo!

In pratica non parte il secondo processore!!!

Il server è un compaq prolian 1600 con due 400mhz e 128mb di memoria ecc (che a breve verrà upgradata a 384)

questo è il contenuto di /proc/cpuinfo


virusscanner proc # cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 5
model name : Pentium II (Deschutes)
stepping : 2
cpu MHz : 399.020
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr
bogomips : 799.46


mentre questo è l'output di dmesg, relativo al boot dei proci


Linux version 2.6.16-gentoo-r12-100706-VirusScanner (root@virusscanner) (gcc version 3.4.4 (Gentoo 3.4.4-r1, ssp-3.4.4-1.0, pie-8.7.8)) #3 SMP Mon Jul 10 20:27:28 CEST 2006
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 0000000008000000 (usable)
BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee10000 (reserved)
BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
128MB LOWMEM available.
.
.
.
DMI not present or invalid.
ACPI: Unable to locate RSDP
Allocating PCI resources starting at 10000000 (gap: 08000000:f6c00000)
Built 1 zonelists
Kernel command line: root=/dev/sda4 lapic
Local APIC disabled by BIOS -- reenabling.
Found and enabled local APIC!
.
.
.
Initializing CPU#0
.
.
.
Detected 399.020 MHz processor.
Using tsc for high-res timesource
Console: colour VGA+ 80x25
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
Memory: 124984k/131072k available (2825k kernel code, 5604k reserved, 903k data, 312k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay using timer specific routine.. 799.46 BogoMIPS (lpj=1598926)
.
.
.
CPU: After generic identify, caps: 0183fbff 00000000 00000000 00000000 00000000 00000000 00000000
CPU: After vendor identify, caps: 0183fbff 00000000 00000000 00000000 00000000 00000000 00000000
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 512K
CPU: After all inits, caps: 0183fbff 00000000 00000000 00000040 00000000 00000000 00000000
Checking 'hlt' instruction... OK.
CPU0: Intel Pentium II (Deschutes) stepping 02
SMP motherboard not detected.
Brought up 1 CPUs


La cosa strana è che mi dice

SMP motherboard not detected.

ma è impossibile perché la macchina ha 2 processori e non 1! Sia SmartStart, il tool di gestione, sia allo startup compaiono ed inoltre fisicamente sono connessi alla macchina correttamente, insieme al relativo modulo VRM

Qualcuno ha qualche idea?

Caleb
13-07-2006, 01:59
benvenuto nel terrificante mondo compaq

entra nel bios e dai un'occhiata a una sezione dove puoi indicare il tipo di sistema operativo installato, a memoria non ricordo dove sia, comunque dovresti poter scegliere fra unix / unixware / sco / other e roba varia

linux non c'è, scegli unixware

daniele_dll
13-07-2006, 11:12
grazie, ho anche cercato su google la cosa e ho trovato qualche altra info che va nella tua stessa direzione :D

carini, ma non poco incasinati LOL

per capire come si tirava fuori il blocco dei processori ho impiegato quasi un'ora :D

Caleb
13-07-2006, 14:16
guarda io li odio, ci ho sputato sangue (ma odio compaq in genere)

non ricordo come sia fatto il 1600 ma pensa che parecchi proliant ospitano un alimentatore proprietario, privo di standard; se ti si rompe sei fottuto, la compaq non li produce più e devi affidarti a ditte che ne realizzano di più o meno compatibili a prezzi esorbitanti, si parla di ~600$ l'uno

ho ancora una scheda madre con la cpu ko che non posso sostituire con nient'altro che sia marchiato compaq, e ovviamente quel processore non lo fanno più

molti deskpro non si avviano senza scheda video e ram compaq

alla faccia dei pc compatible, per certi versi sono sistemi più chiusi dei sun

daniele_dll
14-07-2006, 11:14
FINALMENTE sono riuscito a farlo :SBAV:

sul primo disco i tool a cui si accede con F10 erano spampazzati :stordita:

cosi, stamani, dopo 1 ora e qualcosa di prove e tentativi sono riuscito a fargli piallare TUTTO, previdentemente staccando prima il disco con gentoo dato che mi è costato 3 giorni di sistema up per fargli fare emerge -udn world :stordita:, e quindi poi mi ha chiesto di riconfigurare tutto, compreso il tipo di sistema operativo che, anche se dai tool con F10 non me lo fa mettere, li mi ha dato la possibilità di selezionare Linux

FINALMENTE

cmq ... ha impiegato solo 3 giorni per ricompilare tutto con appena 1 procio e 128mb di memoria ... ora la espando piazzandoci 2 banchi da 128 cosi arrivo a 384 e poi sarà perfetta come macchina addetta alla scansione dei virus :D

(PS: se ti servono pezzi ho trovato qualche seller che su ebay vende roba ricondizionata ... nn è il massimo ma sono abb economici :) )

Loading