PDA

Visualizza la versione completa : NVIDIA su Kubuntu


best1980
15-07-2006, 17:47
Ciao a tutti.

Ho installato su un nuovo PC kubuntu 6.0.6.

Il pc ha una scheda grafica integrata (NVIDIA GeForce 6100 GPU, compatibile DirectX 9.0 e OpenGLŪ 1.5).

non ho mai installato schede NVIDIA e quindi non so che devo installare.

Ho guardato il seguente 3D ma niente:

http://forum.html.it/forum/showthread.php?s=&threadid=1003280&highlight=nvidia

il kernel č il seguente: Linux dragonfly 2.6.15-26-386

Che devo installare???

Ho giā installato xserver-xorg-dev e i dev di glx e glut ma niente.

Il file xorg.conf che ho č questo ma si non mi carica la grafica:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Mon May 15 13:23:42 PDT 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "LCD72VM"
Option "DPMS"
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "LCD72VM"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

HELP


CIAO

best1980
15-07-2006, 18:10
l'errore che mi da č questo:

xauth: creating new authority file /root/.serverauth.4753

X: warning; process set to priority -1 instead of requested priority 0

X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.15.7 i686
Current Operating System: Linux dragonfly 2.6.15-26-386 #1 PREEMPT Fri Jul 7 19:27:00 UTC 2006 i686
Build Date: 16 March 2006
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul 15 17:59:08 2006
(==) Using config file: "/etc/X11/xorg.conf"
FATAL: Module nvidia not found.
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

Ciao

andy caps
15-07-2006, 18:26
guarda cosa dice modprobe nvidia e se da errori

altrimenti installa module-assistant ed avvialo

poi con quello gli fai preparare il sistema e compilare ed installare il driver nvidia di ubuntu

best1980
15-07-2006, 18:28
Ciao Andy!

č da un po' che non frequentavo il forum ma vedo con piacere che tu ci sei sempre... l'ultima volta mi avevi dato una mano con la mia radeon mobility 7500 del notebook :-) vediamo se riesci a farmi funzionare anche l'nvidia...

ora provo subito...

ciao :-)

best1980
15-07-2006, 18:30
root@dragonfly:/home/luca# modprobe nvidia
FATAL: Module nvidia not found.
root@dragonfly:/home/luca# cd /
root@dragonfly:/# cd lib/
root@dragonfly:/lib# cd modules/
root@dragonfly:/lib/modules# find .|grep -i nvidia
./2.6.15-23-386/kernel/drivers/char/agp/nvidia-agp.ko
./2.6.15-23-386/kernel/drivers/video/nvidia
./2.6.15-23-386/kernel/drivers/video/nvidia/nvidiafb.ko
./2.6.15-25-386/kernel/drivers/char/agp/nvidia-agp.ko
./2.6.15-25-386/kernel/drivers/video/nvidia
./2.6.15-25-386/kernel/drivers/video/nvidia/nvidiafb.ko
./2.6.15-26-386/kernel/drivers/char/agp/nvidia-agp.ko
./2.6.15-26-386/kernel/drivers/video/nvidia
./2.6.15-26-386/kernel/drivers/video/nvidia/nvidiafb.ko
root@dragonfly:/lib/modules#

Che dici?

andy caps
15-07-2006, 18:33
che non č installato il driver

guarda che tipo di errore da l'installazione o prova direttamente con modul-assitant

best1980
15-07-2006, 18:34
e come lo installo? c'č un pacchetto precompilato per kubuntu? e devo andare sul sito nvidia?

andy caps
15-07-2006, 18:46
installa come ti ho detto module-assistant con apt

poi pensa lui a scaricare i driver e i pacchetti necessari del kernel

Loading