PDA

Visualizza la versione completa : [XUBUNTU] impostare locale


alkat
19-07-2006, 12:09
Ciao,
non riesco mai a ricordarmi come cavolo si impostano i locale sulle varie distro. Mi sembrava che il file che gestisce i locale fosse /etc/profile ma non e' cosi' (o per lo meno, non su xubuntu).

Se do il comando locale, ottengo questo:



# locale
locale: Cannot set LC_ALL to default locale: Nessun file o directory
LANG=it_IT.UTF-8
LANGUAGE=it_IT:it:en_GB:en
LC_CTYPE="it_IT.UTF-8"
LC_NUMERIC="it_IT.UTF-8"
LC_TIME="it_IT.UTF-8"
LC_COLLATE="it_IT.UTF-8"
LC_MONETARY="it_IT.UTF-8"
LC_MESSAGES="it_IT.UTF-8"
LC_PAPER="it_IT.UTF-8"
LC_NAME="it_IT.UTF-8"
LC_ADDRESS="it_IT.UTF-8"
LC_TELEPHONE="it_IT.UTF-8"
LC_MEASUREMENT="it_IT.UTF-8"
LC_IDENTIFICATION="it_IT.UTF-8"
LC_ALL=


Installando determinati pacchetti, compare il seguente messaggio d'errore:



perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "it_IT:it:en_GB:en",
LC_ALL = (unset),
LANG = "it_IT.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_ALL to default locale: Nessun file o directory


Come lo risolvo?

Inoltre, ho notato che su Ubuntu la localizzazione in italiano e' completa e di buona qualita', su Xubuntu invece no. E' un problema di distro oppure devo riconfigurare qualcosa?

.a.

andy caps
19-07-2006, 14:54
installa i vari locales-data locales aspel-it localeconf

poi dai un dpkg-reconfigure locales e fagli fare i vari locales poi scegli it@euro o uno degli iso it

alkat
19-07-2006, 17:51
Originariamente inviato da andy caps
installa i vari locales-data locales aspel-it localeconf

poi dai un dpkg-reconfigure locales e fagli fare i vari locales poi scegli it@euro o uno degli iso it

Non funziona. Ci avevo gia'_ provato ma non va:



root@ines:/home/ketty# apt-get install locales-data locales aspell-it localeconf
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package locales-data
root@ines:/home/ketty# apt-get install locales aspell-it localeconf Reading package lists... Done
Building dependency tree... Done
locales is already the newest version.
aspell-it is already the newest version.
localeconf is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@ines:/home/ketty# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = "it_IT",
LANG = "it_IT"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales...
en_AU.UTF-8... up-to-date
en_BW.UTF-8... up-to-date
en_CA.UTF-8... up-to-date
en_DK.UTF-8... up-to-date
en_GB.UTF-8... up-to-date
en_HK.UTF-8... up-to-date
en_IE.UTF-8... up-to-date
en_IN.UTF-8... up-to-date
en_NZ.UTF-8... up-to-date
en_PH.UTF-8... up-to-date
en_SG.UTF-8... up-to-date
en_US.UTF-8... up-to-date
en_ZA.UTF-8... up-to-date
en_ZW.UTF-8... up-to-date
it_CH.UTF-8... up-to-date
it_IT.UTF-8... up-to-date
Generation complete.
Current default timezone: 'Europe/Rome'.
Local time is now: Wed Jul 19 16:49:06 CEST 2006.
Universal Time is now: Wed Jul 19 14:49:06 UTC 2006.
Run 'tzconfig' if you wish to change it.


localeconf non mi fa scegliere nessun locale: si limita a mostrare la serie di messaggi indicati sopra.

Aggiungo che ho provato anche a modificare a mano il file /etc/environment ma non ho risolto molto.


.a.

Loading