PDA

Visualizza la versione completa : [Kanotix] Partizione FAT32


popoka
08-08-2006, 07:52
Salve a tutti. Sono nuovo del forum e auguro a tutti buon lavoro.
Ho creato una partizione, formattandola FAT32 per poter scambiare dati
da Windows XP a Linux, ma Kanotix mi restituisce un errore nel file
fstab e non mi permette di montare la partizione.
Ho provato ad aggiungere una riga nel suddetto file copiando e incollando
la riga relativa alla partizione contenente Windows, ma niente da fare,
l'errore rimane.
Come posso fare?

PinguinoGoloso
08-08-2006, 08:52
Postare l'errore che ti dà al mount ?

mykol
08-08-2006, 09:11
ed il contenuto del file /etc/fstab e l'output del comando "fdisk -l" ?

(fdisk -l dato in una console, come root)

aprire una console, scrivere "su" (senza virgolette), invio, scrivere la password di root, invio, e poi scrivere

fdisk -l
poi invio

popoka
08-08-2006, 18:32
Mi correggo.
La partizione viene montata, ma risulta in sola lettura.
Io vorrei fosse anche in scrittura.
Comunque stasera posto il fileGrazie.

popoka
09-08-2006, 18:09
Vi posto il mio file.
Vorrei che la partizione hda5 fosse visibile e modificabile da tutte le distro
presenti nell'hd (Kanotix e PCLinuxOS) e naturalmente winXP.
Grazie.

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs devmode=0666 0 0
/dev/hda3 / ext3 defaults,errors=remount-ro 0 1
/dev/hda1 /media/hda1 ntfs ro,umask=000 0 0

/dev/hda2 none swap sw 0 0
/dev/hda4 /media/hda4 ext3 defaults 0 0
/dev/hda5 /media/hda1 vfat ro,umask=000 0 0

/dev/sda1 /media/sda1 vfat noauto,users,exec,umask=000,shortname=mixed,quiet 0 0
/dev/cdrom /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

alkat
09-08-2006, 19:01
Originariamente inviato da popoka

/dev/hda5 /media/hda1 vfat ro,umask=000 0 0


devi modificarla coś:


/dev/hda5 /media/hda1 vfat rw,umask=000 0 0

Naturalmente questa modifica la devi fare sia su Kanotix che su PCLinuxOS (Windows non c'entra 'na mazza).

Io ci aggiungerei anche il parametro "auto" dopo "rw" coś te la monta in automatico, ma poi vedi tu.

.a.

popoka
11-08-2006, 17:34
Grazie. Ora funziona!

alkat
11-08-2006, 18:19
Originariamente inviato da popoka
Grazie. Ora funziona!

Prego, comunque non era difficile:
ro = read-only (sola lettura)
rw = read-write (lettura e scrittura)

.a.

Loading