PDA

Visualizza la versione completa : Impossibile Switchare da X a Console!


KaZaA
14-08-2006, 17:33
:cry: :cry: Sono disperato! Non riesco pi a switchare da X a Terminale. Appena parte Xorg l'alt + ctrl + fn non funziona pi!!! E' da quando ho aggiornato la SimplyMepis 6.0 con i repository EdgyEft che non mi va + nulla! Ecco il log di Xorg:

http://www.badongo.com/file/1228871

Ho provato a mettere la stringa Option "DontVTSwitch" "False" ma non va lo stesso! Vi prego aiutatemi!!!

sacarde
14-08-2006, 19:17
ma in /etc/inittab le crei le consol virtuali ?

KaZaA
14-08-2006, 19:40
Questo il mio inittab...dovrebbe essere a posto...


#
# inittab This file describes how the INIT process should set up
# the system in a certain run-level.
#
# Author: Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
# Modified for RHS Linux by Marc Ewing and Donnie Barnes
#

# Default runlevel. The runlevels used by Mandrake Linux are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:

# System initialization.
si::sysinit:/etc/init.d/rcS

l0:0:wait:/etc/init.d/rc 0
l1:1:wait:/etc/init.d/rc 1
l2:2:wait:/etc/init.d/rc 2
l3:3:wait:/etc/init.d/rc 3
l4:4:wait:/etc/init.d/rc 4
l5:5:wait:/etc/init.d/rc 5
l6:6:wait:/etc/init.d/rc 6

# What to do in single-user mode.
~~:S:respawn:/bin/bash -login >/dev/tty1 2>&1 </dev/tty1

# What to do when CTRL-ALT-DEL is pressed.
ca::ctrlaltdel:/sbin/shutdown -r now

# What to do when the power fails/returns.
pf::powerwait:/etc/init.d/powerfail start
pn::powerfailnow:/etc/init.d/powerfail now
po::powerokwait:/etc/init.d/powerfail stop

# Run gettys in standard runlevels
1:2345:respawn:/sbin/getty 38400 tty1
2:2345:respawn:/sbin/getty 38400 tty2
3:2345:respawn:/sbin/getty 38400 tty3
4:2345:respawn:/sbin/getty 38400 tty4
5:2345:respawn:/sbin/getty 38400 tty5
6:2345:respawn:/sbin/getty 38400 tty6


#-- isdnutils begin
# Change the line below for your local requirements and uncomment them.
# Use "init q" to reread inittab.
# look at the mgetty manpage for more information (mgetty isn't standard!)
#
#I0:2345:respawn:/sbin/mgetty -D -m '"" ATZ OK AT&Eyourmsnhere OK AT&B512 OK' -s 38400 ttyI0
#-- isdnutils end

sacarde
14-08-2006, 19:51
allora e' X

puoi fare una verifica chiudendo X, dovrebbero andare...


nel log di X non noto niente

prova a ricreare xorg.conf

Xorg -configure

KaZaA
14-08-2006, 19:54
Gi provato... X sicuramente, per non capisco cosa abbia...se lo chiudo funziona tutto perfettamente! Lo Xorg.conf dovrebbe andare bene...lo posto cmq:



# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
Option "DontVTSwitch" "False"
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/100dpi:unscaled"
FontPath "/usr/share/X11/fonts/75dpi:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/local/share/fonts"
EndSection

Section "Module"

# Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc101"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
EndSection

#Section "InputDevice"

# /dev/input/event
# for USB
# Identifier "stylus"
# Driver "wacom"
# Option "Device" "/dev/wacom" # Change to
# Option "Type" "stylus"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection

#Section "InputDevice"

# /dev/input/event
# for USB
# Identifier "eraser"
# Driver "wacom"
# Option "Device" "/dev/wacom" # Change to
# Option "Type" "eraser"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection

#Section "InputDevice"

# /dev/input/event
# for USB
# Identifier "cursor"
# Driver "wacom"
# Option "Device" "/dev/wacom" # Change to
# Option "Type" "cursor"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection

Section "Monitor"
Identifier "Monitor Generico"
HorizSync 28.0 - 90.0
VertRefresh 43.0 - 85.0
Option "DPMS"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV41.0"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV41.0"
Monitor "Monitor Generico"
DefaultDepth 24
Option "AllowGLXWithComposite" "1"
Option "RenderAccel" "True"
Option "Coolbits" "1"
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

cacao74
14-08-2006, 19:55
Verifica se hai una sezione come questa _NON_ commentata:


# Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
# (where n is 1 through 12). This allows clients to receive these key
# events.

# Option "DontVTSwitch"

ciao


Eh gia', e' proprio quello che ti ho indicato:

Originariamente inviato da KaZaA
[...]
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
Option "DontVTSwitch" "False" <----------------- ERRORE ----------
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection

Quella opzione non prevede parametri.
Ergo, commenta quella riga.

KaZaA
14-08-2006, 20:10
Quel parametro l'ho messo io per vedere se riuscivo a combinare qualke cosa... :D :D ma comunque anche commentato non funziona...cmq dal man xorg.conf ho visto che prevede un flag booleano true/false per abilitare/disabilitare l'opzione...

Option "DontVTSwitch" "boolean"
This disallows the use of the Ctrl+Alt+Fn sequence (where Fn
refers to one of the numbered function keys). That sequence is
normally used to switch to another "virtual terminal" on operat-
ing systems that have this feature. When this option is
enabled, that key sequence has no special meaning and is passed
to clients. Default: off.

cacao74
14-08-2006, 20:17
Dimenticavo la possibilita di utilizzo di un flag booleano per quella opzione.

Detto cio', e' strano che non funzioni ancora.

Hai riavviato il server grafico?
Percaso hai un layout di tastiera particolare che 'escluda' i tasti 'morti' quali [CTRL], [ALT], ... ?

ciao

KaZaA
14-08-2006, 20:20
ho provato ora con xev e sembra che il ctrl, l'alt e i tasti funzione vadano tutti...mamma mia :dh: :dh:

KaZaA
20-08-2006, 11:50
Up :messner: :cry:

Loading