PDA

Visualizza la versione completa : aiuto, problemi con grub


Alkaid
27-08-2006, 00:36
Questo il mio fdisk -l

sid:/# fdisk -l

Disk /dev/hda: 81.9 GB, 81964302336 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 9964 80035798+ 7 HPFS/NTFS

Disk /dev/hdb: 20.4 GB, 20496236544 bytes
255 heads, 63 sectors/track, 2491 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 2386 19165513+ 83 Linux
/dev/hdb2 2387 2491 843412+ f W95 Ext'd (LBA)
/dev/hdb5 2387 2491 843381 82 Linux swap / Solaris

Disk /dev/sda: 163.9 GB, 163928604672 bytes
255 heads, 63 sectors/track, 19929 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 1 12282 98655133+ 7 HPFS/NTFS
/dev/sda2 16211 19929 29872867+ c W95 FAT32 (LBA)
/dev/sda3 12283 16210 31551660 f W95 Ext'd (LBA)
/dev/sda5 12283 16210 31551628+ 83 Linux

Partition table entries are not in disk order
sid:/#

/dev/hdb1 corrisponde a debian
/dev/sda1 corrisponde a suse
entrambi sono in reiserfs

questo il menu.lst di suse

GNU nano 1.3.10 File:

# Modified by YaST2. Last modification on Thu Aug 3 04:26:11 CEST 2006

color white/blue black/light-gray
default 0
timeout 8
gfxmenu (hd2,4)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###

title SUSE Linux 10.1
root (hd2,4)
kernel /boot/vmlinuz root=/dev/sda5 vga=0x31a resume=/dev/hdb5 splash=si
initrd /boot/initrd

###Don't change this comment - YaST2 identifier: Original name: Debian GNU/Linux

title Debian GNU/Linux, kernel 2.6.15 Default (/dev/hdb1)
kernel (hd1,0)/boot/vmlinuz root=/dev/hdb1 ro

###Don't change this comment - YaST2 identifier: Original name: windows###

title Windows

Il problema Ŕ che al boot il pc mi salta grub (me lo visualizza meno di un secondo) ed avvia automaticamente debian impedendomi la scelda del s.o., che posso fare?

Ho giÓ tentato di prendere suse col chroot e ridare il grub-install ma mi da il seguente errore:


sid:/boot/grub# grub-install /dev/hda
/dev/hda: Not found or not a block device.
sid:/boot/grub#

help

Alkaid
27-08-2006, 00:41
posto anche il menu.lst di debian casomai fosse utile


title Debian GNU/Linux, kernel 2.6.15 Default
root (hd1,0)
kernel /boot/vmlinuz root=/dev/hdb1 ro
savedefault
boot

title Debian GNU/Linux, kernel 2.6.15 Default (recovery mode)
root (hd1,0)
kernel /boot/vmlinuz root=/dev/hdb1 ro single
savedefault
boot

title Debian GNU/Linux, kernel 2.6.15
root (hd1,0)
kernel /boot/vmlinuz-2.6.15 root=/dev/hdb1 ro
savedefault
boot

title Debian GNU/Linux, kernel 2.6.15 (recovery mode)
root (hd1,0)
kernel /boot/vmlinuz-2.6.15 root=/dev/hdb1 ro single
savedefault
boot

title Debian GNU/Linux, kernel 2.6.8-2-386
root (hd1,0)
kernel /boot/vmlinuz-2.6.8-2-386 root=/dev/hdb1 ro
initrd /boot/initrd.img-2.6.8-2-386
savedefault
boot

title Debian GNU/Linux, kernel 2.6.8-2-386 (recovery mode)
root (hd1,0)
kernel /boot/vmlinuz-2.6.8-2-386 root=/dev/hdb1 ro single
initrd /boot/initrd.img-2.6.8-2-386
savedefault
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title Microsoft Windows XP Professional
root (hd0,0)
savedefault
makeactive
chainloader +1



p.s. potrei aggiungere suse a questo grub di debian e poi dargli un grub-install da debian?

Alkaid
27-08-2006, 01:30
ho risolto mettendo la parte di suse sul menu.lst di debian, tutto ok.

Loading