PDA

Visualizza la versione completa : [UBUNTU] Lexmark Z612


Demonologo
28-08-2006, 18:11
ho scaricato i driver dal sito lexmark ma nn ho capito dove installarli, la stampante almeno veniva riconosciuta prima... dopo l'istallazzione nemmeno questo... aiuto

sacarde
28-08-2006, 19:35
http://gentoo-wiki.com/HOWTO_Lexmark_Printers

Demonologo
08-09-2006, 03:20
sarcade grazie dell'aiuto davvero.. ma come faccio tutto ciò su ubuntu? cioè nn ho emerge qui, giusto?

Demonologo
08-09-2006, 03:54
ho trovato questo http://www.ubuntuforums.org/showthread.php?t=49714 ma mentre procedo alc omando "$ sudo tar xvzf z600llpddk-2.0.tgz -C / # extract the tgz's to / putting the files in their right place
$ sudo tar xvzf z600cups-1.0.tgz -C / # extract the tgz's to / putting the files in their right place"
mi viene detto "tar: option requires an argument -- C
" e nn posso procedere

sacarde
08-09-2006, 06:59
scusa
quel documento e' stato completamente riscritto per gentoo

originariamente era generico

puoi trovarlo qui

http://www.linuxfromscratch.org/hints/downloads/files/lexmark-printer.txt

Demonologo
08-09-2006, 16:50
puoi ricontrollare il lik? è tutto il giorno che provo ma nn me lo carica... idee invece per il problema seguendo la guida x ubuntu?

sacarde
08-09-2006, 18:09
AUTHOR: Richard A Downing <richard at linuxfromscratch dot org>

DATE: 2005-08-20

LICENSE: Creative Commons Attribution-NonCommercial-ShareAlike 2.0

SYNOPSIS: How to install Lexmark's binary printer drivers.

DESCRIPTION:

Lexmark publish printer drivers for a number of their printers on their
website. Unfortunately, these are binary drivers, not source code, so if
you have one of these printers you have no choice but to use the binary
driver. This hint explains how to get the driver packages, extract the
binary drivers, and install them on a LFS/BLFS system.

ATTACHMENTS:

None

PREREQUISITES:

You'll need to have installed CUPS and a compatible Ghostscript using the
BLFS instructions.

The Lexmark drivers are currently compiled using libstdc++.so.5, so install
gcc-3.3.x from BLFS if you use gcc-3.4 or later.

You will also need rpm2targz, from:
http://downloads.linuxfromscratch.org/rpm2targz.tar.bz2.

HINT:

Get the Lexmark package from http://www.lexmark.com. I have a Z515 so I used:
http://downloads.lexmark.com/cgi-perl/downloads.cgi?ccs=229:1:0:389:0:0&emeaframe=&fileID=1151

Unpack the tarball like this:

mkdir sandbox
cd sandbox
tar -xvf ../CJLZ600LE-CUPS-1.0-1.TAR.gz

This gets you a script, but it won't work for LFS/BLFS setups (we don't
have rpm for a start), so strip the script from the data with:

tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz

and unpack that tarball:

tar -xvf install.tar.gz

which gives you a lot of files, including two rpms. These need to be
converted to tarballs:

rpm2targz z600cups-1.0-1.i386.rpm
rpm2targz z600llpddk-2.0-1.i386.rpm

Now, providing your cups installation is standard (like BLFS), install the
driver with:

tar -xvzf z600cups-1.0-1.i386.tar.gz -C /
tar -xvzf z600llpddk-2.0-1.i386.tar.gz -C /

You can test that all is well by running the cups backend for the printer:

/usr/lib/cups/backend/z600

which should return something like:

direct z600:/dev/usb/lp0 "Lexmark Lexmark 510 Series" "Lexmark Printer"

Now restart your cups daemon:

/etc/rc.d/init.d/cups restart

You can now use either lpadmin or the web interface to set up your printer.

ACKNOWLEDGEMENTS:

* The GENTOO Wiki of this topic:
http://gentoo-wiki.com/HOWTO_Lexmark_Printers

CHANGELOG:

[2005-08-20]
* Initial hint.

Loading