PDA

Visualizza la versione completa : [UBUNTU] alice adsl ed ethernet


metal milita
06-09-2006, 18:20
premessa:
ho un alice adsl che collego al pc con cavo di rete.
da windows mi collego inserendo nome utente e password, al resto ci pensa dhcp.

si ubuntu non riesco a collegarmi ne con lŽinterfaccia chiamata network, ne da linea di comando usando route e ifconfig.

avete mai avuto un problema simile?

francofait
06-09-2006, 18:45
Originariamente inviato da metal milita
premessa:
ho un alice adsl che collego al pc con cavo di rete.
da windows mi collego inserendo nome utente e password, al resto ci pensa dhcp.

si ubuntu non riesco a collegarmi ne con lŽinterfaccia chiamata network, ne da linea di comando usando route e ifconfig.

avete mai avuto un problema simile?

fa tanto pensare che la tua scheda di rete non venga riconosciuta , non vedo altri motivi visto che cion XP la connessione funziona subito regolarmente

an3a
06-09-2006, 19:37
Originariamente inviato da metal milita
premessa:
ho un alice adsl che collego al pc con cavo di rete.
da windows mi collego inserendo nome utente e password, al resto ci pensa dhcp.

si ubuntu non riesco a collegarmi ne con lŽinterfaccia chiamata network, ne da linea di comando usando route e ifconfig.

avete mai avuto un problema simile?

Ciao,

dunque, ho una ubuntu e uso alice adsl ormai da qualche mese, quindi dovrei riuscire a darti una mano ... :stordita:

per prima cosa devi lanciare la configurazione di ppoeconf con il comando:
sudo pppoeconf

e impostare i paremetri che ti verranno chiesti.

fatto questo, che devi fare solo una volta e creare una configurazione pppoe io ho uno script che lancio per collegarmi e uno per scollegarmi, se ti interessa te li mando.

Casper87
06-09-2006, 19:40
controlla con route -n se è stato assegnato sotto un IP al gateway. per eliminarlo devi dare route del default gw [ultimo indirizzo IP del gateway che hai visualizzato con route -n]

ovviamente senza parentesi quadre ma solo l'IP

metal milita
06-09-2006, 19:48
Originariamente inviato da an3a
Ciao,

dunque, ho una ubuntu e uso alice adsl ormai da qualche mese, quindi dovrei riuscire a darti una mano ... :stordita:

per prima cosa devi lanciare la configurazione di ppoeconf con il comando:
sudo pppoeconf

e impostare i paremetri che ti verranno chiesti.

fatto questo, che devi fare solo una volta e creare una configurazione pppoe io ho uno script che lancio per collegarmi e uno per scollegarmi, se ti interessa te li mando.

ciao. mi fa piacere se mi mandassi lo script. poi ci penso io a modificarlo per il mio pc.

comunque ho provato ad usare pppeconfig e la scheda me la riconosce. credo che siano solo gli indirizzi che mi fregano.

Casper87
06-09-2006, 19:52
@metal milita: edita il resolv.conf e inserisci gli ip statici

@an3a: interessa anche a me lo script :D

:ciauz:

an3a
06-09-2006, 20:02
Originariamente inviato da Casper87
@metal milita: edita il resolv.conf e inserisci gli ip statici

@an3a: interessa anche a me lo script :D

:ciauz:

ah, ok ... ora scriverei solo castronate ... domattina lo posto qui ... se non vedete arrivare niente fate un fischio ... :stordita:

an3a
07-09-2006, 11:10
heyla'!

per usare il modem ethernet che mi ha dato alice (purtroppo non e' venuta a casa direttamente lei ma ha mandato un tecnico bruttarello), seguo questa procedura.

la configurazione e l'attivazione del servizio al primo collegamente a internet l'ho fatto da pc win che non so bene il programma che ti danno se configuri qualcosa anche sul modem.

dicevo, la procedura:

0. (da fare una volta solo o per modificare i parametri della connessione)
creata una configurazione di connessione con il comando:
sudo pppoeconf
la configurazione che ho creato io si chiama dsl-provider.

i passi da qui in avanti invece li faccio ogni volta che devo collegarmi...

1.
disabilitare la scheda di rete, si possono seguire due strade:
- tasto destro sull'appleto della rete -> Proprieta' -> Configura
- da menu' Sistema -> Amministrazione -> Rete
a questo punto seleziono la scheda di rete e clicco su proprieta'
http://an3a.altervista.org/linux/rete_1.png
e tolgo la spunta ad "Abilitare questa connessione"
http://an3a.altervista.org/linux/rete_2.png

2.
tiro su il collegamento con questo script:


#! /bin/sh

sudo ifconfig eth0 up

sudo pon dsl-provider


3.
tiro giu' il collegamento con questo script:


#! /bin/sh

sudo poff dsl-provider


fatto!

in realta' i pochi comandi contenuti negli script potrebbero essere lanciati a mano ... ma sono pigro! :stordita:

una volta tirato su il collegamenti ci vuole qualche secondo (tra i 5 e i 10) per poter navigare altrimenti i nomi non mi vengono risolti (io ad esempio provo a dare un paio di: sudo apt-get update per capire se i dns fanno il loro lavoro ...)

se qualcosa non e' chiaro .. mi trovate qui!
ciau! :ciauz:

metal milita
07-09-2006, 12:53
grazie ragazzi.

si fa proprio così. :)

Loading