PDA

Visualizza la versione completa : [Ubuntu] Impossibile installare KDE


PiKey
07-09-2006, 01:15
Voglio avere la possibilità di switchare tra GNOME e KDE a seconda di come mi gira sul momento.
Così ho dato un sudo apt-get install kubuntu-desktop

Tuttavia per un pacchetto che dà problemi non riesco a installare proprio niente. Il pacchetto in questione si chiama language-selector-qt e l'errore è il seguente:


I seguenti pacchetti hanno dipendenze non soddisfatte:
kubuntu-desktop: Dipende: language-selector-qt ma non sta per essere installato
E: Pacchetto non integro

Per avere più informazioni ho provato a installare il pacchetto di cui sopra singolarmente, ma:


I seguenti pacchetti hanno dipendenze non soddisfatte:
language-selector-qt: Dipende: language-selector-common (= 0.1.20) ma 0.1.20.1 sta per essere installato
E: Pacchetto non integro

Facendo una ricerca tra i pacchetti ho visto che ho installato language-selector e language-selector-common, entrambi alla versione 0.1.20.1; mentre il povero language-selector-qt nei repositories è fermo alla 0.1.20

Tuttavia non è tutto. Dato l'errore "pacchetto non integro" ho provato a reinstallare language-selector e language-selector-common, con:

sudo apt-get install --reinstall language-selector language-selector-common

Mi viene quindi un errore alquanto strano:


La reinstallazione di language-selector non è possibile, non può essere scaricato.
La reinstallazione di language-selector-common non è possibile, non può essere scaricato.

Boh. Il mio file /etc/apt/sources.list mi sembra a posto. :bhò:
Che mi dite?

:ciauz:

submax82
07-09-2006, 01:23
prova

apt-get -f install

Casper87
07-09-2006, 02:14
da synaptic vai e marca kde e poi il file kde-i18n-it (non ricordo se si scrive proprio così e comunque mi sa che lo ,arca da solo se hai le impostazioni della lingua di sistema in ita)

PiKey
07-09-2006, 12:43
Originariamente inviato da Casper87
da synaptic vai e marca kde e poi il file kde-i18n-it (non ricordo se si scrive proprio così e comunque mi sa che lo ,arca da solo se hai le impostazioni della lingua di sistema in ita)

credo però che il metapacchetto kde abbia molte meno dipendenze di kubuntu-desktop...

PiKey
07-09-2006, 17:22
Uhm, sembra un problema diffuso. Ho trovato un thread simile (http://www.ubuntuforums.org/showthread.php?p=1473294) anche sul forum ufficiale di Ubuntu e il problema non sembra essere stato nemmeno temporaneamente risolto. Sì, c'è una soluzione molto fai-da-te che però la considero proprio come ultima spiaggia, dato i rischi che si corrono a modificare le dipendenze di un repository come quello di Ubuntu.

EDIT:

Originariamente inviato da submax82
prova

apt-get -f install

Questo comporta la non installazione del pacchetto che dà problemi, giusto?

PiKey
07-09-2006, 17:45
Ah, ho provato anche a fare il downgrade dei due pacchetti che danno problemi alla versione 0.1.20, ma mentre per language-selector-common questo è possibile, il pacchetto language-selector è disponibile proprio e solo dalla versione 0.1.20.1

mah

submax82
07-09-2006, 19:34
dal man


-f, --fix-broken
Fix; attempt to correct a system with broken dependencies in
place. This option, when used with install/remove, can omit any
packages to permit APT to deduce a likely solution. Any Package
that are specified must completely correct the problem. The op-
tion is sometimes necessary when running APT for the first time;
APT itself does not allow broken package dependencies to exist
on a system. It is possible that a system's dependency structure
can be so corrupt as to require manual intervention (which usu-
ally means using dselect(8) or dpkg --remove to eliminate some
of the offending packages). Use of this option together with -m
may produce an error in some situations.

PiKey
08-09-2006, 00:03
Ho provato con l'opzione --fix-broken attivata, ma non cambia la situazione purtroppo :(

EDIT: oggi pomeriggio ho inserito un bug-report su Launchpad... speriamo che qualcuno lo risolva... per ora è ancora Untriaged.

francofait
08-09-2006, 01:00
Originariamente inviato da PiKey
Ho provato con l'opzione --fix-broken attivata, ma non cambia la situazione purtroppo :(

EDIT: oggi pomeriggio ho inserito un bug-report su Launchpad... speriamo che qualcuno lo risolva... per ora è ancora Untriaged.

trasferisci tutti i pacchetti interessati da /var/cache/apt in una dir di comodo vuota , poi dai li dai:
dpkg --force-all -i *.deb

PiKey
08-09-2006, 17:21
purtroppo faccio periodicamente una pulizia della cache per problemi di spazio... cmq posso sempre scaricare i pacchetti dal sito di Ubuntu

Loading