PDA

Visualizza la versione completa : Inviare email con postfix: qualche aiuto?


kylnas1
11-10-2006, 17:21
Salve a tutti,
ho creato un mail server con postfix ma non riesco a mandare le email. Il problema che non so come testare il server.

Ho provato ad eseguire il comando "mail indirizzoemail" ma la mail non arriva, quindi deduco che non funzioni.
Inoltre per farlo funzionare serve necessariamente che la macchina abbia un indirizzo IP pubblico statico?

grazie

Fabiuz
11-10-2006, 18:37
ma non riesci a mandare mail a lui, o tramite lui???

kylnas1
11-10-2006, 18:47
Originariamente inviato da Fabiuz
ma non riesci a mandare mail a lui, o tramite lui???
Tramite lui, ottengo questi errori:


Oct 11 16:14:27 ... amavis[4038]: (04038-07) TROUBLE in check_mail: decoding2-get-file-types FAILED: 'file' utility (/usr/bin/file) failed, status=1 $
Oct 11 16:14:27 ... amavis[4038]: (04038-07) PRESERVING EVIDENCE in /var/lib/amavis/amavis-20061011T161427-04038
Oct 11 16:14:27 ... postfix/smtp[5144]: CD164264EE0: to=<kylnas@tiscali.it>, relay=127.0.0.1[127.0.0.1], delay=1969, status=deferred (host 127.0.0.1[$
Oct 11 16:14:27 ... amavis[5151]: (04039-08) run_command: child process [5151] failed to exec /usr/bin/file /var/lib/amavis/amavis-20061011T161427-04$
Oct 11 16:14:27 ... amavis[4039]: (04039-08) TROUBLE in check_mail: decoding2-get-file-types FAILED: 'file' utility (/usr/bin/file) failed, status=1 $
Oct 11 16:14:27 ... amavis[4039]: (04039-08) PRESERVING EVIDENCE in /var/lib/amavis/amavis-20061011T161427-04039
Oct 11 16:14:27 ... postfix/smtp[5145]: 88071264EE6: to=<kylnas@tiscali.it>, relay=127.0.0.1[127.0.0.1], delay=1822, status=deferred (host 127.0.0.1[$
Oct 11 16:31:07 ... postfix/qmgr[5068]: DEFA7264E98: from=<root@...>, size=282, nrcpt=1 (queue active)
Oct 11 16:31:07 ... postfix/qmgr[5068]: F1A46264E0D: from=<root@...>, size=287, nrcpt=1 (queue active)
Oct 11 16:31:07 ... postfix/qmgr[5068]: 05818264EA6: from=<root@...>, size=307, nrcpt=1 (queue active)
Oct 11 16:31:07 ... postfix/qmgr[5068]: 0B0A5264E5D: from=<root@...>, size=310, nrcpt=1 (queue active)
Oct 11 16:31:07 ... amavis[5178]: (04038-08) run_command: child process [5178] failed to exec /usr/bin/file /var/lib/amavis/amavis-20061011T163107-04$
Oct 11 16:31:07 ... amavis[4038]: (04038-08) TROUBLE in check_mail: decoding2-get-file-types FAILED: 'file' utility (/usr/bin/file) failed, status=1 $
Oct 11 16:31:07 ... amavis[4038]: (04038-08) PRESERVING EVIDENCE in /var/lib/amavis/amavis-20061011T163107-04038
Oct 11 16:31:07 ... amavis[5180]: (04039-09) run_command: child process [5180] failed to exec /usr/bin/file /var/lib/amavis/amavis-20061011T163107-04$
Oct 11 16:31:07 ... amavis[4039]: (04039-09) TROUBLE in check_mail: decoding2-get-file-types FAILED: 'file' utility (/usr/bin/file) failed, status=1 $
Oct 11 16:31:07 ... amavis[4039]: (04039-09) PRESERVING EVIDENCE in /var/lib/amavis/amavis-20061011T163107-04039
Oct 11 16:31:07 ... postfix/smtp[5177]: F1A46264E0D: to=<giacomom@triware.it>, relay=127.0.0.1[127.0.0.1], delay=5961, status=deferred (host 127.0.0.$
Oct 11 16:31:07 ... postfix/smtp[5176]: DEFA7264E98: to=<test@...>, orig_to=<test>, relay=127.0.0.1[127.0.0.1], delay=5979, status=deferred (h$
Oct 11 16:31:07 ... amavis[5185]: (04038-09) run_command: child process [5185] failed to exec /usr/bin/file /var/lib/amavis/amavis-20061011T163107-04$
Oct 11 16:31:07 ... amavis[4038]: (04038-09) TROUBLE in check_mail: decoding2-get-file-types FAILED: 'file' utility (/usr/bin/file) failed, status=1 $
Oct 11 16:31:07 ... amavis[4038]: (04038-09) PRESERVING EVIDENCE in /var/lib/amavis/amavis-20061011T163107-04038
Oct 11 16:31:07 ... amavis[5184]: (04039-10) run_command: child process [5184] failed to exec /usr/bin/file /var/lib/amavis/amavis-20061011T163107-04$

Ho letto che un bug della debian con amavis, ma non sono riuscito a scoprire altro... :(

Qualche idea?

oTTony
11-10-2006, 19:30
Io non uso amvis quindi non saprei dirti se si tratta di un bug , guardando il tuo log sembrarebbe che il relay non esca dal net locale , sempre se vuoi inviare mail ad un indirizzo remoto chiaro , sei sicuro di aver configurato il relayhost esatto e mynetwork in maniera coerente ?

Fabiuz
11-10-2006, 23:30
guarda io ho postfix+clamav+spamassassin con la debian e funziona tutto alla grande

ovviamente con sarge..

kylnas1
12-10-2006, 02:17
Originariamente inviato da Fabiuz
guarda io ho postfix+clamav+spamassassin con la debian e funziona tutto alla grande

ovviamente con sarge..
Repository stable?

kylnas1
12-10-2006, 02:24
Originariamente inviato da oTTony
Io non uso amvis quindi non saprei dirti se si tratta di un bug , guardando il tuo log sembrarebbe che il relay non esca dal net locale , sempre se vuoi inviare mail ad un indirizzo remoto chiaro , sei sicuro di aver configurato il relayhost esatto e mynetwork in maniera coerente ?
Il relay host dovrebbe essere esatto ( il server smtp con il quale spedisco la posta normalmente con thunderbird), per quanto riguarda mynetwork non credo di averlo settato in maniera coerente. Ma cosa intendi esattamente con "coerente"?

Fabiuz
12-10-2006, 07:29
posta i due file principali di configurazione di postfix

kylnas1
12-10-2006, 10:42
Originariamente inviato da Fabiuz
posta i due file principali di configurazione di postfix
main.cf:


smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

myhostname = tricommerce.it
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = Triware.it, triware-it, localhost.localdomain, localhost, tricommerce.it
relayhost = smtp.fastwebnet.it
mynetworks = 127.0.0.0/8
mynetworks_style = host
mailbox_command = /usr/bin/spamc | procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
content_filter = amavis:[127.0.0.1]:10024

E master.cf


================================================== ========================
# service type private unpriv chroot wakeup maxproc command + args
# (yes) (yes) (yes) (never) (100)
# ================================================== ========================
smtp inet n - - - - smtpd
#submission inet n - - - - smtpd
# -o smtpd_etrn_restrictions=reject
#628 inet n - - - - qmqpd
pickup fifo n - - 60 1 pickup
cleanup unix n - - - 0 cleanup
qmgr fifo n - - 300 1 qmgr
#qmgr fifo n - - 300 1 oqmgr
rewrite unix - - - - - trivial-rewrite
bounce unix - - - - 0 bounce
defer unix - - - - 0 bounce
trace unix - - - - 0 bounce
verify unix - - - - 1 verify
flush unix n - - 1000? 0 flush
proxymap unix - - n - - proxymap
smtp unix - - - - - smtp
relay unix - - - - - smtp
# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq unix n - - - - showq
error unix - - - - - error
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - n - - lmtp
anvil unix - - n - 1 anvil
#
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# maildrop. See the Postfix MAILDROP_README file for details.
#
maildrop unix - n n - - pipe
flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
uucp unix - n n - - pipe
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail unix - n n - - pipe
flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp unix - n n - - pipe
flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -d -t$nexthop -f$sender $recipient
scalemail-backend unix - n n - 2 pipe
flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}

# only used by postfix-tls
#tlsmgr fifo - - n 300 1 tlsmgr
#smtps inet n - n - - smtpd -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#587 inet n - n - - smtpd -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes

amavis unix - - n - 2 smtp
-o smtp_data_done_timeout=1200
-o disable_dnl_lookup=yes

127.0.0.1:10025 inet n - n - - smtpd
-o content_filter=
-o local_recipient_maps=
-o relay_recipient_maps=
-o smtpd_restriction_classes=
-o smtpd_helo_restrictions=
-o smtpd_sender_restrictions=
-o smtpd_recipient_restrictions=permit_mynetworks,rej ect
-o mynetworks=127.0.0.0/8
-o strict_rfc821_envelopes=yes

kylnas1
12-10-2006, 15:18
Per ora ho risolto...era "/dev/null" che non aveva i permessi adatti... :dh:

Aveva 660 invece di 666.

Se ho altri problemi scrivo qui.

Grazie a tutti e 2 per l'aiuto.

Loading