PDA

Visualizza la versione completa : Slackware 11


pop killer
20-10-2006, 15:41
Ciao a tutti. :D
Eccomi di nuovo qui. Dopo aver smanettato parecchio con ubuntu ed arch, ho deciso di vedere la nuova slackware. Dato la scarsita' di informazioni vorrei porvi alcune domande:
1. Ho sentito che il 2.6 e' senza moduli... quindi cosa mi consigliate di fare, installare di base il 2.4 e poi compilare il 2.6 vanilla?
2. Ho scaricato il dvd da 3.8gb, ma ad esempio su http://www.linuxpackages.net/ vedo che ci son molti meno pacchetti... cosa dite, posso provare a mettere anche quelli della 10.2 oppure devo compiarmeli quelli che non ci sono?

Grazie anticipatamente. :)

francofait
20-10-2006, 16:07
Originariamente inviato da pop killer
Ciao a tutti. :D
Eccomi di nuovo qui. Dopo aver smanettato parecchio con ubuntu ed arch, ho deciso di vedere la nuova slackware. Dato la scarsita' di informazioni vorrei porvi alcune domande:
1. Ho sentito che il 2.6 e' senza moduli... quindi cosa mi consigliate di fare, installare di base il 2.4 e poi compilare il 2.6 vanilla?
2. Ho scaricato il dvd da 3.8gb, ma ad esempio su http://www.linuxpackages.net/ vedo che ci son molti meno pacchetti... cosa dite, posso provare a mettere anche quelli della 10.2 oppure devo compiarmeli quelli che non ci sono?

Grazie anticipatamente. :)


Hai sentiito male , l'installazzione diretta con kernel-2.6.18 non ti installa i moduli , ma nel dvd sono presenti senza problemi.
Per cui puoi tranquillamente installare subito 2.6.18 , poi riavvi sempre da dvd installazione passando al prompt dei comandi :
linux root=/dev/hdxx (xx = disco-partiz.)
e completi la configurazione installando anche il pacchetto dei moduli

pop killer
20-10-2006, 18:49
Originariamente inviato da francofait
Hai sentiito male , l'installazzione diretta con kernel-2.6.18 non ti installa i moduli , ma nel dvd sono presenti senza problemi.
Per cui puoi tranquillamente installare subito 2.6.18 , poi riavvi sempre da dvd installazione passando al prompt dei comandi :
linux root=/dev/hdxx (xx = disco-partiz.)
e completi la configurazione installando anche il pacchetto dei moduli
e come si chiama il pacchetto dei moduli?

per quanto riguarda il numero basso di pacchetti?

grazie mille.

pop killer
21-10-2006, 16:09
Ho installato il kernel huge26.s (2.6.17.13), e questo parte perfettamente, ma non so come fare per vedere se ha i moduli.

Solo che ho bisogno dei sorgenti per installare ndiswrapper, che non sono nel cd. Devo scaricarli dal sito kernel.org?

francofait
21-10-2006, 16:37
Originariamente inviato da pop killer
Ho installato il kernel huge26.s (2.6.17.13), e questo parte perfettamente, ma non so come fare per vedere se ha i moduli.

Solo che ho bisogno dei sorgenti per installare ndiswrapper, che non sono nel cd. Devo scaricarli dal sito kernel.org?

ndiswrapper nel cdrom c' , chi cerca trova :mame: :mame:

francofait
21-10-2006, 16:38
Originariamente inviato da francofait
ndiswrapper nel cdrom c' , chi cerca trova :mame: :mame: aprile tutte le cartelle di quei benetti cdrom , mica le sciupi a vedere cosa c' dentro

pop killer
21-10-2006, 17:02
Originariamente inviato da francofait
aprile tutte le cartelle di quei benetti cdrom , mica le sciupi a vedere cosa c' dentro
Scusa, ma io ho fatto "install all packages" pensando che installasse tutto, ma se mi dici che ndiswrapper e' nel cd, allora non e' vero. :confused:

Comunque, ora controllo meglio il dvd.

Ma scusa una cosa... sai non son esperto.
Hai detto che i moduli non li installa all'inizio, ma questi moduli sono necessari o no? dato che a me il sistema parte benissimo e funge... quindi se non son necessari evito di installarli, tranne che per ndiswrapper che mi serve.

in sostanza la mia domanda e': nel kernel i moduli necessari son compilati all'interno e non sono presenti quelli non strettamente necessari?

francofait
21-10-2006, 17:09
come faccia ad andar bene senza i moduli , inconcepibile salvo tu non abbia avviato l'installazione con bare.i nel qual caso non hai il kernel 2.6.18 m il 2.4.33 .
per vedere che kernel stai usando editi /etc/lilo.con e lo vedi subito , per vedere i moduli basta aprire la cartella /lib/modules /2.4.33 o 2.6.18 se hai realmente il .6.18

pop killer
21-10-2006, 17:22
Ho avviato l'installazione con il bare.i, ma nella scelta del kernel ho scelto il 2.6, infatti se do uname -a mi da come kernel il 2.6.17.13.

solo che in /lib/modules c'e' solo la cartella del 2.4

quindi dici che slack non trova i moduli del 2.6 e carica al suo posto il 2.4?

francofait
21-10-2006, 17:46
Originariamente inviato da pop killer
Ho avviato l'installazione con il bare.i, ma nella scelta del kernel ho scelto il 2.6, infatti se do uname -a mi da come kernel il 2.6.17.13.

solo che in /lib/modules c'e' solo la cartella del 2.4

quindi dici che slack non trova i moduli del 2.6 e carica al suo posto il 2.4?

bare.i non carica il kernel 2.6.x ma il 2.4.x
per lanciare l'installazione con kernel2.6.17.x dovevi dare
huge26.s
per il kernel 2.6.18 invece visto che nel dvd c' anche quello:
test26.s

il pacchtto dei moduli x hoge26s nel dvd nella cartella /extra
quello x test26.s in /testing/package/2.6.18
ndiswrapper in /extra
wsuplicant in /testing/package

Loading