PDA

Visualizza la versione completa : help scheda nvidia


mandrillo
23-10-2006, 17:48
h un bel problema con la mia sceda nvidia, :dh:
dopo aver installato i driver, non riesco a settare la frequenza del monitor che fissa a 85 hz e il mio lcd viaggia a 60.
H provato a modificare /etcx11/xorg.conf, ma niente...non fa una piega
:cry:
mi date una mano?? :D

superbubba
23-10-2006, 21:38
Ricopia qui il tuo xorg.conf, cos gli diamo un'occhiata...

mandrillo
24-10-2006, 06:09
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Tue Aug 1 21:11:12 PDT 2006

# File generated by XFdrake (rev 41554)
# ************************************************** ********************
# Refer to the xorg.conf man page for details about the format of
# this file.
# ************************************************** ********************

Section "ServerLayout"
Identifier "layout1"
Screen "screen1" 0 0
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
EndSection

Section "Files"

# font server independent of the X server to render fonts.
# minimal fonts to allow X to run without xfs
FontPath "unix/:-1"
FontPath "/usr/lib/X11/fonts/misc:unscaled"
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "ServerFlags"

#DontZap # disable <Crtl><Alt><BS> (server abort)
# allows the server to start up even if the mouse does not work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
Option "allowmouseopenfail"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ButtonMapping" "1 2 3 6 7"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
Identifier "monitor1"
VendorName "Generic"
ModelName "1280x1024 @ 60 Hz"
HorizSync 31.5 - 64.3
VertRefresh 50.0 - 70.0
ModeLine "768x576" 50.0 768 832 846 1000 576 590 595 630
ModeLine "768x576" 63.1 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
Driver "nvidia"
VendorName "nVidia Corp."
BoardName "NVIDIA GeForce 7 Series"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24
Option "DPMS"
SubSection "Display"
Depth 8
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Section "Extensions"
Option "Composite"
EndSection

---------------------
intanto grazzie dell'interessamento :)

superbubba
24-10-2006, 09:34
Hai provato a editare il file settando:

VertRefresh 60.0

mandrillo
24-10-2006, 18:52
si super...fatto
mi sa che mi devo rassegnare a tenere il linuzzo senza accellerazione :cry:
va be...fa niente
per grazie x l'interessamento :ciauz:

KaZaA
24-10-2006, 19:25
Se sei sicuro che il tuo monitor supporti 85Hz di refresh a 1280x1024 ma Xorg non ne vuole sapere, potresti fare una piccola cosa:

aggiungi nella Sezione Device il comando

Option "UseEDID" "False",

imposta l'HorizSync a 31.5 - 80 (L?aggiornamento Orizontale...l'80 indicativo...metti quello supportato dal tuo monitor) e il VertRefresh a 50.0 - 85.0 e commenta le 2 modeline...poi prova a riavviare X...io l'ho dovuto fare per operare di Refresh Override...mi sono spinto con il refresh oltre le impostazioni di fabbrica :mame: :mame:

Loading