PDA

Visualizza la versione completa : [hal]non funziona più hal


alcohol90
28-10-2006, 17:46
Ciao a tutti,
ho eseguito un aggiornamento dei vari pacchetti con synaptic su una Debian.
Dopo l'aggiornamento però hal non ha dato più segni di vita.
Infatti le periferiche tipo CD o chiavetta usb, ecc. non me le monta più automaticamente come prima.
Se nel terminale digito "lshal" mi appare il seguente errore:

error: libhal_ctx_init: (null): (null)
Could not initialise connection to hald.
Normally this mean the HAL daemon (hald) is not running or not ready.
lshal.c 689 : INFO: called LIBHAL_FREE_DBUS_ERROR but dbusError was not set.

Qualcuno mi può dare una mano a ripristinare questa comodissima funzione?

sacarde
28-10-2006, 18:32
ma il servizio e' partito ?


ristartalo

bereshit
28-10-2006, 18:43
mi era successo anche a me..poi ho scoperto che durante l'update avevo detto di non aggiornare un file di configurazione di hal..e di mantenere quello vecchio..l'update successivo invece ho presomquello nuovo è tutto è andato a posto..:)

alcohol90
29-10-2006, 12:31
Digitando "hald" da console di root, le periferiche cominciano a lampeggiare, ciò significa che hal le riconosce. il problema e che kde (aggiornato a 3.5.5) non le vede e non le monata,
Infatti andando in "dispositivi di archiviazione" le periferiche hal non compaiono oppure il CD già montato da fstab non me lo fa smontare facendo apparire il messaggio "disponibile solo con HAL".
Andando su "Centro di controllo" -> "Periferiche" -> "Dispositivi di archiviazione", la casella "Abilita il backend HAL" è disabilitata cioè è grigia.

Cosa devo fare?

alcohol90
29-10-2006, 18:17
ricercando un po su google ho letto che molte persone avendo aggiornato KDE alla 3.5.5 hanno avuto il mio stesso problema però non ho trovato come risolverlo.

Qualcuno può aiutarmi?

Loading