PDA

Visualizza la versione completa : awstats - configurazione


Sandrocchio_0.1
10-11-2006, 16:15
Ciao a tutti,
sto provando a configurare awstats su Apache2, Suse 10.1

Ho installato l'rpm, seguito la documentazione per quanto concerne la configurazione base.
Sono riuscito a generare un report da riga di comando ma se provo a farlo attraverso il browser non funziona correttamente. Ho provato a cercare e di rileggere la documentazione, ma nada, non ci salto fuori.

Gli obiettivi sono due:
[list=1]
Riuscire ad avere il report delle statistiche attraverso l'url.
Separarle tra i diversi virtualhost.
[/list=1]

Durante l'installazione mi sono ritrovato i seguenti files:
/etc/awstats/awstats.conf che se chiamato da riga di comando genera correttamente i report relativi a localhost in un file html
/srv/www/cgi-bin/awstats.pl che se chiamato dal browser http://localhost/cgi-bin/awstats.pl?month=11&year=2006&output=unknownos non da altro che la pagina di awstats ma senza report, solo con il logo.

Leggendo sembra che debba configurare un file awstats.localhost.conf preso da /etc/awstats/awstats.conf e copiato nella stessa cartella di /srv/www/cgi-bin/awstats.pl - ma l'unica cosa che cambia un messaggio che avvisa che il report non aggiornato.

Consigli e suggerimenti sono ben accetti.
Ciao, grazie in anticipo.
Ciao

side-server
11-11-2006, 08:20
Andiamo ad esclusione; visto che awstats usa degli script in perl devi dire ad Apache che ha il permesso per eseguirli.

<Directory /srv/www/cgi-bin>
Options +ExecCGI
#altre tue eventuali opzioni
</Directory>

:ciauz:

marketto
11-11-2006, 13:25
ciao,
ti sposto su linux. :)

Sandrocchio_0.1
11-11-2006, 21:07
#Default server
<VirtualHost *:80>
DocumentRoot /srv/www/htdocs/
ServerName localhost
ServerAdmin alessandro@xxx.eu
# YaST created entry
<Directory "/srv/www/htdocs/">
Options +Indexes
AllowOverride None
Order allow,deny
Allow from all
DirectoryIndex index.php index.html index.htm
</Directory>
ScriptAlias /cgi-bin/ "/srv/www/cgi-bin/"
<Directory "/srv/www/cgi-bin">
AllowOverride None
Options +ExecCGI
Order allow,deny
Allow from all
</Directory>
Include /etc/apache2/conf.d/*.conf
</VirtualHost>


Nessun cambiamento

Ciao e grazie.

Loading