PDA

Visualizza la versione completa : Perchè nel pc si e nel portatile no...?


wozzek
16-11-2006, 16:30
ciao a tutti,
premetto che uso suse 10.1
sto lavorando con un'applicazione che si chiama emstar ed in particolare sto utilizzando un comando che permette la simulazione della comunicazione tra un client ed un server.Digitando questo comando dalla finestra terminale del mio pc parte il programma di simulazione mentre digitandolo dal portatile ( dove è installata la stessa versione di Suse ) mi vengono dati questi errori

Thu Nov 16 15:37:56.835 2006:get_ifaddr_by_name: can't get interface address of eth0: Cannot assign requested address
Thu Nov 16 15:37:56.836 2006: can't get interface parameters for eth0 - giving up

quello che penso io è che il problema sta nel fatto che la lan nel pc è vista da suse come eth0 e non mi da errore mentre nel portatile la eth0 è assegnata alla rete wifi e la eth1 alla lan. Sapete dirmi se c'è un modo cambaire questi assegnamenti in modo da assegnare la eth0 alla lan e la eth1 alla wifi?
Oppure se pensate che non è questo il problema potete darmi una mano a risolverlo?

grazie mille

sacarde
16-11-2006, 21:55
credo che sia proprio questo il problema


leggi ti un po sulla creazione delle regole di Udev

"mi pare" si possa controllarlo il nome assegnato


p.s.
http://ftp.opensuse.org/pub/opensuse/distribution/SL-10.1/inst-source/docu/it/reference_it.pdf

mykol
16-11-2006, 22:44
prova a disattivare la rete wifi con l'apposito comando (non lo conosco perchè non ce l'ho, ma se fai qualche ricerca lo trovi di sicuro). Per spiegarmi meglio, se volessi disattivare la scheda ethernet darei il seguente comando

# ifconfig eth0 down

Caso mai rimuovi anche il driver della wifi dal file /etc/modules (o come si chiama in suse).
In sostanza, devi fare in modo che la wifi non venga vista, così la ethernet dovrebbe diventare eth0.

wozzek
17-11-2006, 08:01
ok ora provo con i consigli che mi avete dato
grazie

wozzek
17-11-2006, 19:28
tutto risolto!!
ho visto che il comando udpd ha come opzione quella di decidere su quale interfaccia lavorare e quindi ho scelto di lavorare sulla eth1 al posto della eth0 ed ho risolto il problema
grazie comunque del vostro aiuto

Loading