PDA

Visualizza la versione completa : [ASSEMBLY] Problemi compilazione con MASM32


UltraBeginner
28-11-2006, 17:21
Ciao a tutti,

sono passato ai primi rudimenti di assembly (il c++ puo aspettare :D ) e sto seguendo il tutorial sul sito http://www.giobe2000.it/tutorial/

qui per compilare usa il MASM che io pero non ho trovato...ho bensi trovail il MASM32....

ora immettendo il codice piu semplice che viene suggerito dal tutorial e cioe

_prog SEGMENT BYTE PUBLIC 'CODE'
ASSUME CS:_prog,DS:_prog
ORG 0100H
INIZIO: MOV AH,00H
MOV AL,03H
INT 10H
MOV AH,00H
INT 16H
MOV AH,4CH
INT 21H
_prog ENDS
END INIZIO

la compilazione non riesce in modo alcuno....il codice funzione perche ho scaricato il sorgente compilato dal sito e fa quello che deve fare....

voi che compilatori usate? sto cercando di utilizzare un certo xasm ma e alquanto criptico...

se usate masm32 riuscite a compilare correttamente il codice di sopra?

Saluti!!!! :ciauz: :ciauz: :ciauz:

Xaratroom
28-11-2006, 17:42
io uso tasm

UltraBeginner
28-11-2006, 17:44
E dove lo hai trovato? Mi daresti il link please?

Xaratroom
28-11-2006, 17:54
Il compilatore tasm non mai stato rilasciato dalla borland...

Xaratroom
28-11-2006, 17:56
Ho provato a compilartelo in tasm ma nn funziona neanche a me

Xaratroom
28-11-2006, 18:25
no mi sbagliavo funziona

UltraBeginner
29-11-2006, 11:09
Bhe meglio ke niente :D provo a cercare codesto tasm in internet!

Xaratroom
12-12-2006, 19:03
Mentre gironzolavo, in rete, ho trovato questo:

http://sourceforge.net/project/showfiles.php?group_id=6208

Vedi 1 po' se ti pu essere di aiuto
:bh:

Loading