PDA

Visualizza la versione completa : configurazione router cisco 1721


tatunni
21-12-2006, 09:39
salve,

avrei bisogno di configurare un router cisco mod. 1721 per l'adsl flat di telecomitalia.
Ho seguito la procedura che vi allego a seguito ma non ci sono riuscito. Qualche comando è diverso (interface ethernet 0 nel mio è interface fastethernet 0) e un comando non lo accetta (interface ATM 0). C'è da specificare che ho installato l'SDM prima sul pc poi visto che mi dava errore sull'immagine SDM del router l'ho installato anche li.Sono solo riuscito ad entrarci una volta (quando mi ha dato errore immagine SDM) poi niente più. Non lo riesco a pingare ne a raggiungerlo con il browser. Eppure avevo inserito l'ip router 192.168.1.1 e il mio pc 192.168.1.2 con getaway 192.168.1.1. Mi potete aiutare?

Grazie.



Il router Cisco 827 si configura tramite telnet utilizzando l'indirizzo IP del router oppure attraverso la porta console, se al router non è mai stato assegnato nessun indirizzo.
In caso di prima installazione proseguire come descritto di seguito.
Dopo aver acceso il router collegate il cavo console al vostro personal computer con emulazione di terminale (Hyper Terminal)
Al termine della fase di test il router si fermerà sul prompt:

Router>

Per poterlo configurare è necessario entrare nella modalità Enable, digitate sul prompt:

Router>enable

e premete il tasto INVIO sulla tastiera (dopo aver digitato un comando premere sempre il tasto INVIO).
A questo punto il router dovrebbe chiedere una password, ma se il router non è mai stato configurato in precedenza
non verrà richiesta nessuna password.
Il prompt cambierà da > a #

Router#

Entrate in configurazione terminale digitando:

Router#conf t

Apparirà il seguente prompt:

Router(config)#

Configurare l’interfaccia ethernet:

Router(config)#interface ethernet 0

Apparirà il seguente prompt:

Router(config -if)#

Assegnate un indirizzo IP all’interfaccia ethernet del router (es: 192.168.1.1).
Questo indirizzo IP dovrà essere scelto in funzione dell'indirizzamento della rete locale. All’indirizzo dovrà essere
associata una netmask (es: 255.255.255.0).

Router(config -if)#ip address 192.168.1.1 255.255.255.0

Rendete operativa l’interfaccia:

Router(config -if)#no shutdown

Per uscire dalla configurazione dell’interfaccia:

Router(config -if)#exit

Tornerete così al prompt:

Router(config)#

Sarà ora necessario eseguire la configurazione per Internet (Dialer + ATM).

CONFIGURAZIONE DEL DIALER
Entrate dunque sull’interfaccia di configurazione del Dialer.

Router(config)#interface dialer 0

Il prompt diventerà:

Router(config -if)#

Per configurare la negoziazione dell’indirizzo IP (se invece è stato richiesto un indirizzo statico inserire questo
indirizzo con la sua netmask, così come indicato nella configurazione dell’interfaccia ethernet), digitate:

Router(config -if)#ip address negotiated

Affinché l’interfaccia possa essere messa in contatto con la rete pubblica, digitate il seguente comando:

Router(config -if)#ip nat outside

Per la configurazione del protocollo di comunicazione con il POP, digitate:

Router(config -if)#encapsulation ppp

Per specificare quanti dialer pool utilizzare, digitate:

Router(config -if)#dialer pool 1

Per uscire dalla configurazione dell’interfaccia del dialer, digitate:

Router(config -if)#exit

CONFIGURAZIONE INTERFACCIA ATM
Per configurare l’interfaccia ATM, sempre dal prompt di configurazione, digitate:

Router(config)#interface ATM 0

Il prompt diventerà:

Router(config -if)#

Per configurare il circuito PVC, digitate:

Router(config -if)#pvc 8/35

In questo caso il prompt cambierà automaticamente e diventerà:

Router (config-atm-vc)#

Per configurare il tipo di incapsulamento dati che dovrà usare il circuito, digitate:

Router (config-atm-vc)#encapsulation aal5mux ppp dialer

Per specificare il dialer pool member (configurato in precedenza), digitate:

Router (config-atm-vc)#dialer pool-member 1

Per rendere operativa l’interfaccia, digitate:

Router (config-atm-vc)#no shutdown

Per uscire dal menù, digitate:

Router (config-atm-vc)#exit

CONFIGURAZIONE NAT
Per configurare il NAT per la rete locale, dal prompt:

Router (config)#

Per abilitare dinamicamente la traslazione degli indirizzi specificati nell’interfaccia del dialer, digitate:

Router (config)#ip nat inside source list 1 interface dialer 0 overload

Per impostare l’IP route dell’interfaccia di dialer come default Gateway (in questo modo tutto il traffico non
appartenente alla rete locale verrà automaticamente inviato all’interfaccia di dialer), digitate:

Router (config)#ip route 0.0.0.0 0.0.0.0 dialer 0

Per definire una ACCESS LIST che permetta agli indirizzi la traslazione(in questo esempio il riferimento all’indirizzo
privato usato in precedenza), digitate:

Router (config)#access-list 1 permit 192.168.1.0 0.0.0.255

Rientrate in configurazione sull’interfaccia ethernet, digitate:

Router (config)#interface ethernet 0

Apparirà il prompt:

Router (config-if)#

Digitate il seguente commando relativo alle funzionalità del NAT sull’interfaccia:

Router (config-if)#ip nat inside

Per abilitare l’interfaccia, digitate:

Router (config-if)#no shutdown

Infine, per uscire dalla configurazione, digitate:

Router (config-if)#exit

CONFIGURAZIONE DEI CODICI DI ACCESSO AL SERVIZIO
Per impostare la login e la password relative alla connessione, dovrete entrate nell’interfaccia del dialer.
Per accedere all’interfaccia di dialer, digitate:

Router (config)#int dialer 0

Per configurare la login, digitate:

Router (config-if)#ppp chap hostname xxxxxxx (dove xxxxxxx è la login)

Per configurare la password, digitate:

Router (config-if)#ppp chap password zzzzzzz (dove zzzzzzz è la password)

Sullo stesso prompt, attivate anche l'autenticazione PAP nel caso quella CHAP non avvenga con successo. Digitate:

Router (config-if)#ppp pap sent-username xxxxxxx password zzzzzzz

Per uscire dall’interfaccia di Dialer, digitate:

Router (config-if)#exit

IMPOSTAZIONE PASSWORD DI AMMINISTRATORE
Per inserire la password dell'amministratore (o di enable) del router, il comando da inserire è il seguente:

Router (config)#enable secret yyyyyyy (dove yyyyyyy è la password di amministratore che volete inserire)

E’ importante che la password non vada persa.

IMPOSTAZIONE PASSWORD DI TELNET
Prima di salvare tutto, è consigliabile impostare una password affinché si possa raggiungere il router anche tramite
telnet.
Partendo dal prompt:

Router (config)#

digitate:

Router (config)#line vty 0 4

Per impostare la password di telnet, digitate:

Router (config-line)#password kkkkkkk (dove kkkkkkk è la password di telnet che volete inserire)

Per attivare il comando, sempre sullo stesso prompt, digitate:

Router (config-line)#login

Per uscire dall'interfaccia di line, digitate:

Router (config-line)#exit

Per uscire dalla modalità di configurazione digitare exit o premete contemporaneamente i pulsanti CTRL e Z dalla
tastiera.

Router (config)#exit

Il prompt che vi apparira:

Router#

SALVATAGGIO DELLA CONFIGURAZIONE
Per salvare quanto fino a qui configurato sulla memoria permanente del router, scrivete il seguente comando:

Router#copy running-config startup-config

Vi verrà chiesto di confermare. Rispondete in modo affermativo (yes) e la configurazione verrà salvata.

magnet_80
23-12-2006, 11:51
questa è la conf di un 1721 coin bri di backup. la bri non la uso.
la conf è per l'adsl di libero 4MD con PPPoE

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 25
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
ip cef
!
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
no sh
!
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface FastEthernet0
ip address 192.168.123.254 255.255.255.0
ip nat inside
ip virtual-reassembly
speed auto
hold-queue 100 out
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
no cdp enable
ppp chap hostname username@provider
ppp chap password miapassword
ppp pap sent-username username@provider password miapassword
!
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 192.168.123.0 0.0.0.255
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

ciao e buone feste

tatunni
25-12-2006, 11:20
..ho combinato un pasticcio, con la procedura che avevo descritto in pratica non mi teneva la configurazione, e non accettava il comando "interface ATM o" poi su internet ho trovato una procedura per reinstallare l' SDM l'ho seguita solo che adesso il router non parte perchè non ha i files nella memory flash. Mi servirebbel' SDM versione 1.1 ma non la trovo e poi dovrei sapere come fare a reinstallare i files per far funzionare il router perchè quando accedo con telnet mi appare subito "rommon1>" e non procede (almeno io non so fare nulla).

magnet_80
25-12-2006, 12:05
http://www.cisco.com/en/US/products/hw/routers/ps221/products_installation_guide_chapter09186a008007e57 a.html

segui il link qui sopra. ti permette di settare il config register. qui trovi anche il manuale del 1721. oggi non posso aiutarti. comunque lo puoi recuperare. segui attentamente il link riportato qui sopra
ciao

tatunni
28-12-2006, 08:09
...niente, non sono riuscito a fare nulla, ecco cosa esce quando avvio il router (tramite telnet):



System Bootstrap, Version 12.2(7r)XM1, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 2001 by cisco Systems, Inc.
C1700 platform with 32768 Kbytes of main memory

loadprog: bad file magic number: 0x0
boot: cannot load "flash:"

System Bootstrap, Version 12.2(7r)XM1, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 2001 by cisco Systems, Inc.
C1700 platform with 32768 Kbytes of main memory





anche se faccio confreg 0x142 o altro non fa nulla.
aiutatemi.......
loadprog: bad file magic number: 0x0
boot: cannot load "flash:"

System Bootstrap, Version 12.2(7r)XM1, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 2001 by cisco Systems, Inc.
C1700 platform with 32768 Kbytes of main memory

rommon 1 >

Habanero
28-12-2006, 14:09
non è che in tutto quel macello hai cancellato anche IOS dalla flash?

tatunni
28-12-2006, 16:24
non ne ho idea, ho allegato quello che esce all'accensione del router che inserisco nuovamente:
System Bootstrap, Version 12.2(7r)XM1, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 2001 by cisco Systems, Inc.
C1700 platform with 32768 Kbytes of main memory

loadprog: bad file magic number: 0x0
boot: cannot load "flash:"

System Bootstrap, Version 12.2(7r)XM1, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 2001 by cisco Systems, Inc.
C1700 platform with 32768 Kbytes of main memory

loadprog: bad file magic number: 0x0
boot: cannot load "flash:"

System Bootstrap, Version 12.2(7r)XM1, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 2001 by cisco Systems, Inc.
C1700 platform with 32768 Kbytes of main memory

rommon 1 >

ho provato a fare confrek 0x142 e poi reset ma niente
io ho l'sdm 2.3, però quasi sicuramente ci vuole una versione più vecchia.
In pratica io ho cancellato tutti i files presenti nella directory "flash".
Ora come procedo?
Ho fatto danni irreversibili?
grazie.

tatunni
28-12-2006, 16:26
inserisco i veri passagi che ho fatto:

magnet_80
28-12-2006, 20:53
che culo!!!
ti devi ricaricare la flash via seriale a 9600. in pratica un paio d'ore di lavoro.
fai una ricerca sul sito della cisco su come ricaricare la flash via seriale. a memoria non me lo ricordo
MAI CANCELLARE LA DIR FLASH !!!
[: sarcastico] auguri di buon divertimento [:/sarcastico]

tatunni
29-12-2006, 09:24
lo so che ho un c...o pazzesco, scusa se te lo chiedo (non è per pigrizia ma per velocizzare) mi potresti dare un link.
In inglese me la cavicchio ma ci metterei una vita a trovare l'informazione che mi serve.

grazie.

Loading