PDA

Visualizza la versione completa : Applicazioni 3D OpenGL


mxa
22-12-2006, 23:08
Ubuntu 6.06
Driver ati presi dai repository.

E' normale che con i giochi 3D (Torcs, billard...) il processore mi sta al fisso al 100%?

GunMan
22-12-2006, 23:25
direi proprio di no, teoricamente anche con hardware non proprio recentissimo dovresti andare pi che liscio.

che scheda usi?

:ciauz:

mxa
22-12-2006, 23:30
ati x600

infatti quando avevo suse non mi pare che si comportasse cos, invece adesso con ubuntu lo fa.
Ma lo fa anche con glxgears, appena lo avvio il processore balza a 1.6GHz

GunMan
22-12-2006, 23:36
come scheda video sicuramente stai messo pi che bene per far andare un giochino del genere.

se anche glxgears ti da di questi problemi assai probabile che sia una questione di driver... potresti provare ad usare l'installer nella sezione driver di ati e usare quelli.

:ciauz:

GreyFox86
23-12-2006, 13:28
A me faceva cos quando il rendering hardware non era attivo e quindi demandava tutto il carico alla cpu...
solo un'idea ma prova a controllare:

$ glxinfo | grep direct

paolino_delta_t
23-12-2006, 14:03
in effetti al 99% il rendering hardware che disabilitato.....

a questo punto visto che hai usato i driver presenti sul sito ATI e non quelli forniti nel repo Ubuntu, pu essere andata storta l'installazione....

la prima cosa da fare digitare da riga di comando



lsmod | grep fglrx

e vedere se esce qualcosa di simile



fglrx 406988 8
agpgart 34888 2 fglrx,intel_agp


a questo punto se il driver fglrx attivo, devi verificare che sia presente nel file /etc/X11/xorg.conf

in pratica dev'esserci una cosa tipo



Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
EndSection


se c' "vesa" al posto di "fglrx" allora il driver non stato selezionato, probabilmente non hai eseguito aticonfig --initial

comunque se il driver proprietario attivo prova a digitare da riga di comando



glxinfo | grep direct


se esce "direct rendering: No" vuol dire che il rendering hardware demandato alla CPU tramite Mesa.....

a questo punto dovresti verificare cosa succede durante l'avvio di X cercando possibili errori in /var/log/Xorg.0.log

ad ogni modo ho notato ( non so se il tuo caso ) che da Xorg 7.0 in poi AIGLX viene attivato di default e questo causa il problema in questione.....

dovresti verificare sempre nel /etc/X11/xorg.conf se ci sono questi settaggi



Section "DRI"
Mode 0666
EndSection



Section "Extensions"
Option "Composite" "Disable"
EndSection




Section "ServerFlags"
Option "AIGLX" "off"
EndSection

mxa
23-12-2006, 14:26
i driver sono quelli dei repository, installati con la progedura dell'wiki. Il modulo fglrx caricato, il direct rendering attivo e questo xorg.conf:


Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Device"

# Driver "ati"
Identifier "ATI Technologies, Inc. Radeon X600 (RV380)"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. Radeon X600 (RV380)"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x768"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

paolino_delta_t
23-12-2006, 16:53
nel tuo xorg.conf manca



Section "Extensions"
Option "Composite" "Disable"
EndSection


il punto che i driver ATI non supportano il compositing con DRI

guardando il file /var/log/Xor.0.log dovrebbe darti proprio un errore relativo a questa cosa

mxa
23-12-2006, 17:40
ho aggiunto


Section "Extensions"
Option "Composite" "Disable"
EndSection


ma non cambiato nulla :(

gli unici errori nel log sono


max@max-laptop:~$ cat /var/log/Xorg.0.log |grep "Error"
Error opening /dev/wacom : Invalid argument
Error opening /dev/wacom : Invalid argument
Error opening /dev/wacom : Invalid argument
Error opening /dev/wacom : Invalid argument
Error opening /dev/wacom : Invalid argument
Error opening /dev/wacom : Invalid argument

mxa
24-12-2006, 13:43
up

Loading