PDA

Visualizza la versione completa : Strano malfunzionamento di X


denis76
04-01-2007, 23:11
Ho uno strano malfunzionamento.
Se guardo un film ogni 3 secondi circa sembra che il flusso video si fermi per un istante. Pensavo dipendesse dal fatto che non ho i driver che supportano l'accelerazione della mia scheda.
Il fatto che guardi il film a tutto schermo oppure con dimensione minima ininfluente.
Il problema che la cosa capita pure con il salvaschermo, eppure il processore del mio pc molto generoso.
Avete qualche idea? Non trovo particolari errori in nessun file di log.

n0t
04-01-2007, 23:33
con xine? usa kaffeine con il motore xine-lib.. e i driver o "opengl" o "fb"

GunMan
04-01-2007, 23:40
potresti comunque provare a fare qualche test, con glxgears magari specificando anche il tipo di scheda che hai.

prova a dare anche un glxinfo |grep rendering

:ciauz:

GreyFox86
04-01-2007, 23:54
In genere ho incontrato problemi di questo genere quando l'accelerazione hardware non era abilitata o quando non c'erano i driver migliori per la scheda.
Che tipo di scheda video hai?

Sachertorte
05-01-2007, 00:07
provare a fare qualche test, con glxgearsMa non c'era anche un parametro da passare a glxgear per avere gli FPS ?

Non lo trovo pi :cry:

GunMan
05-01-2007, 03:58
che io sappia non necessario inserire alcuna opzione particolare, lo stesso avviare glxgears restituisce gli fps della scheda per quel test.

:ciauz:

GreyFox86
05-01-2007, 12:14
confermo, lo lanci da consolle e lui ad intervalli regolari stampa fps ed altre info

mcz
05-01-2007, 14:16
glxgears -printfps

denis76
05-01-2007, 18:27
denis76@tomcat:~$ glxinfo |grep rendering
direct rendering: No
denis76@tomcat:~$

01:00.1 Display controller: ATI Technologies Inc RV370 [Radeon X300SE]

Che devo fare?

GreyFox86
05-01-2007, 18:37
Stando alla doc:

http://www2.ati.com/drivers/linux/linux_8.32.5.html

la tua scheda supportata... installa i driver proprietari ati fglrx

Loading