PDA

Visualizza la versione completa : accelerazione 3D


filo_a86
09-01-2007, 18:00
Ciao a tutti
ho un problema riguardante l'accelerazione 3d. La mia distro è ubuntu edgy cn una ATI MOBILITY RADEON x700...ho installato i driver correttamente tanto che quando faccio partire il comando "fglrxinfo" mi risponde :

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON X700 Generic
OpenGL version string: 2.0.6234 (8.32.5)

mentre se faccio "fgl_glxgears" :

Using GLX_SGIX_pbuffer
Xlib: extension "XFree86-DRI" missing on display ":1.0".
Error: couldn't get fbconfig

..io ho provato a reinstallare ma l'accelerazione 3d nn funziona ugualmente..da cosa potrebbe dipendere ?

Grazie

vortex87
09-01-2007, 19:18
Hai la riga

Load "dri"
nel file /etc/X11/xorg.conf?

trader#1
09-01-2007, 19:23
hai disabilitato composite....??


Section "Extensions"
Option "Composite" "Disable"
EndSection

Ciao ciao...

:ciauz:

filo_a86
09-01-2007, 20:32
Intanto grazie per l'aiuto..però il Module "dri" è presente...e composite è disabilitato...scusate se nn l'ho scritto prima ma io Xgl cel'ho già e funziona benissimo solo che non mi vanno i giochi proprio perchè nn c'è l'accelerazione 3D...io vi posto il mio xorg.conf :


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "it"
Option "XkbVariant" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 28.0 - 51.0
VertRefresh 43.0 - 60.0
Option "DPMS"
EndSection

Section "Device"
Identifier "ATI Technologies, Inc. Radeon Mobility X700 (RV410 PCIE)"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
BusID "PCI:2:0:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. Radeon Mobility X700 (RV410 PCIE)"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection

GRAZIEEEE !! :ciauz:

trader#1
09-01-2007, 20:36
hai provato ad usare i driver open...anzichè quelli proprietari.... ??

ciao ciao

filo_a86
09-01-2007, 20:59
sinceramente quando avevo la dapper usavo quelli e l'accelerazione funzionava...però con la edgy non ho mai provato...ma come faccio a rimuovere i driver proprietari ??

trader#1
09-01-2007, 21:12
bella domanda....non mi è mai capitato di doverlo fare....

probabilmente...con:

sudo dpkg-reconfigure xserver-xorg

e selezionando ati anzichè fglrx dovresti sistemare X e poi puoi installare i driver open....

non ti do la certezza....però :(

fai un backup del tuo xorg.conf e prova...

tentar non nuoce...

GunMan
09-01-2007, 21:13
non ho la tua stessa scheda ma pur sempre una ATI e i driver fanno spesso innervosire, secondo me potrebbe trattarsi di qualche impostazione mancante (o non specificata).

prova a inserire in questa sezione dello xorg.conf la seguente stringa, naturalmente prima esegui un backup del file


Section "Device"
Identifier "ATI Technologies, Inc. Radeon Mobility X700 (RV410 PCIE)"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
BusID "PCI:2:0:0"
EndSection



Option "no_accel" "no"


io avevo avuto un problema similare al tuo che risolsi in questo modo spero possa tornarti utile :)

:ciauz:

trader#1
09-01-2007, 21:44
dai un occhio qui...potrebbe esserti utile...

https://help.ubuntu.com/community/BinaryDriverHowto/ATI

:ciauz:

filo_a86
09-01-2007, 23:00
scusatemi tanto ma mi sono sbagliato fin dall'inizio...la cosa che non mi funziona è opengl direct rendering..mi scuso ancora :ciauz:

Loading