PDA

Visualizza la versione completa : Grub Problemino con Sata


oTTony
13-01-2007, 18:30
Ciao a Tutti !

Ho un piccolo problema che vorrei risolvere , con calma sto cercando di capire dove sbaglio , ho un HD sata su cui volevo clonare un sistema , per essere precisi una debian sid che ho su un HD ormai vecchio e piccolo , alch mi sono copiato la partizione con gost4linux e fin qui tutto ok , poi ho sistemato fstab e ho installato grub , con un chroot sulla partizione montata , durante l'installazione grub non d errori di sorta , poi quando do i comandi come sotto ricevo l'errore 15 :

grub> root (hd1,0)
Filesystem type is ext2fs, partition type 0x83

grub> setup (hd1)
Checking if "/boot/grub/stage1" exists... no
Checking if "/grub/stage1" exists... no

Error 15: File not found

Logicamente i file stage1 e stage2 sono presenti e i permessi di scrittura sono (sembrano) giusti , tantovero che se d un grub-update si aggiornano , a sto punto dopo millemila prove ho cambiato rotta ,mi son detto che ha sto disco ??? :nillio:
Con la solita calma mi sono messo a fare un installazione da nuovo su codesto HD , con una netinstall setto e partiziono senza errori , installo grub e non ricevo errori , il sistema l'ho tenuto all'osso per non perdere tempo , poi ho riavviato e il grub non viene trovato dal bios ... :master:

A questo punto preso dallo sconforto chiedo a voi , se mai successa una cosa del genere ?
Il controller sata integrato nella scheda madre e i dischi sata vengono riconosciuti dal kernel e li monto , smonto , scrivo ecc...
Qualcuno conosce qualche trucchetto , oppure ho trascurato qualche partiloare importante , bohh .E pensare che la settimana scorsa ho reinstallato grub senza problemi su una chiavetta usb ... :bh:

andy caps
13-01-2007, 18:50
se hai gia' grub sul disco con partizione attiva non serve grub nel sata
quello ti servebbe se tu staccassi il master

dovrebbe bastare aggiungere una voce a menu.lst attuale per caricarla

oTTony
14-01-2007, 11:49
Ehh , forse non mi sono spiegato bene , proprio quello che voglio staccare il master per rendere attivo il sistema sul disco sata , ma non capisco per quale motivo sul quel sata il grub non si installi , guarda ho provato in molti modi ma nulla da fare .
Certo lo s che se configuro il grub per lanciare il sistema su dico sata funziona , ma dopo volevo eliminare il disco primario , che tra l'altro un disco scsi su un controller pci , sono due pezzi un p vecchi e vorrebbero pensionati o usati su sistemi non importanti .
Ma ho il brutto presentimento che dovr rimettere in piedi il sistema da nuovo ... :incupito:

andy caps
14-01-2007, 12:08
puoi provare a staccare il disco e farlo da una live

controllando magari device.map in /boot/grub che riporta i dischi presenti e fstab in base a cosa dice fdisk -l dopo avere staccato il disco

Loading