PDA

Visualizza la versione completa : Nuovo server dhcp


moskitoita
27-01-2007, 19:37
Salve, devo montare un server dhcp in una rete che attualmente usa un modem alice gate con server dhcp incluso.
Ho quindi disattivato il server dhcp e il nat del router. Ma ora se imposto un indirizzo statico e uso come gateway l'indirizzo del router non mi pinga nessun ip esterno

Consigli??? :cry:

fbracal
27-01-2007, 23:56
Hai assegnato i valori corretti dei DNS?

moskitoita
28-01-2007, 10:09
si, si, ma il fatto è che non riesco neppure a pingarli :cry:

P.s.
Una domanda non legata al problema: è normale che un ip 192,168.1.x non veda un 192.168.0.x?

fbracal
28-01-2007, 10:45
Originariamente inviato da moskitoita
P.s.
Una domanda non legata al problema: è normale che un ip 192,168.1.x non veda un 192.168.0.x?
Sì, è normale se non hai impostato route aggiuntive sul router.
Mi viene il sospetto che tu abbia impostato il router su indirizzo tipo 192.168.1.x e i PC con indirizzi 192.168.0.x, se è così non si vedranno mai.
Puoi per favore postare l'output del comando ipconfig /all e la configurazione del router per la parte LAN e DHCP?
Un'altra cosa dici di aver tolto anche il NAT, a cosa ti serviva di preciso?

moskitoita
28-01-2007, 11:08
Originariamente inviato da fbracal
Sì, è normale se non hai impostato route aggiuntive sul router.
Mi viene il sospetto che tu abbia impostato il router su indirizzo tipo 192.168.1.x e i PC con indirizzi 192.168.0.x, se è così non si vedranno mai.
Puoi per favore postare l'output del comando ipconfig /all e la configurazione del router per la parte LAN e DHCP?
Un'altra cosa dici di aver tolto anche il NAT, a cosa ti serviva di preciso?

No, il router ha indirizzo 192.168.1.1 e i client 192.168.1.x (il problema era con una stampante: 192.168.0.200 a cui ora cambierò indirizzo).
Non sono fisicamente lì quindi non ti do l'output del comando però ricordo perfettamente le impostazioni:
Per i client:
ip 192.168.1.x
netmask 255.255.255.0
gateway 192.168.1.1
dns (quello preso dal router)

per il router:
dhcp disabilitato
nat disabilitato
ip 192.168.1.1
netmask 255.255.255.0


Ho dato un'occhiata alla pagina di wikipedia sul nat, lo avevo disabilitato perchè lo credevo collegato al problema degli ip; comunque sia abilitato sia disabilitatoi il problema permane: non riesco a pingare nessun ip esterno.

:master:

fbracal
28-01-2007, 11:22
Hai la possibilità di lanciare un ping direttamente dal router?
Ovviamente avrai provato anche a fare un tracert su un indirizzo esterno, ti si ferma subito?
Una volta ho avuto un problema simile, togliendo il DHCP non uscivo più verso l'esterno, in quel caso un semplice reset del router mi risolse la situazione.

moskitoita
28-01-2007, 12:10
Non ho possibilità di lanciare alcun comando dal router( è quello telecom, mai vista una cosa più brutta)
Non ho provato a tracciare un indirizzo esterno perchè so che dal router in poi è tutto ok (se attivo il dhcp i client funzionano)
Il problema effettivamente sembra essere uguale al tuo, ma io devo a tutti i costi disattivare il dhcp :cry:

s|n3
28-01-2007, 22:44
attiva il DHCP, accendi un PC, vedi che ip gli viene assegnato, impostalo come IP fisso per quel PC, disattiva il DHCP e vedi se quel pc continua a navigare.

DEVE funzionare ugualmente perchè il DHCP, una volta assegnato l'ip da un client, non interviene in nessun altro modo.

potrebbe essere abilitata la navigazione verso l'esterno dei soli ip nel pool a disposizone del DHCP (molto strano comunque)...fa anche firewalling il router?

moskitoita
28-01-2007, 23:19
Non credo funga da firewall è un modem alice gate della telecom; proverò ma ho già fatto un cosa simile con risultati negativi

Loading