PDA

Visualizza la versione completa : Il software modem ha occupato tutte le risorse audio [Ubuntu 6.10]


Kirk
29-01-2007, 19:12
Salve,
configurando il software modem ATI ho potuto poi riscontrare che il sistema ha perduto il controllo delle altre funzioni della scheda audio.
L'interfaccia grafica sotto Sistema/preferenze/audio da dei messaggi di errore dicendo che la risorsa occupata.
Cosa posso fare? Se volete posso continuare a definire una diagnostica con il vostro aiuto.

Ciao e grazie anticipate :ciauz:

andy caps
29-01-2007, 20:43
puoi provare a scaricare il driver audio del modem

sudo modprobe -r snd-atiixp-modem
( cosi scarichi momentaneamente il driver audio del modem )

poi dare un sudo /etc/init.d/alsa reload
sudo /etc/init.d/alsa-utils restart

:bh: in teoria il driver snd-atiixp-modem doveva servire a fare funnzionare parte del software modem ma se va solo con i driver smartlink magari risolvi

incolla magari un sudo lspci che ci dice la scheda audio che hai

Kirk
29-01-2007, 21:42
Grazie :)

Ecco i risultati:

$ sudo modprobe -r snd-atiixp-modem
FATAL: Module snd_atiixp_modem is in use.

$ sudo /etc/init.d/alsa reload
sudo: /etc/init.d/alsa: command not found

$ sudo /etc/init.d/alsa-utils restart
* Shutting down ALSA... [ ok ]
* Setting up ALSA... [ ok ]

$ lspci
00:00.0 Host bridge: ATI Technologies Inc R200 AGP Bridge [Mobility Radeon 7000 IGP] (rev 05)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 340M]
00:13.0 USB Controller: ATI Technologies Inc OHCI USB Controller #1 (rev 01)
00:13.1 USB Controller: ATI Technologies Inc OHCI USB Controller #2 (rev 01)
00:13.2 USB Controller: ATI Technologies Inc EHCI USB Controller (rev 01)
00:14.0 SMBus: ATI Technologies Inc ATI SMBus (rev 18)
00:14.1 IDE interface: ATI Technologies Inc ATI Dual Channel Bus Master PCI IDE Controller
00:14.3 ISA bridge: ATI Technologies Inc Unknown device 434c
00:14.4 PCI bridge: ATI Technologies Inc Unknown device 4342
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC'97 Audio Controller
00:14.6 Modem: ATI Technologies Inc IXP AC'97 Modem (rev 01)
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility 7000 IGP
02:04.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
02:06.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
02:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:0a.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000 Controller (PHY/Link)

Adesso per funziona, dopo che ho cambiato le impostazioni in Sistema/Preferenze/Audio.
Tuttavia non funziona la cattura.

:dh:

Kirk
29-01-2007, 21:59
Pardon,
funziona anche la cattura.
Tutto a posto allora, anche se mi domando di quegli errori...

Grazie infinite :ciauz:

andy caps
30-01-2007, 00:05
probabilmente ubuntu ha /etc/init.d/alsa-base restart non alsa
se va tutto comunque lascialo stare
il driver audio comunque snd-atiixp se dovesse servire

Loading