PDA

Visualizza la versione completa : libreria lua


alexthemaster
31-01-2007, 14:42
ciao a tutti quando compilo il plugins lua mi dice questo quando il il ./configure


checking for lua headers...
checking lua.h usability... no
checking lua.h presence... no
checking for lua.h... no
checking lua50/lua.h usability... no
checking lua50/lua.h presence... no
checking for lua50/lua.h... no
configure: error: Please install the lua library headers (lua.h and lualib.h) before trying to install lua plugin.


come lo risolvo?


grazie

andy caps
31-01-2007, 14:44
devi usare apt per trovare le librerie

apt-cache search lua

poi installare i -dev di liblua

alexthemaster
31-01-2007, 14:49
quele mi consigli?


liblua40 - Main interpreter library for the Lua 4.0 programming language
liblua40-dev - Main interpreter library for lua40: static library and headers
liblua50 - Main interpreter library for the Lua 5.0 programming language
liblua50-dev - Main interpreter library for Lua 5.0: static library and headers
liblualib40 - Extension library for the Lua 4.0 programming language
liblualib40-dev - Extension library for Lua 4.0: static and headers
liblualib50 - Extension library for the Lua 5.0 programming language
liblualib50-dev - Extension library for Lua 5.0: static and headers

a me servono i file

configure: error: Please install the lua library headers (lua.h and lualib.h) before trying to install lua plugin.


grazie

francofait
31-01-2007, 14:50
Installando le relative liblua di cui ha bisogno

apt_-get install liblualib50 liblualib50-dev

andy caps
31-01-2007, 14:51
installa liblualib50-dev liblua50-dev

poi la trova

i -dev in genere mettono gli headers della libreria
poi il configure la puo' usare

alexthemaster
31-01-2007, 14:52
ok grazie mille ^^

scusate se sto rompendo tanto sti giorni ma ho preso un server da 0 e mi ci sto montando tutto e sto quasi diventando pazzo XD per ora mi manca poco alla fine altre 2 orette di lavoro :dh:

GunMan
31-01-2007, 14:52
ciao, se non erro i devel di lua dovrebbero bastare.


Package: lua-devel
Section: Development/Libraries/C and C++
Installed Size: 236151
Maintainer: http://bugs.opensuse.org
Version: 5.0.2-15
Pre-Depends: rpmlib(PayloadFilesHavePrefix) (<= 4.0-1), rpmlib(CompressedFileNames) (<= 3.0.4-1), rpmlib(PayloadIsBzip2) (<= 3.0.5-1)
Depends: lua (= 5.0.2)
Provides: lua-devel (= 5.0.2-15)
Architecture: i586
Size: 78013
MD5Sum: 0a377cd6503f4b63c006d03af24186ca
Filename: lua-devel-5.0.2-15.i586.rpm
Description: Development files for lua
Lua is a programming language originally designed for extending
applications, but also frequently used as a general-purpose,
stand-alone language.

This package contains files needed for embedding lua into your
application.


:ciauz:

Loading