PDA

Visualizza la versione completa : [ATI-DEBIAN-2.6.19] problema installazione del modulo del kernel fglrx


iDleR
31-01-2007, 17:27
ho scaricato gli ultimi driver dal sito ufficiale di ati, poi ho fatto in questo modo:



sh ./ati-driver-installer-8.32.5-x86.x86_64.run --buildpkg Debian/etch

dpkg -i fglrx-*.deb

module-assistant prepare

module-assistant update

module-assistant a-i fglrx


a questo punto il dramma incombe perché non va a buon fine la compilazione del modulo per questo errore:



/usr/bin/make -C /lib/modules/2.6.19.2-sucs/source ↑
│ SUBDIRS=/usr/src/modules/fglrx modules ▒
│ make[1]: Entering directory `/usr/src/linux-2.6.19.2' ▒
│ CC [M] /usr/src/modules/fglrx/firegl_public.o ▒
│ /usr/src/modules/fglrx/firegl_public.c:89:26: error: linux/config.h: No ▒
│ such file or directory ▒
│ /usr/src/modules/fglrx/firegl_public.c:456: warning: initialization from ▒
│ incompatible pointer type ▒
│ /usr/src/modules/fglrx/firegl_public.c: In function ‘firegl_stub_open’: ▒
│ /usr/src/modules/fglrx/firegl_public.c:579: warning: assignment discards ▮
│ qualifiers from pointer target type ▒
│ /usr/src/modules/fglrx/firegl_public.c: In function ‘__ke_request_irq’: ▒
│ /usr/src/modules/fglrx/firegl_public.c:2568: warning: passing argument 2 ▒
│ of ‘request_irq’ from incompatible pointer type
(bla bla)


se non vado errato questa riga qua è il dramma:


│ /usr/src/modules/fglrx/firegl_public.c:89:26: error: linux/config.h: No ▒
│ such file or directory

dato che suppongo che quel file è deprecated. Come risolvo?

andy caps
31-01-2007, 19:40
controlla di avere installati gli headers corretti del kernel e magari disinstalla gli altri

:bhò: anche il kernel 2.6.19 non è il massimo per i driver proprietari
io sulla sid per stare tranquillo uso il 2.6.18-3 che mette di default

iDleR
31-01-2007, 20:06
è uscito l'8.33 che risolve i problemi col 2.6.19 ma non riesco a trovare il download per l'x86

andy caps
31-01-2007, 20:18
http://ati.amd.com/support/drivers/linux/linux-radeon.html

dovrebbe essere questo :bhò:

iDleR
01-02-2007, 12:19
sì grazie, è sbagliato il mirror per le mobility, cmq poi ho installato quello ed ho risolto tutto :)

Loading