PDA

Visualizza la versione completa : connessione internet


elyfiora
06-02-2007, 18:57
Ciao a tutti!!!!! Io ho un pc portatile con installato mandriva e vorrei configurare l'accesso ad internet ma non ne sono capace. Premetto che sono totalmente ignorante in merito.
La connessione è di tipo adsl con fastweb.
In windows, quando attacco il cavo dal modem al pc, non devo effettuare nessuna connessione perchè automaticamente si trova in internet.
Con mandriva invece le pagine web non si aprono.
Non ho nessun cd di installazione del modem.
Come posso fare? C'è qualcuno che mi può aiutare?
Grazie, Elisa

spqr
06-02-2007, 19:00
Dovresti specificare che tipo di modem hai, se USB oppure ethernet.
Li distingui dall'attacco: se è come un plug-in di un telefono, allora è ethernet.

elyfiora
06-02-2007, 19:04
l'attacco è come quello del telefono-.......

elyfiora
06-02-2007, 19:11
l'attacco è come quello del telefono-.......

spqr
06-02-2007, 22:53
Purtroppo al momento non ho mandriva sotto mano e non posso essere molto preciso nè essere sicuro che questo sia il tuo problema.

A volte mi è capitato di dover impostare manualmente i DNS per potermi connettere. Per fastweb guardando in rete dovrebbero essere:
DNS1 » 213.140.2.12
DNS2 » 213.140.2.21
(prova anche 1.70.140.222 come DNS1 se i primi due non vanno)
(come "nome dominio" metti fastwebnet.it)

Prova ad aprire il "Centro di Controllo Mandriva" e trovare il modo di impostare questi due DNS in impostazioni di rete, della scheda di rete o impostazioni di connessione.
Controlla anche che sia attivo "dhcp per l'ottenimento dell'IP in automatico".

Per essere sicura che le modifiche siano state applicate, riavvia il servizio dal terminale con /etc/rc.d/init.d/network restart

elyfiora
06-02-2007, 23:12
Ciao, sono andata nella sezione Centro di Controllo Mandriva e ho aperto la sezione Network. Se gli dico di configurare una nuova connessione e seleziono la modalità ADSL, mi si presentano una serie di opzioni tra le quali: DHCP e PPPoE. Ho provato selezionando la seconda e mi chiede i dati dei DNS, ho inserito quelli che mi hai detto tu, riavviando il pc come mi hai detto ma niente. Ho provato anche selezionando DHCP, in questo modo non mi chiede i DNS ma solo il nome del dominio ma non va nulla neanche così...... :bhò:

GunMan
06-02-2007, 23:20
vediamo se c'è già qualcosa di attivo...

prova a dare da console, con i privilegi di root


ifconfig eth0

e postane l'output :)

:ciauz:

elyfiora
06-02-2007, 23:47
Fatto....... :)
L'output è il seguente:

eth0 Link encap:Ethernet HWaddr 00:03:0D:1D:54:A0
inet6 addr: fe80::203:dff:fe1d:54a0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:80 errors:0 dropped:0 overruns:0 frame:0
TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6062 (5.9 Kb) TX bytes:378 (378.0 b)
Interrupt:19 Base address:0xd800

:ciauz:

GunMan
06-02-2007, 23:57
prova a dare, sempre con i privilegi di root


dhclient eth0

:ciauz:

elyfiora
07-02-2007, 00:06
Funziona!!!!!!!!!!!!!!!!!!! :) :) :) :) :) :) :)
Cavolo grazie mille!!!!!!
Posso approfittarne di te chiedendoti un'altra cosa? :) Tra un po' quelli di fastweb mi dovrebbero portare il kit per il wireless...a quel punto connettermi ad internet sarà un problema? Devo fare qualcos'altro oppure andrà tranquillamente?
Grazie di nuovo!
:ciauz:

Loading