PDA

Visualizza la versione completa : [Debian] ati open source e accelerazione 3D


Tigre851
06-02-2007, 19:08
Ciao, Ŕ da qualche giorno che st˛ andando via di testa perchŔ con i driver open source della ati (ho una mobility radeon 9700) non riesco a far partire l'accelerazione 3D. vi posto le sezioni salienti del mio xorg.conf:


Section "Module"
Load "dbe"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "radeon"
Option "XAANoOffscreenPixmaps" "true"
Option "DRI" "true"
Option "GARTSize" "64"
Option "AGPMode" "4"
Option "ColorTiling" "1"
Option "AGPSize" "128"
Option "AccelMethod" "XAA"
Option "AccelDFS" "0"
Option "EnablePageFlip" "true"
Option "RenderAccel" "true"
Option "EnableDepthMoves" "true"
Option "DPMS" #support for VESA's Display Power Management Specification
Option "DynamicClocks" "on" # problems on latest git - disable with glitches
EndSection



qualche suggerimento? grazie!

bereshit
06-02-2007, 21:09
i driver opensource della ati fanno funzionare anche il 3d? ma sono quelli di xorg?

(per curiositÓ..sono empre stato un utente nvidia)

SpArDa_II
06-02-2007, 21:50
Si, con i driver radeon puoi far andare l'accellerazione 3d! Devi per˛ caricare i moduli drm e radeon.

Tigre851
07-02-2007, 00:05
ok ho caricato i moduli radeon e drm ma ancora nessuna accelerazione 3d, ho inoltre rmodificato lo xorg.conf perchŔ mi crashava ogni tanto, ve lo riposto modificato:



Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
Load "drm"
Load "radeon"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "ati"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
EndSection



infatti dando un glxinfo | grep direct ottengo:
direct rendering: No

grazie ancora

GunMan
07-02-2007, 00:32
prova a reinserire questa opzione nella section device della scheda

Option "RenderAccel" "true"

:ciauz:

Loading