PDA

Visualizza la versione completa : [debian etch] Apache e mysql


iox84
09-02-2007, 00:40
Salve a tutti.
Ho installato debian etch (amd64) e mi servono mysql e apache2 + php5. Dopo aver eseguito il classico apt-get install nomepacchetto controllo il funzionamento di apache via browser e no va. Allora ho eseguito un


netstat -anp|grep :80

Che mi restituisce


tcp6 0 0 :::80 :::* LISTEN 22816/apache2

Quel 6 li significa ipv6? E se si come faccio a far partire apache in ipv4?
Mysql invece fallisce miseramente l'avvio del demone in fase di installazione con in seguente errore:


Configuro mysql-server-5.0 (5.0.32-3) ...
Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: errore processando mysql-server-5.0 (--configure):
il sottoprocesso post-installation script ha restituito un codice di errore 1
Sono occorsi degli errori processando:
mysql-server-5.0
E: Sub-process /usr/bin/dpkg returned an error code (1)


Sapreste aiutarmi?
Ciao e grazie...

iox84
10-02-2007, 10:00
1 - Per quanto riguarda apache, bastava solo attivare l'interfaccia di rete di loopback :fagiano:
2 - Per quanto riguarda mysql pochi minuti fa ho eseguito i seguenti comandi:


develop:~# apt-get install mysql-common
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
mysql-common gi alla versione pi recente.
0 aggiornati, 0 installati, 0 da rimuovere e 19 non aggiornati.
develop:~# apt-get install mysql-server
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
I seguenti pacchetti verranno inoltre installati:
mysql-server-5.0
Pacchetti suggeriti:
tinyca
I seguenti pacchetti NUOVI (NEW) saranno installati:
mysql-server mysql-server-5.0
0 aggiornati, 2 installati, 0 da rimuovere e 19 non aggiornati.
necessario prendere 0B/25,9MB di archivi.
Dopo l'estrazione, verranno occupati 71,5MB di spazio su disco.
Continuare [S/n]? S
Preconfigurazione dei pacchetti in corso
Selezionato il pacchetto mysql-server-5.0, che non lo era.
(Lettura del database ... 76554 file e directory attualmente installati.)
Spacchetto mysql-server-5.0 (da .../mysql-server-5.0_5.0.32-3_amd64.deb) ...
Selezionato il pacchetto mysql-server, che non lo era.
Spacchetto mysql-server (da .../mysql-server_5.0.32-3_all.deb) ...
Configuro mysql-server-5.0 (5.0.32-3) ...
Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld.
Checking for corrupt, not cleanly closed and upgrade needing tables..

Configuro mysql-server (5.0.32-3) ...


Quindi funziona :bh:

Loading