PDA

Visualizza la versione completa : touchpad su acer travelmate


sacarde
10-02-2007, 16:55
ciao,
su questo ormai vecchio portatile con sopra CENTOS non funziona il
touchpad.....
dopo qualche ricerca ho letto di eseguire:

gpm -k
gpm -m imps2 -t /dev/mouse

ma al secondo comando ho l'errore:

O0o.oops(): server_tools.c(76): could not open imps2

p.s.
il fatto e' che non capisco e non vedo il device del touchpad....
non lo dovrei trovare nel dmesg ?
o usa lo stesso device del mouse... in questo caso /dev/input/mice ???

grazie mille

sacarde
11-02-2007, 09:53
qualcuno ha un portatile ?

per favore mi dite se il dispositivo del mouse e' lo stesso del touchpad ?

grazie

mykol
11-02-2007, 11:33
sul mio HP dmesg mi da, tra l'altro queste righe

mice: PS/2 mouse device common for all mice
e
Synaptics Touchpad, model: 1, fw: 5.8, id: 0x1d48b1, caps: 0x904713/0x4006
input: SynPS/2 Synaptics TouchPad as /class/input/input1
input: HID 1241:1166 as /class/input/input2
input: USB HID v1.10 Mouse [HID 1241:1166] on usb-0000:00:1d.0-1

lsusb

root@Knoppix:/home/giorgio# lsusb
Bus 001 Device 002: ID 1241:1166 Belkin


lspci

non dice nulla d'interessante

in /etc/X11/xorg.conf

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
# PS/2 Mouse not detected
# Serial Mouse not detected
InputDevice "USB Mouse" "CorePointer"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"

Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "SendCoreEvents" "true"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"

ho un mouse usb.

Del touchpad non c'è traccia, eppure funziona perfettamente assieme al mouse

sacarde
11-02-2007, 11:43
e poi dentro xorg.conf

cosa hai come device per mouse e touchpad?

mykol
11-02-2007, 12:33
questo è il mio xorg.conf (ho solo eliminato delle modeline perchè era troppo lungo ...)

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
# PS/2 Mouse not detected
# Serial Mouse not detected
InputDevice "USB Mouse" "CorePointer"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "true"

EndSection

Section "Files"
RgbPath "/usr/share/X11/rgb"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc:unscaled"
FontPath "/usr/share/fonts/X11/75dpi:unscaled"
FontPath "/usr/share/fonts/X11/100dpi:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/Speedo"
FontPath "/usr/share/fonts/X11/PEX"
# Additional fonts: Locale, Gimp, TTF...
FontPath "/usr/share/fonts/X11/cyrillic"
# FontPath "/usr/share/fonts/X11/latin2/75dpi"
# FontPath "/usr/share/fonts/X11/latin2/100dpi"
# True type and type1 fonts are also handled via xftlib, see /etc/X11/XftConfig!
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/latex-ttf-fonts"
EndSection

Section "Module"
# Comments: see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=346408
Load "dbe" # Double Buffering Extension, very important.
Load "dri" # This shouldn't be available choice if user has selected driver vga, vesa or nv.
Load "glx" # GLX Extension.
Load "freetype" # Freetype fonts.
Load "type1" # Type 1 fonts
Load "record" # Developer extension, usually not needed
# Load "extmod" # This is okay, but if you look into "man xorg.conf" you'll find option NOT to include DGA extension with extmod, and for a good reason.. DGA causes instability as it access videoram without consulting X about it.
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
# Load "speedo" # Speedo fonts, this module doesn't exist in Xorg 7.0.17
# The following are deprecated/unstable/unneeded in Xorg 7.0
# Load "ddc" # ddc probing of monitor, this should be never present, as it gets automatically loaded.
# Load "GLcore" # This should be never present, as it gets automatically loaded.
# Load "bitmap" # Should be never present, as it gets automatically loaded. This is a font module, and loading it in xorg.conf makes X try to load it twice.
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"

EndSection

Section "InputDevice"
Identifier "Serial Mouse"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/ttyS0"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
EndSection

Section "InputDevice"
Identifier "PS/2 Mouse"
Driver "mouse"
Option "Protocol" "auto"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
EndSection

Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "SendCoreEvents" "true"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection

# Auto-generated by KNOPPIX mkxf86config

Section "Monitor"
Identifier "Monitor0"
Option "DPMS" "true"
# HorizSync 28.0 - 78.0 # Warning: This may fry very old Monitors
HorizSync 28.0 - 96.0 # Warning: This may fry old Monitors
VertRefresh 50.0 - 75.0 # Very conservative. May flicker.
# VertRefresh 50.0 - 62.0 # Extreme conservative. Will flicker. TFT default.
# Default modes distilled from
# "VESA and Industry Standards and Guide for Computer Display Monitor
# Timing", version 1.0, revision 0.8, adopted September 17, 1998.
# $XFree86: xc/programs/Xserver/hw/xfree86/etc/vesamodes,v 1.4 1999/11/18 16:52:17 tsi Exp $
# 640x350 @ 85Hz (VESA) hsync: 37.9kHz
ModeLine "640x350" 31.5 640 672 736 832 350 382 385 445 +hsync -vsync
# 640x400 @ 85Hz (VESA) hsync: 37.9kHz
ModeLine "640x400" 31.5 640 672 736 832 400 401 404 445 -hsync +vsync
# 720x400 @ 85Hz (VESA) hsync: 37.9kHz
ModeLine "720x400" 35.5 720 756 828 936 400 401 404 446 -hsync +vsync
# 640x480 @ 60Hz (Industry standard) hsync: 31.5kHz
ModeLine "640x480" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
# 640x480 @ 72Hz (VESA) hsync: 37.9kHz
ModeLine "640x480" 31.5 640 664 704 832 480 489 491 520 -hsync -vsync
# 640x480 @ 75Hz (VESA) hsync: 37.5kHz
ModeLine "640x480" 31.5 640 656 720 840 480 481 484 500 -hsync -vsync
# 640x480 @ 85Hz (VESA) hsync: 43.3kHz
ModeLine "640x480" 36.0 640 696 752 832 480 481 484 509 -hsync -vsync
# 800x600 @ 56Hz (VESA) hsync: 35.2kHz
ModeLine "800x600" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
# 800x600 @ 60Hz (VESA) hsync: 37.9kHz
ModeLine "800x600" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
# 800x600 @ 72Hz (VESA) hsync: 48.1kHz
ModeLine "800x600" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
# 800x600 @ 75Hz (VESA) hsync: 46.9kHz
ModeLine "800x600" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
# 800x600 @ 85Hz (VESA) hsync: 53.7kHz
ModeLine "800x600" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
# 1024x768i @ 43Hz (industry standard) hsync: 35.5kHz
ModeLine "1024x768" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync +vsync Interlace
# 1024x768 @ 60Hz (VESA) hsync: 48.4kHz
ModeLine "1024x768" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
# 1024x768 @ 70Hz (VESA) hsync: 56.5kHz
ModeLine "1024x768" 75.0 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
# 1024x768 @ 75Hz (VESA) hsync: 60.0kHz
ModeLine "1024x768" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
# 1024x768 @ 85Hz (VESA) hsync: 68.7kHz
ModeLine "1024x768" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
# 1152x864 @ 75Hz (VESA) hsync: 67.5kHz
ModeLine "1152x864" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
# 1280x960 @ 60Hz (VESA) hsync: 60.0kHz
ModeLine "1280x960" 108.0 1280 1376 1488 1800 960 961 964 1000 +hsync +vsync
# 1280x960 @ 85Hz (VESA) hsync: 85.9kHz
ModeLine "1280x960" 148.5 1280 1344 1504 1728 960 961 964 1011 +hsync +vsync
# 1280x1024 @ 60Hz (VESA) hsync: 64.0kHz
ModeLine "1280x1024" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
# 1280x1024 @ 75Hz (VESA) hsync: 80.0kHz
ModeLine "1280x1024" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
# 1280x1024 @ 85Hz (VESA) hsync: 91.1kHz
# ModeLine "1280x1024" 157.5 1280 1344 1504 1728 1024 1025 1028 1072 +hsync +vsync
Modeline "1280x1024" 157.50 1280 1328 1488 1728 1024 1025 1028 1072 +hsync +vsync
# 1600x1200 @ 60Hz (VESA) hsync: 75.0kHz
ModeLine "1600x1200" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
# 1600x1200 @ 65Hz (VESA) hsync: 81.3kHz
ModeLine "1600x1200" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
# 1600x1200 @ 70Hz (VESA) hsync: 87.5kHz
ModeLine "1600x1200" 189.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
# 1600x1200 @ 75Hz (VESA) hsync: 93.8kHz
ModeLine "1600x1200" 202.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
# 1600x1200 @ 85Hz (VESA) hsync: 106.3kHz
ModeLine "1600x1200" 229.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
# 1792x1344 @ 60Hz (VESA) hsync: 83.6kHz
ModeLine "1792x1344" 204.8 1792 1920 2120 2448 1344 1345 1348 1394 -hsync +vsync
# 1792x1344 @ 75Hz (VESA) hsync: 106.3kHz
ModeLine "1792x1344" 261.0 1792 1888 2104 2456 1344 1345 1348 1417 -hsync +vsync
# 1856x1392 @ 60Hz (VESA) hsync: 86.3kHz
ModeLine "1856x1392" 218.3 1856 1952 2176 2528 1392 1393 1396 1439 -hsync +vsync
# 1856x1392 @ 75Hz (VESA) hsync: 112.5kHz
ModeLine "1856x1392" 288.0 1856 1984 2208 2560 1392 1393 1396 1500 -hsync +vsync
# 1920x1440 @ 60Hz (VESA) hsync: 90.0kHz
ModeLine "1920x1440" 234.0 1920 2048 2256 2600 1440 1441 1444 1500 -hsync +vsync
# 1920x1440 @ 75Hz (VESA) hsync: 112.5kHz
ModeLine "1920x1440" 297.0 1920 2064 2288 2640 1440 1441 1444 1500 -hsync +vsync

EndSection

Section "Device"
### Available Driver options are:-
# sw_cursor is needed for some ati and radeon cards
Option "sw_cursor"
#Option "hw_cursor"
#Option "NoAccel"
#Option "ShowCache"
#Option "ShadowFB"
#Option "UseFBDev"
#Option "Rotate"
Identifier "Card0"
# The following line is auto-generated by KNOPPIX mkxf86config
Driver "ati"
VendorName "All"
BoardName "All"
# BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultColorDepth 16
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

mykol
11-02-2007, 12:37
credo che usi lo stesso device del mouse, perchè in xorg non compare

non so se ha un modulo particolare caricato

ecco il mio lsmod (dovrò ripulirlo un pò, ho parecchia roba che non c'entra nulla)

giorgio@Knoppix:~$ lsmod
Module Size Used by
bluetooth 47460 0
radeon 109600 2
drm 62228 3 radeon
nfs 208476 0
nfsd 210180 17
exportfs 8576 1 nfsd
lockd 56296 3 nfs,nfsd
nfs_acl 6912 2 nfs,nfsd
sunrpc 132260 13 nfs,nfsd,lockd,nfs_acl
ipx 30884 0
p8023 5504 1 ipx
autofs4 20740 1
capifs 7944 1
ppp_generic 26772 0
slhc 10112 1 ppp_generic
deflate 6656 0
zlib_deflate 23968 1 deflate
twofish 46080 0
serpent 24064 0
aes 33320 0
blowfish 12928 0
des 21120 0
sha256 14464 0
sha1 6400 0
crypto_null 6400 0
ipv6 238336 20
sworks_agp 11040 0
nvidia_agp 9756 0
ati_agp 10636 0
amd64_agp 13380 0
ali_agp 9344 0
af_packet 23816 0
eepro100 30352 0
fuse 34952 0
video 17284 0
container 7168 0
button 8848 0
battery 11524 0
ac 7428 0
unionfs 61728 0
sbp2 22788 0
usb_storage 76480 0
ohci_hcd 21636 0
ehci_hcd 32008 0
efs 14468 0
dm_snapshot 17316 0
dm_mirror 20916 0
dm_mod 48404 2 dm_snapshot,dm_mirror
pcmcia 33324 0
firmware_class 11648 1 pcmcia
yenta_socket 25612 1
rsrc_nonstatic 14080 1 yenta_socket
pcmcia_core 35992 3 pcmcia,yenta_socket,rsrc_nonstatic
snd_intel8x0 31260 1
snd_ac97_codec 88352 1 snd_intel8x0
snd_ac97_bus 6016 1 snd_ac97_codec
snd_pcm_oss 38176 0
snd_mixer_oss 17536 1 snd_pcm_oss
snd_pcm 73220 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer 22148 1 snd_pcm
snd 44768 8 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_ oss,snd_pcm,snd_timer
i2c_i801 11532 0
intel_agp 22684 1
agpgart 29156 7 drm,sworks_agp,nvidia_agp,ati_agp,amd64_agp,ali_ag p,intel_agp
8250_pnp 12288 0
8250 24320 1 8250_pnp
shpchp 37032 0
pci_hotplug 28612 1 shpchp
soundcore 11104 1 snd
snd_page_alloc 11272 2 snd_intel8x0,snd_pcm
serial_core 20480 1 8250
i2c_core 20480 1 i2c_i801
eth1394 20100 0
tsdev 9920 0
evdev 11648 1
joydev 11712 0
usbhid 50144 0
ohci1394 33200 0
ieee1394 285784 3 sbp2,eth1394,ohci1394
e100 34052 0
mii 8448 2 eepro100,e100
uhci_hcd 23308 0
usbcore 109084 6 usb_storage,ohci_hcd,ehci_hcd,usbhid,uhci_hcd
thermal 14472 0
processor 25736 1 thermal
fan 7300 0
reiserfs 238704 1
giorgio@Knoppix:~$

mykol
11-02-2007, 12:46
in /dev/input ho

/by-id
/by-path
-event0
-event1
-event2
-mice
-mouse0
-mouse1
-ts0
-ts1

sacarde
11-02-2007, 12:47
credevo che occorresse la definizione in xorg.conf


grazie mille

mykol
11-02-2007, 13:01
prego

sacarde
29-05-2007, 22:08
dopo svariati tentativi con alcune distribuzioni .......

mi arrendo......

con il comando cat /proc/bus/input/devices non vedo nessun device touchpad,
solo tastiera e mouse PS2

Loading