PDA

Visualizza la versione completa : linux problemi con Beryl [era: linux mi sta a piglià...]


FinalFantasy
18-02-2007, 01:28
e mo mi sto ad incazzà....
è da una dannata settimana ke cerco di installare i driver proprietari de sta cazzo di skeda ati, e alla fine, dopo 34534534 peripezie, scopro ke fglrx non è compatibile con l'estenzione composite di xorg, e non posso usare beryl...

come devo usare allora sto cavolo di beryl se l'estensione di composite è disattivata??????

e ke ho fatto a fare 1 settimana di rompimento di palle????

scusate lo sfogo...è 1.30 e sn incazzato nero...

uso xgl e da quando ho messo Compisite Disable beryl nn parte +...ora vi posto i messaggi di errore

Room237
18-02-2007, 02:17
Guarda, io ho seguito queste istruzioni: http://www.aldolat.it/?p=79 ed ha funzionato subito... Ti consiglio di guardare anche i commenti, perchè ci sono soluzioni anche li...

antares11
18-02-2007, 10:10
Originariamente inviato da FinalFantasy
e mo mi sto ad incazzà....
................................................
cerchiamo di evitare certi termini ... e usiamo un titolo del thread indicativo e pertinente
grazie

giomazz
18-02-2007, 11:13
guarda io sul mio pc attualmente ho la suse 10.2, e la mepis 6.6 beta5
su la suse ho xgl e compiz scheda nvidia e su la mepis, aiglx e beryl con esmerald e acquamarine
e funzionano alla grande
cmq beryl è il composite manager
non per niente nasce da una costola di Compiz :madai!?:

FinalFantasy
18-02-2007, 11:35
rispondo un po' a tutti...
anche a me prima funzionava subito, ma era lento...
quindi ho installato i driver proprietari ATI, e ora quando carico il gestore di finestre beryl, spunta tutto bianco...se riesco vi faccio anche uno screen shot...xke ho notato quando esce tutto bianco, se io a memoria clicco su i tasti x terminare la sessione, funziona...allora tutto funge, ma si vede bianco...cosa dovrei fare allora?

Leo15
18-02-2007, 11:36
Magari comincia col dirci che distro stai usando :)

FinalFantasy
18-02-2007, 11:37
Originariamente inviato da Leo15
Magari comincia col dirci che distro stai usando :)
ma davvero la mia firma nn si legge? me lo kiedete tutti, ma intanto c'è scritto

ubuntu 6.10 linux 2.6.17-11-generic

Leo15
18-02-2007, 11:49
Le firme difficilmente le leggo, e cmq non è detto che il problema sia sempre con quello che c'è in firma...

Detto questo, Ubuntu Edgy ha installato di suo AIGLX, ti bastava installare beryl per farlo girare. Non serviva installare XGL.

Comunque, se resti convinto di usare XGL con la Ubuntu ti conviene installare i pacchetti dai repo, anzichè scaricare l'installer dal sito della ati.
Esistono un sacco di guide, prova questa:

http://wiki.cchtml.com/index.php/Ubuntu_Edgy_Installation_Guide

La parte di configurazione con aticonfig, per esperienza, ti consiglio di saltarla, edita a mano il file xorg.conf cambiando il nome del driver in fglrx e abilitando/disabilitando il composite

KaZaA
18-02-2007, 11:59
No...il problema è che AIGLX per ora NON può funzionare con schede ATi, dato che i suddetti driver non hanno l'estensione per il Composite...l'unica soluzione per ora è installare Xgl e usare questo al posto di AIGLX...altrementi, se vuoi usare AIGLX devi per forza usare i driver OpenSource "radeon", ma devi vedere se la tua scheda è supportata (ovviamente poi le prestazioni saranno quelle che saranno...)

Leo15
18-02-2007, 12:15
AIGLX gira solo con driver open (con le ATI), ma per la mia esperienza le prestazioni sono decisamente superiori ad XGL, nonostante XGL usi i driver ufficiali.
beryl funziona a meraviglia con AIGLX, come anche compiz (alcuni lo preferiscono a beryl perchè più leggero)

Loading