PDA

Visualizza la versione completa : [gentoo] Vim impazzito


Gionnico
19-02-2007, 19:37
Ciao!

Dopo aver emerso vim ed aver fornito il file /etc/vimrc che usavo su LFS, ho provato ad aprire un file ed ho notato comportamenti alquanto strani.
Il file /etc/vimrc (che non s tra l'altro se viene considerato o meno) questo


" Begin /etc/vimrc

set nocompatible
set backspace=2
syntax on
if (&term == "iterm") || (&term == "putty")
set background=dark
endif
set laststatus=2
set ruler
" End /etc/vimrc



I comportamenti strani sono:
1) Anche dopo aver premuto ESC, basta premere un tasto qualunque per modificare il file.
2) I tasti i,I,a,A non funzionano: non appare la scritta in basso.
3) Premendo le frecce appaiono rispettivamente le lettere


SU = A
GIU = B
DX = C
SX = D

:dott:


:confused:

GreyFox86
19-02-2007, 19:48
Il mio file di config in gentoo in /etc/vim/vimrc (una cartella perch ci sta anche gvimrc nel caso lo avessi) prova a spostarlo l.

Gionnico
19-02-2007, 19:53
Originariamente inviato da GreyFox86
Il mio file di config in gentoo in /etc/vim/vimrc (una cartella perch ci sta anche gvimrc nel caso lo avessi) prova a spostarlo l.
Funziona ... !!! :D

Come mai non sar stata creata neanche la directory?? :confused:



Comunque mi dice che "syntax" non supportato ... :oVVoVe:

Come no?! :zizi:

GreyFox86
19-02-2007, 19:57
edit: oops, ho visto solo ora che hai editato il tuo messaggio :D

Gionnico
19-02-2007, 19:58
Leggi ho modificato ;)

GreyFox86
19-02-2007, 20:03
Che non sia stata creata la directory in effetti strano... hai avuto errori/interruzioni durante l'installazione?
Per quanto riguarda la sintassi... la mia configurazione di vim (ho tenuto quella base) dice

" Switch syntax highlighting on, when the terminal has colors
" Also switch on highlighting the last used search pattern.
quindi la prima cosa che mi viene in mente che il terminale che usi non supporti i colori...

edit: apri vim e digita :highlight per vedere se i colori ci sono. prova anche a verificare di non aver installato vim con la use flag "minimal" impostata (equery uses vim)

Gionnico
19-02-2007, 20:09
Originariamente inviato da GreyFox86
Che non sia stata creata la directory in effetti strano... hai avuto errori/interruzioni durante l'installazione?
Per quanto riguarda la sintassi... la mia configurazione di vim (ho tenuto quella base) dice

" Switch syntax highlighting on, when the terminal has colors
" Also switch on highlighting the last used search pattern.
quindi la prima cosa che mi viene in mente che il terminale che usi non supporti i colori...

edit: apri vim e digita :highlight per vedere se i colori ci sono. prova anche a verificare di non aver installato vim con la use flag "minimal" impostata (equery uses vim)
Ho usato minimal :fagiano:

Posso ricompilarlo semplicemente con


USE="-minimal" emerge -u vim

:stordita:

edit: una domanda..

edit2: risposta - penso di si - ora provo..

GreyFox86
19-02-2007, 20:20
Puoi, ma per sicurezza sempre meglio NON usare le use in quel modo, passandole ogni volta.
Usa gli appositi file di configurazione, come in questo caso: /etc/portage/package.use
Se non esiste lo crei (o crei una cartella con quel nome e ci sbatti dentro pi file se vuoi organizzare meglio le impostazioni) e ci metti il nome (completo del pacchetto e poi una in fila all'altra le use: a differenza che quelle in make.conf, qui le imposti pacchetto per pacchetto, usale spesso perch senn quando riemergerai il software (updates, eccetera) e non usi package.use dovrai sempre ricordarti per ognuno quali use specificare, e non bello :D

app-editors/vim -minimal

edit: avevo capito che si trattava di una domanda ma ero impegnato a scrivere questa pizza :zizi:

Gionnico
19-02-2007, 20:41
Originariamente inviato da GreyFox86
Puoi, ma per sicurezza sempre meglio NON usare le use in quel modo, passandole ogni volta.
Usa gli appositi file di configurazione, come in questo caso: /etc/portage/package.use
Se non esiste lo crei (o crei una cartella con quel nome e ci sbatti dentro pi file se vuoi organizzare meglio le impostazioni) e ci metti il nome (completo del pacchetto e poi una in fila all'altra le use: a differenza che quelle in make.conf, qui le imposti pacchetto per pacchetto, usale spesso perch senn quando riemergerai il software (updates, eccetera) e non usi package.use dovrai sempre ricordarti per ognuno quali use specificare, e non bello :D

app-editors/vim -minimal

edit: avevo capito che si trattava di una domanda ma ero impegnato a scrivere questa pizza :zizi:
:smack:

Ho installato vim con USE="-minimal" e quindi ho memorizzato il flag nel packages.use ...

Ha creato il suo bel file di configurazione che ho "mergiato" con il mio vecchio (in realt c'erano solo cose aggiuntive).. in pratica il mio era una cacchetta :oVVoVe:


Grazie dei consigli!!!! :)

GreyFox86
20-02-2007, 12:09
Figurati ;)
Si cmq vero, il vimrc che installato di base mostruoso, non gli manca davvero nulla :D

Loading