PDA

Visualizza la versione completa : Kubuntu e apt...non scarica i pacchetti!


alx815
19-02-2007, 23:54
Premesso che ho dato uno sguardo all'interno del forum e nulla ho trovato in proposito volevo porvi una domanda, ovvero come da titolo topic come mai apt (come pure Adept) non mi scaricano i pacchetti? Allora il problema è abbastanza anomalo, infatti ieri sera sono iuscito tranquillamente ad usare entrambi collegandomi alla rete di mio fratello, invece attaccandomi alla mia nn ne vogliono sapere. Non mi danno nessun errore però rimane a vita a dirmi che il download dei pacchetti sta x iniziare. Le configurazioni delle rete sono pressocchè simili, solo che la sua è una cablata su switch connesso a modem adsl e la mia sempre una cablata su router adsl. Di navigare navigo bene con entrambe... cosa sarà mai?

Ps: Alla fine dopo esser passato in una settimana da mandriva a suse mi sono installato una bella kubuntu che forse è + gratificante :unz:

alx815
20-02-2007, 00:07
Allora continuo a provarci e lui continua a rimanere impalato sulla scritta "waiting for headers"... :dhò:
Se nn risolvo questo problema nn riuscirò a configurare un bel niente -.-

Ps: dato che ci sono ne approfitto, sapreste indicarmi un buon repository x kubuntu? io x il momento ho attivato quasi tutti quelli che si riporta di default, ma se ce ne stanno di migliori vi prego di suggerirmeli :ciauz:

alx815
20-02-2007, 09:46
Torno x aggravare la situazione, al momento nn riesco nemmeno a far passare la lingua del sistema in italiano e a mettere compiz :dhò:
Please help :confused:

Edit x altre info: può cambiare qualcosa se da mio fratello la connessione è alice e da me libero?

francofait
20-02-2007, 10:04
Originariamente inviato da alx815
Torno x aggravare la situazione, al momento nn riesco nemmeno a far passare la lingua del sistema in italiano e a mettere compiz :dhò:
Please help :confused:

Edit x altre info: può cambiare qualcosa se da mio fratello la connessione è alice e da me libero?


inposta la connessione internet sul gatewait del ruter con gli indirizzi dns statici del tuo fornitore di servizio .

alx815
20-02-2007, 10:48
Grazie francofait, sono riuscito a risolvere alla fine, in effetti erano i dns che davano problemi col mio router. Adesso sto smanettando un pò, speriamo che nn trovo altri problemi sennò torno a torturarvi, e comunque è da stamattina presto che letto howto e mo ci vedo doppio, però a qualcosa servono, ho imparato un sacco di cose :mame:

alx815
20-02-2007, 14:41
Ciau... riecchime, adesso mi sto mettendo ad installare compiz ed amici x utilizzare il cubo e gli altri effetti. Ho installato i driver nvidia e i pacchetti compiz, adesso cosa dovrei fare x avviarli????
Ho l'impressione che devo metter mano a xorg.conf, ma cosa devo fare?

GunMan
20-02-2007, 14:46
prova a dare un'occhiata Qui (http://mcz.altervista.org/Pagine/Appendice10.html)

comunque rimane sempre valido il consiglio di cercare how to e guide sui generis che, come è facile immaginare per un argomento del genere, sono praticamente ovunque :)

:ciauz:

alx815
20-02-2007, 23:43
Ho provato a seguire quella (ma anche altre) guide, ma il mio problema adesso sono i driver video. Li ho provati ad installare con "$ sudo module-assistant auto-install nvidia" ma mi dice che nn ci sono pacchetti da aggiornare, quindi ne convengo che la precedente installazione fosse andata a buon fine. Allora adesso mi manca da configurare solo xorg, ma dopo innumerevoli tentativi e riavvii in modalità testuale x rimettere tutto apposto ho buttato la spugna... ecco il mio xorg.conf, potreste dirmi dove sbaglio?

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/usr/share/fonts/X11/misc"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "NVIDIA Corporation NVIDIA Default Card"
Driver "nv"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NVIDIA Default Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection

Nella sezione device a driver ho provato a mettere nvidia al posto di nv ma nn parte, stessa cosa vale x le altre modifiche apportate x la definizione dello skermo e quant'altro. L'accelerazione grafica ovviamente nn risulta attiva e nemmeno le opengl. Se può essere d'aiuto quando metto lo xorg.conf che mi imposta l'installazione dei driver proprietari nvidia mi esce il logo nvidia ma subito dopo mi rimane uno skermo nero con cursore lampeggiante.
Idee?? :master:

GunMan
21-02-2007, 00:08
premetto che non sono espertissimo di compiz, beryl e compagnia bella, comunque a quanto ne so è meglio installare i driver nvidia proprietari e acceleratore grafico.

visto che stai ancora usando i driver di base che trovi su xorg


sudo apt-get install nvidia-kernel-common nvidia-glx

se quanto detto finora va a buon fine puoi aggiungere questa riga nella Section "Device"


Option "RenderAccel" "true"

edit: nella sezione Section "Module" commenta questa riga:

# Load "dri"

lasciando di fatto solo il modulo glx

:ciauz:

alx815
21-02-2007, 10:10
Grazie x la risposta, ho fatto come mi hai detto e sembra andare. Adesso però dovrei attivare anche le glx x poter mettere il cubo, solo che quando do il comando:
$ glxinfo |grep rendering
me ne esce questo:
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".

Lo so che sono un utonto ancora ma vi prego di scusarmi :zizi:

Loading