PDA

Visualizza la versione completa : modem dlink e debian


Marcolino's
25-02-2007, 14:26
Già, oggi sembra la giornata dei modem.
Ma il mio è un problema datato, ovvero da quando Libero mi ha fornito di questa disgrazia di modem ethernet della D-Link.
In pratica non iesco a navigare se non settando i dns di libero ogni qualvolta devo collegarmi, e spesso comunque cado perché perde i dns.

Cosa posso fare per sistemare la situazione?
Con il modem Zypher questi problemi non li avevo.

francofait
25-02-2007, 14:34
Originariamente inviato da Marcolino's
Già, oggi sembra la giornata dei modem.
Ma il mio è un problema datato, ovvero da quando Libero mi ha fornito di questa disgrazia di modem ethernet della D-Link.
In pratica non iesco a navigare se non settando i dns di libero ogni qualvolta devo collegarmi, e spesso comunque cado perché perde i dns.

Cosa posso fare per sistemare la situazione?
Con il modem Zypher questi problemi non li avevo.

Tanto disgrazia non direi , se lo lasci configurato con dhcp attivo al boot è poco ma sicuro che ad ogni riavvio ti sovrascriverà sempre e comunque /etc/resolve.conf
Disattiva dhcp ed imposta l'avvio con dns statici
nameserver 193.70.152.15
nameserver 193.70.152.25

Marcolino's
25-02-2007, 14:39
No, non ho una configurazione con un window desktop, tutto da shell :)
ho provato a dare i comandi di ifconfig, ma non basta a parte fare il ping, non riesco nemmeno a fare apt-get qualcosa (ovvio, il source.list esiste ;) )
Dovrei riuscire a editare la configurazione per evitare che parta il DHCP.

francofait
25-02-2007, 14:56
Originariamente inviato da Marcolino's
No, non ho una configurazione con un window desktop, tutto da shell :)
ho provato a dare i comandi di ifconfig, ma non basta a parte fare il ping, non riesco nemmeno a fare apt-get qualcosa (ovvio, il source.list esiste ;) )
Dovrei riuscire a editare la configurazione per evitare che parta il DHCP.

neppure ti serve
editi /etc/ppp/peers/provider
cerchi la stringa:
userpeerdns e la modifichi in
nouserpeerdns

poi riaggiorni se non lo hai già fatto gli indirizzi in /etc/resolv.conf

Marcolino's
25-02-2007, 18:25
Rispondo solo ora, comunque la questione è semplice:
[list=1]
ho editato il file provider e vi ho aggiunto il comando nouserpeerdns dato chen n c'era nulla di tutto ciò;
ho editato il file resolv.conf e qui ci sono state pure sorprese, infatti:


search
nameserver 192.168.1.1

tutto qui. Tra l'altro non so nemmeno i nomi dei comandi per aggiungere i dns, come non so se nameserver si riferisca al gateway del router (anche se l'indirizzo IP è quello giusto)
[/list=1]
Ora potrei pure riavviare, non so cosa succederà, al limite non funziona ;)

Marcolino's
25-02-2007, 18:36
Bene ho riavviato e come immaginavo non è andato meglio di prima.
Ho provato a connettermi tramite telnet alla pagina di google, ma a parte trovare l'IP di google non fa altro.

Ora ho modificato un poco il router D-Link, in particolare ho settato i DNS del server DHCP uguali a quelli di Libero, vediamo che fa ....

.... nulla Telenet è in trying su 1.0.0.0 bo!

Ebbene, come indicato da questo esempio:
http://www.firenze.linux.it/~piccardi/corso/netadmin/node22.html

ho aggiunto nel file resolv.conf altri due nameserver con i dns e .... non funziona.

C'è da aggiungere che sono in una LAN con una macchina Windows2000 sotto questo router, oltre alla debian che non si collega, e nel caso aveste dei dubbi, la LAN funziona, visto che scrivo dalla macchina Win.

Marcolino's
25-02-2007, 18:55
:dhò:
Va be quando ci vuole ..... ok nella fretta di trovare una soluzione non avevo riavviato la macchina :fagiano: ora sta facendo l'update e pare che funzioni in rete.

E' bello farcela con le proprie gambe, anche se con un piccolo aiuto. :yuppi:

Loading