PDA

Visualizza la versione completa : [OpenSuse 10.2] Conflitto di dipendenze


zito882000
01-03-2007, 15:15
Salve a tutti,
sono divenuto da poco un utente Suse e sono molto soddisfatto dei risultati che ho ottenuto nel corso di questo periodo di utilizzo di questo SO Open Source...unico problema che mi impedisce di installare tutti i programmi la dipendenza da delle librerie che non so e non riesco a risolvere...
Ad esempio amule ha un conflitto di dipendenza con wxgtk-compat...qualcuno potrebbe aiutarmi? Vi chiedo solo di essere pi chiari possibili, dopotutto sono ancora alle prime armi!!!
Grazie a tutti comunque in anticipo :)

untamed
01-03-2007, 15:22
Per installare/rimuovere software, puoi usare il tool di gestione del sistema di openSuSE, cio Yast, che risolve da solo le dipendenze.

zito882000
01-03-2007, 15:24
proprio lui che mi da questi problemi, devo modificare qualche impostazione?

untamed
01-03-2007, 16:22
Ma quindi amule lo cerchi e trovi con yast? Oppure lo hai scaricato tu? Nel primo caso strano che non riesca a risolvere le dipendenze...

zito882000
01-03-2007, 16:25
amule si trova sul mio computer ma anche i problemi che sono nei repository in rete mi danno lo stesso problema...comunque se hai un repository dove si trova fra le altre cose anche amule potresti passarmelo?

untamed
01-03-2007, 17:10
Ho installato opensuse su un pc di un amico e gli avevo messo amule, ma avevo dovuto cercare un po' in giro qualche repository da cui scaricarlo. Cerca e cerca lo avevo trovato, ma non mi ricordo dove...

GunMan
01-03-2007, 17:16
se posso dare un consiglio del tutto spassionato ti direi di usare smart al posto del gestore di pacchetti integrato in yast.

molto pi leggero e offre gi in partenza, alla sua installazione, un parco di repository molto vasto, normalmente non c' nessun problema nel reperire software, anche per quanto riguarda amule (a men che non sia adunanza, che ha un suo pacchetto a parte).

se vorrai provare scarica i seguenti pacchetti

smart
smart-addons
smart-gui (interfaccia grafica)
smart-ksmarttray (KDE System Tray for the Smart Package Manager)

:ciauz:

zito882000
01-03-2007, 17:34
anche smart mi da rpoblemi di dipendenze!!! comunque vedo se riesco a risolvere almeno quelli...ho anche cercato amule in un repository in rete ma tanto per cambiare ho sempre problemi di dipendenze...

GunMan
01-03-2007, 17:45
anomalo questo problema, normalmente i gestori di pacchetti risolvono per loro conto le varie dipendenze.

il problema in maniera specifica con cosa si manifesta e quali sono queste librerie che causano tutte queste noie?

potresti provare ad installare in separata sede e poi successivamente riprovare.

:ciauz:

zito882000
01-03-2007, 17:48
cosa intendi per separata sede? su un'altro pc?

si comunque me ne rendo conto che effettivamente anomalo, ma queste librerie stesse a loro volta non posso installarle perch hanno un problema di dipendenza da altre librerie...insomma non riesco a venirne a capo...ogni programma o libreria ha una dipendenza da una libreria che yast non riesce a risolvere, e io sono con le mani legate... :(

Loading