PDA

Visualizza la versione completa : [NEWBIE] - Messaggio di errore.


Illogitech
08-03-2007, 10:39
Salve,
Su una distribuzione Kubuntu, entrando in monitor&display, dopo aver inserito la pass di admin, mi appare questo messaggio:

Impossibile caricare il modulo monitor&display
La diagnosi :
cause possibili
-si verificato un errore quando hai aggiornato kde de rimasto un vecchio modulo di controllo
ci sono dei vecchi moduli sviluppati da terze parti

...prova a rimuovere il modulo indicato nel messaggio di errore...

Quale messaggio di errore?? cosa dovrei fare?
Ho provato tramite adept a cercare pacchetti con quel nome o simile ma non ho trovato nulla...

grazie.

andy caps
08-03-2007, 15:12
puoi provare a reinstallare il pacchetto responsabile della sezione

apt-get --reinstall install kcontrol kdebase

se un aggiornamento parziale come dice dovrebbe aggiornartelo

Illogitech
08-03-2007, 16:24
Originariamente inviato da andy caps
puoi provare a reinstallare il pacchetto responsabile della sezione

apt-get --reinstall install kcontrol kdebase

se un aggiornamento parziale come dice dovrebbe aggiornartelo


ah, ecco! allora sarebbe quello il pacchetto da reinstallare!
OK ci provo appena torno a casa.

Grazie!

Illogitech
09-03-2007, 09:09
Ho provato a reinstallare kcontrol e kdebase ma non cambiato nulla, ho sempre lo stesso messaggio di errore.

Qualche altro suggerimento?

Illogitech
09-03-2007, 14:53
UP!

niente? :cry:

Illogitech
10-03-2007, 09:44
Vi do qualche altro elemento. lanciando il programma da linea di comando l'output questo:


ale@pc-ale:~$ kcmshell displayconfig
X Error: BadDevice, invalid or uninitialized input device 168
Major opcode: 145
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 168
Major opcode: 145
Minor opcode: 3
Resource id: 0x0
Failed to open device


Pythonize constructor -- pid = 4724
Python interpreter initialized!



Pythonize constructor -- pid = 4724
Traceback (most recent call last):
File "<string>", line 8, in kcontrol_bridge_create_displayconfig
File "/var/lib/python-support/python2.4/displayconfig.py", line 1685, in create_displayconfig
return DisplayApp(parent, name)
File "/var/lib/python-support/python2.4/displayconfig.py", line 441, in __init__
self.xsetup = XSetup(self.xconfigpath)
File "/var/lib/python-support/python2.4/displayconfigabstraction.py", line 72, in __init__
self.xorg_config = xorgconfig.readConfig(xorg_config_filename)
File "/var/lib/python-support/python2.4/xorgconfig.py", line 641, in readConfig
for row in XorgconfCVSReader(filename=filename).readlines():
File "/var/lib/python-support/python2.4/xorgconfig.py", line 696, in __init__
fhandle = codecs.open(filename,'r',locale.getpreferredencodi ng(),'replace')
File "/usr/lib/python2.4/locale.py", line 417, in getpreferredencoding
setlocale(LC_CTYPE, "")
File "/usr/lib/python2.4/locale.py", line 381, in setlocale
return _setlocale(category, locale)
locale.Error: unsupported locale setting
error: *** runFunction failure
;


che per me abbastanza arabo. Qualche consiglio su cosa fare?

sacarde
10-03-2007, 11:54
http://www.archlinux.it/forum/problema-con-gtkpacman

Illogitech
12-03-2007, 23:55
ho letto l'articolo ma i files citati /etc/rc.conf e /etc/locale.gen non esistono sul mio PC :(
In compenso penso di aver circoscritto l'errore a questo warning che mi appare un po' dappertutto:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "it_IT@euro"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").


evidentemente devo settare LANGUAGE = (unset), e LC_ALL = (unset),
ma in che file? E cosa devo mettere al posto di unset?

grazie.

francofait
13-03-2007, 00:25
da console sudo
apt-get autoremove
apt-get --reinstall install locales

andy caps
13-03-2007, 00:49
prova a dare il comando

sudo gedit /var/lib/locales/supported.d/local
e metti queste due righe

it_IT.UTF-8 UTF-8
en_US.UTF-8 UTF-8

poi metti in /etc/environment demprre con sudo gedit /etc/environment
LANG="it_IT.UTF-8 sotto alla riga del patch

dai po un dpkg-reconfigure locales

e prova a riavviare

:bh: ubuntu purtoppo ha eliminato i tools di debian per configurare e scegliere il locales preferito


prima pero prova a settare semplicemente da system setting nel menu il tuo locale dalla sezione regional . . . .

Loading