PDA

Visualizza la versione completa : [kubuntu] installazione pacchetti e info


torejx
10-03-2007, 00:08
Ciao ragazzi sono un novello di linux e vorrei sapere dove posso trovare una guida per principianti che riguarda questa distro e poi come faccio a installare i pacchetti? :dhò:
so che è una domanda trita e ritrita... :(

mandrillo
10-03-2007, 06:11
http://www.ubuntu-it.org/index.php?page=kubuntu

qui trovi la giuda di kubuntu
http://www.ubuntu-it.org/index.php?page=kubuntu

e x installare pacchetti, il modo + facile è questo
http://help.ubuntu-it.org/6.10/kubuntu/desktopguide/it/add-applications.html

torejx
10-03-2007, 23:43
Originariamente inviato da mandrillo
http://www.ubuntu-it.org/index.php?page=kubuntu

qui trovi la giuda di kubuntu
http://www.ubuntu-it.org/index.php?page=kubuntu

e x installare pacchetti, il modo + facile è questo
http://help.ubuntu-it.org/6.10/kubuntu/desktopguide/it/add-applications.html

grazie mille :ciauz:

torejx
11-03-2007, 23:15
sto provando a prendere dimestichezza con i comandi... però volevo chiedervi un paio di cose:
1) apt cerca i programmi in rete e li installa giusto? perchè ho scritto
sudo apt-get install firefox e lo ha installato.
2) avevo alcuni pacchetti .tar e ho visto la procedura per l'installazione... dopo averli scompattati seguo le direttive del readme e quando faccio il make mi dice
make -f Makefile spim2
make[1]: Entering directory `/home/salvatore/Desktop/spim-7.3/spim'
bison -d --file-prefix=y ../CPU/parser.y
make[1]: bison: Command not found
make[1]: *** [y.tab.c] Error 127
make[1]: Leaving directory `/home/salvatore/Desktop/spim-7.3/spim'
make: *** [spim] Error 2


cosa vuol dire? :dhò:

GunMan
11-03-2007, 23:22
apt è un gestore di pacchetti ne più ne meno, funziona da riga di comando e ha diversi frontend grafici, come ad esempio adept e synaptic.

essendo un gestore di pacchetti si occupa sia di scaricarli che di installarli, rimuoverli e aggiornarli.

come al solito man apt per saperne di più o una semplicissima ricerca on line.

per quanto riguarda il resto pare che il problema sia questo

make[1]: bison: Command not found

prova ad installare bison ed eventualmente riprova, comunque se vuoi un consiglio prima di andare a compilare verifica sempre la disponibilità del software pacchettizzato per la tua distribuzione.

:ciauz:

torejx
11-03-2007, 23:25
Originariamente inviato da GunMan
apt è un gestore di pacchetti ne più ne meno, funziona da riga di comando e ha diversi frontend grafici, come ad esempio adept e synaptic.

essendo un gestore di pacchetti si occupa sia di scaricarli che di installarli, rimuoverli e aggiornarli.

come al solito man apt per saperne di più o una semplicissima ricerca on line.

per quanto riguarda il resto pare che il problema sia questo

make[1]: bison: Command not found

prova ad installare bison ed eventualmente riprova, comunque se vuoi un consiglio prima di andare a compilare verifica sempre la disponibilità del software pacchettizzato per la tua distribuzione.

:ciauz:

cos'è bison? lo posso installare con apt-get install bison? Quello che sto cercando di installare è un programma particolare, come faccio a vedere se posso installarlo sulla mia distro?quando l'ho scaricato faceva distinzione solo tra win/mac/linux....

GunMan
11-03-2007, 23:31
beh allora apt non prevede mica solo l'opzione install :)

prova:

apt-cache search bison

(bison comunque è un parser generator, uno dei tanti, forse tra i più conosciuti)

ti invito nuovamente a documentarti su apt, altrimenti puoi sempre usare adept che ha la sua comoda interfaccia.

:ciauz:

edit: quello che tu hai scaricato è un .tar che produce un tarball io parlavo di un pacchetto vero e proprio per la tua distribuzione, lo cerchi normalmente con adept.

torejx
11-03-2007, 23:36
Originariamente inviato da GunMan
beh allora apt non prevede mica solo l'opzione install :)

prova:

apt-cache search bison

(bison comunque è un parser generator, uno dei tanti, forse tra i più conosciuti)

ti invito nuovamente a documentarti su apt, altrimenti puoi sempre usare adept che ha la sua comoda interfaccia.

:ciauz:

ok ho provato sia synaptic che adept e devo dire che sono molto comodi...ti disturbo l'ultima volta per due piccoli chiarimenti poi ti giuro che prendo la guida di kubuntu e me la mangio :D
1)la ricerca che faccio su adept/synaptic equivale al comando shell apt-cache search ?
2)su synaptic ho fatto la ricerca per il mio programma e ne ho trovata una versione meno recente di quella che avevo...la versione che mi da synaptic è quella giusta per la mia distro oppure non è detto che lo sia?
Scusa ma sono a lavoro e non riesco a stare tranquillo per studiarmi la guida

GunMan
11-03-2007, 23:42
Originariamente inviato da torejx
1)la ricerca che faccio su adept/synaptic equivale al comando shell apt-cache search ?

praticamente si, come ti dicevo prima synaptic e adept sono semplicemente dei frontend di apt e inoltre "pescano" dal medesimo sources.list


Originariamente inviato da torejx
2)su synaptic ho fatto la ricerca per il mio programma e ne ho trovata una versione meno recente di quella che avevo...la versione che mi da synaptic è quella giusta per la mia distro oppure non è detto che lo sia?
Scusa ma sono a lavoro e non riesco a stare tranquillo per studiarmi la guida

la versione che ti da il gestore di pacchetti è semplicemente l'ultima versione pacchettizzata che c'è a disposizione per la tua distribuzione, questo non significa che tu non possa decidere per tutta una serie di motivi di lasciar perdere quella per compilare i sorgenti dell'ultimissima release.

si consiglia di usare software pacchettizzato per via della migliore gestione delle dipendenze in linea di massima, per una "pulizia" maggiore potremmo dire.

:ciauz:

torejx
11-03-2007, 23:46
Originariamente inviato da GunMan
praticamente si, come ti dicevo prima synaptic e adept sono semplicemente dei frontend di apt e inoltre "pescano" dal medesimo sources.list



la versione che ti da il gestore di pacchetti è semplicemente l'ultima versione pacchettizzata che c'è a disposizione per la tua distribuzione, questo non significa che tu non possa decidere per tutta una serie di motivi di lasciar perdere quella per compilare i sorgenti dell'ultimissima release.

si consiglia di usare software pacchettizzato per via della migliore gestione delle dipendenze in linea di massima, per una "pulizia" maggiore potremmo dire.

:ciauz:
ok ora ho capito...cmq penso di utilizzare la versione pescata da synaptic visto che cmq io ho la 7.3 mentre lì ho trovato la 7.1 quindi cambia ben poco credo...
Sei stato gentilissimo...grazie :ciauz:

Loading