PDA

Visualizza la versione completa : disabilitare touchpad


cicciodevoto
09-04-2007, 10:48
ciao a tutti,
vorrei sapere come disabilitare il touchpad dal portatile e utilizzare sol il mouse usb. ho cercato in rete e ho trovato che dovrei editare il file xorg.conf, ma le opzioni che dovrei modificare non compaiono nel xorg.conf che ho io, di seguito ripoto il contenuto inerente al mouse:



Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection


grazie di tutto
ciccio

francofait
09-04-2007, 10:52
Semplicissino , le aggiungi poi riavvi , e commenti quelle x il touchpad

sacarde
09-04-2007, 10:54
io ho il problema inverso...

su un travelmate non mi riesce farlo funzionare

mi e' stato consigliato di aggiungere alla conf di X

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "100"
Option "VertScrollDelta" "100"
EndSection


qindi tu dovresti togliere questa parte

mykol
09-04-2007, 11:07
e non caricare il modulo "synaptic" (se usa quello) ?

# lsmod |grep synaptic per vederlo

magari

# modprobe -r synaptic

per toglierlo

Controlla man modprobe

cicciodevoto
09-04-2007, 12:17
ora il file xorg.conf č:



Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "SHMConfig" "on"
EndSection


e avevo trovato che per disabilitare il touchpad avrei dovuto scrivere nella shell:



$ synclient TouchpadOff=1


ma ottengo il messaggio:



$ Can't access shared memory area. SHMConfig disabled?


cosa devo fare?
grazie
ciccio

p.s.: buona pasqua a tutti!!!

mykol
09-04-2007, 14:23
prova a commentare (# davanti ad ogni riga) tutta questa sezione

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "SHMConfig" "on"
EndSection

e poi a riavviare X (CTRL+CANC, cioč freccia grossa indietro) e rifare il login

cacao74
09-04-2007, 15:16
Senza modificare la configurazione di X, dove peraltro potrai configurare la parte per il touchpad nel caso volessi riutilizzarlo, ti bastera' premere una particolare combinazione di tasti [Fn]-[FX] con X che va da 1 a 12 per (dis)abilitare il touchpad. In base al modello del tuo portatile, dovrai comportarti di conseguenza. Questa gestione e' indipendente dal sistema operativo sottostante. Consulta il manuale d'uso del tuo portatile.

ciao

cicciodevoto
09-04-2007, 17:49
Originariamente inviato da mykol
prova a commentare (# davanti ad ogni riga) tutta questa sezione

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "SHMConfig" "on"
EndSection

e poi a riavviare X (CTRL+CANC, cioč freccia grossa indietro) e rifare il login

questa parte l'ho aggiunta io, nel xorg.conf originale non c'era. cmq con o senza funziona sia il mouse usb che il touchpad

cicciodevoto
09-04-2007, 17:51
Originariamente inviato da cacao74
Senza modificare la configurazione di X, dove peraltro potrai configurare la parte per il touchpad nel caso volessi riutilizzarlo, ti bastera' premere una particolare combinazione di tasti [Fn]-[FX] con X che va da 1 a 12 per (dis)abilitare il touchpad. In base al modello del tuo portatile, dovrai comportarti di conseguenza. Questa gestione e' indipendente dal sistema operativo sottostante. Consulta il manuale d'uso del tuo portatile.

ciao

ho provato con tutte le combinazioni ma niente di fatto, funzionano sempre entrambi

cacao74
09-04-2007, 18:17
Originariamente inviato da cicciodevoto
ho provato con tutte le combinazioni ma niente di fatto, funzionano sempre entrambi
non e' una combinazione a casaccio... sul mio ad esempio e' [Fn]-[F7].
Cosa dice il manuale d'uso?
Che modello di portatile hai ?

Loading