PDA

Visualizza la versione completa : Errore dipendenza in Fedora Core 6


kolore
15-04-2007, 21:32
Ciao a tutti!
Sto muovendo i primi passi in linux e mi trovo subito in difficoltÓ. :)

Ho installato yumex per l'aggiornamento dei programmi.
vorrei aggiornare openoffice alla versione 2.2 ma quando lancio l'upgrade yumex mi restituisce un errore di dipendenze :

Missing Dependency: python(abi) = 2.4 is needed by package yumex
Missing Dependency: python(abi) = 2.4 is needed by package aqbanking

Non riesco a capire cosa devo fare per risolvere il problema, che pacchetto devo installare?
purtroppo lo stesso problema mi si presenta anche per l'installazione di altri pacchetti!
aiuto!!!! :dh˛:

tremalnaik_sal
16-04-2007, 10:06
devi installare i pacchetti relativi al linguaggio python

kolore
16-04-2007, 12:35
Ieri sera ho installato il pacchetto python 2.4 ma ora Ŕ anche peggio.

adesso non trovo piu una marea di dipendenze, al momento non ho il pc sottomano, stasera riprovo a lanciare tutto e posto gli errori. comuque sono ancora tutti riguardanti il pacchetto python.

Credo che forse ho installato una versione piu vecchia, potrebbe essere questo il problema.
Stasera posto anche il nome del pacchetto.

grazie per l'aiuto.

ciao

andy caps
16-04-2007, 14:29
devi installarli con yum che risolve tutte le dipendenze

yum install yumex

scarica ed installa yumex e tutto quello che serve

yum search python trova i pacchetti di pyton
se hai installato pacchetti erronei o di un altra versione manualmente
disinstallali rpm -e nome pacchetto

kolore
16-04-2007, 21:43
Ciao a tutti!

Ho provato a installare la versione 2.5 di python (file Python-2.5.tgz)ma niente.

Ora gli errori che ricevo sono:
Missing Dependency: python-abi = 2.4 is needed by package PyQt-qscintilla
Missing Dependency: python(abi) = 2.4 is needed by package eric
Missing Dependency: python(abi) = 2.4 is needed by package PyQt-qscintilla
Missing Dependency: python(abi) = 2.4 is needed by package python-logilab-common
Missing Dependency: python(abi) = 2.4 is needed by package ipython
Missing Dependency: python(abi) = 2.4 is needed by package aqbanking
Missing Dependency: python(abi) = 2.4 is needed by package python-logilab-astng
Missing Dependency: python(abi) = 2.4 is needed by package yumex
Missing Dependency: python(abi) = 2.4 is needed by package pylint
Missing Dependency: python-abi = 2.4 is needed by package eric
Missing Dependency: python-abi = 2.4 is needed by package ipython
Missing Dependency: PyQt = 3.17 is needed by package PyQt-qscintilla
Missing Dependency: db4 = 4.3.29-9.fc6 is needed by package db4-devel

Questi errori li ricevo dalla schermata di yumex.

aiuto!!! :dh˛:

Loading