PDA

Visualizza la versione completa : debian testing: lenny - togliere gnome


magnet_80
18-04-2007, 19:22
ciao, ho installato la testing (lenny) tramite netinst e ho visto che ha gnome.
(vecchia discussione: http://forum.html.it/forum/showthread.php?threadid=1094285&highlight=debian+testing)
ho provveduto quindi a installare kde tramite apt. una volta entrato in kde come root, tramite synaptic, alla voce "ambiente GNome" ho provveduto a togliere tutte le voci riguardanti l'ambiente grafico gnome.
1) come sapere se ho tolto tutto e non vi pi niente che riguarda gnome?

grazie

andy caps
18-04-2007, 19:45
:bh: qualche libreria di gnome la installa anche kde
non ci sono molti probemi se qualche file rimasto
( meglio cento file in piu che uno in meno )
non portano comunque via risorse al sistema

rimuovi le libgnome
dovrebe rimuovere quasi tutto

bereshit
18-04-2007, 21:08
se non volevi gnome bastava non installarlo..installa il core e poi con aptitude installa il task kde..

magnet_80
18-04-2007, 22:39
se l' installato in automatico, quando nei vari passaggi della net-inst ho selezionato l'ambiente desktop.
un'altro aiuto per nvidia. ho il kernel 2.6.18-4-686 e ho scaricato nvidia-kernel-common, nvidia-kernel-source, nvidia-setting nvidia-xconfig, nvidia-kernel-legacy-2.6-686 e nvidia-kernel-legacy-2.6.18-4-686. xorg dai repository di debian

questo xorg.conf
**************
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "Monitor"
Identifier "PHILIPS 105S"
Option "DPMS"
EndSection

Section "Device"
Identifier "nVidia Corporation G70 [GeForce 7300 GT]"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation G70 [GeForce 7300 GT]"
Monitor "PHILIPS 105S"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
EndSubSection
EndSection
************
non dovrei avere una grafica pi performante? mi pare uguale a prima che installassi gli nvidia. grazie

andy caps
18-04-2007, 23:34
controlla con il comando glxinfo se il direct rendering su yes e guarda se hai installato anche

nvidia-glx

i driver nv dovrebbero avere le stesse performance
l'unica cosa che cambia che con nvidia hai l'accelerazione grafica

bereshit
19-04-2007, 18:43
consiglio per la prossima installazione..installa solo il core (non selezionare al cun task..tipo desktop)..poi ad installazione avvenuta dai aptitude e dai task scegli quello di kde (desktop installa di base il task gnome..cos lo agiri e ti installi il task che vuoi)..

per nvidia basta installare nvidia-glx..e i moduli nvidia per il tuo kernel (installa quelli fittizzi..tipo nvidi-kernel-module-2.6-686 in modo che si aggiorni in automatico il pacchetto nvidia ogni volta che cambia il kernel o il driver)

poi in xorg modifica "nv" con nvidia :)

spero di esserti stato di aiuto

magnet_80
20-04-2007, 20:29
ciao, ho provato pi volte ad installare solo il core, poi con aptitude gli seleziono il sistema kde con anche xorg.
installa il tutto e poi quando tento di farlo partire mi restituisce un'errore sulla frequenza di refresh del monitor.
al momento sto usando il pc della ditta per navigare/scrivere.
ora sto re-installando il tutto, anche l'ambiente desktop, poi selezioner a mano kde, kdm e toglier gnome.
per caso, ti ricordi i passi che hai fatto partendo dalla core per installare kde?
grazie

bereshit
20-04-2007, 20:47
il core la prima cosa che ti installa..

poi saltando il passaggio dei task usando aptitude..vai nella sezione task end-user e selezioni desktop e kde-desktop..fine..per selezionare usa + per deseleziona -..seleziona tutto il task (se sai che installare puoi anche scegliere pacchetto per paccheto all'interno dei task)..

ps: tra i task oltre kde-desktop avevi selezionato anche desktop? perch quello che ti instala xorg e altra roba che non so se segnata come dipendenza di kde..

pps:installa anchela localizzazione in italiano..sempre dai task..

magnet_80
20-04-2007, 21:54
sono riuscito dopo molti giri a installare kde. ho fatto cos:
ho installato il sistema con desktop gnome. poi ho riavviato il tutto e sono entrato in shell e con aptitude ho deselezionato l'ambiente gnome e ho inserito kde.
ora il problema con l'installer che ho scaricato dal sito nvidia: mi dice "no precompiled kernel interface..." e mi chiede se scaricarlo dal sito nvidia. clicco di no.
poi mi dice "not have libc header file installed...install your distribution's libc development package"
con apt ho fatto apt-get install linux-kernel-headers ed ok.
ma i lib me ne trova un sacco. quali scarico?

magnet_80
20-04-2007, 22:18
RISOLTO!!!!!
soluzione:
http://www.debianclan.org/index.php?option=com_content&task=view&id=17&Itemid=38

seguendo il procedimento numero 2, ovvero "metodo debian".
dopo "apt-get install nvidia-glx" si passa torna a met pagina e si riparte da "Si andr ora ad editare il file di configurazione ..." fino alla voce "Load "glx"
poi, riavvio il pc e si nota un certo miglioramento. :)
ol. dopo tanto tempo ce lo fatta!!!
'notte

Loading