PDA

Visualizza la versione completa : ubuntu e win vista


np2k
19-04-2007, 23:38
ho installato ubuntu 6.10 dopo che avevo gia' installato windows vista...
adesso mi parte solo ubuntu, mentre windows no...

in menu.lst ho:

title Windows Vista/Longhorn (loader)
root (hd0,1)
savedefault
makeactive
chainloader +1

quindi non sembra essere stato sovrascritto niente e la
root (hd0,1) e' giusta perche' vista e' installato in /dev/sda2...
che faccio?

alkat
19-04-2007, 23:43
Originariamente inviato da np2k
ho installato ubuntu 6.10 dopo che avevo gia' installato windows vista...
adesso mi parte solo ubuntu, mentre windows no...

in menu.lst ho:

title Windows Vista/Longhorn (loader)
root (hd0,1)
savedefault
makeactive
chainloader +1

quindi non sembra essere stato sovrascritto niente e la
root (hd0,1) e' giusta perche' vista e' installato in /dev/sda2...
che faccio?

hd = hda, direi quindi che non tanto corretta la voce di grub che citi.

Non so come funzioni per i dispositivi SATA, ma prova a sostituire root (hd0,1) con root (sd0,1).

francofait
20-04-2007, 00:37
no per la notazione grub hd sta solo per hard disk

hd0,1 = hda2
hd4,x = sdax ma se le impostazioni bios sono corrette sda dovrebbe essere intercettato in hd4 solo con periferiche hd su usb. Per il primo disco fisso dovrebbe rimanere valido hd0 .

dAb
20-04-2007, 00:48
Premi E al menu di grub per andare nella sua console, poi scrivi:

root (hd

e premi tab. Ti apparira` la lista delle partizioni riconosciute da grub. Ma che errore ti da`?

alkat
20-04-2007, 01:20
Originariamente inviato da francofait
no per la notazione grub hd sta solo per hard disk

hd0,1 = hda2
hd4,x = sdax ma se le impostazioni bios sono corrette sda dovrebbe essere intercettato in hd4 solo con periferiche hd su usb. Per il primo disco fisso dovrebbe rimanere valido hd0 .

oops... chiedo venia. :(

Loading