PDA

Visualizza la versione completa : [ubuntu 7.04] Consiglio


psykopear
14-05-2007, 22:48
Ciao, mi sono iscritto ora la forum, quindi rima di tutto saluto tutti.
Volevo chiedere una cosa: ho installato la festy fawn l'ultima versione di ubuntu, e per installare la maggior parte de pacchetti si può usare il gestore synaptic. Fin qui ok, però ho problemi per installare i pacchetti che scarico: da shell li scompatto con tar xvfz (non ricordo se è proprio così però è scritto anche in questo sito) e il nome del pacchetto. Lo decomprime, poi per installarlo gli do: sudo apt-get install nomepacchetto. Alcuni li scarica, poi in fase di configurazione si ferma e non mi fa andare avanti, altri proprio dice che non è stato trovato, e fino ad ora sono riuscito ad installare solo java6. Mi potreste aiutare, scusate l'incompetenza, ma ho iniziato da poco con GNU/Linux e devo ancora fare pratica... :dhò:

Tekemaja
14-05-2007, 23:06
Uhm, strano... io ricordavo che Synaptic i pacchetti, oltre a scaricarli, li installava anche.. :confused:

francofait
14-05-2007, 23:31
Stai con le idee confuse .
Il gestore dei pacchetti ricerca scarica ed installa i pacchetti predisoposti sulle repositri della distribuzione in uso . Con ubuntu quindi Synaptic che altro non è che una gui x apt , ti visualizza per selezione e poi ti scarica ed installa i pacchetti.deb pronti dalle sue repositry poste agli indirizzi riportati nel file di configurazione /etc/apt/sources.list
Evita l'uso di sorgenti da altre fonti software. Ed in ogni caso se non puoi farne a meno , una volta scompattati in una dir di comodo , per installarli essendo in formato sorgente vanno prima compilati , quindi richiedono la presenza dell' ambiente sviluppo.

psykopear
15-05-2007, 21:55
Originariamente inviato da Tekemaja
Uhm, strano... io ricordavo che Synaptic i pacchetti, oltre a scaricarli, li installava anche.. :confused:

non è che ho le idee confuse, però in effetti rileggedo il mex mi sono espresso davvero male, volevo dire che volevo installare un altro programma non presente nei file sorgenti del gestore synaptic, ma che ho scaricato da internet, solo che non ho capito bene il processo per compilare il file sorgente...

vortex87
15-05-2007, 21:58
In genere il procedimento tipo è
./configure
make
make install

e richiede che sia installato il pacchetto "build-essentials"

ma è sconsigliato farlo, piuttosto conviene cercare i file .deb già pronti (prova magari a vedere su getdeb.net, se non sono presenti nelle repository di ubuntu - anche quelle aggiuntive che abiliti da synaptic o dalla voce sorgenti software nel menù sistema > amministrazione).

psykopear
15-05-2007, 21:59
Originariamente inviato da psykopear
non è che ho le idee confuse, però in effetti rileggedo il mex mi sono espresso davvero male, volevo dire che volevo installare un altro programma non presente nei file sorgenti del gestore synaptic, ma che ho scaricato da internet, solo che non ho capito bene il processo per compilare il file sorgente...

ok grazie, provo e vi faccio sapere... :)

Tekemaja
15-05-2007, 22:05
Cioè. del tipo che hai scaricato un file tar.gz et similia e vuoi sapere come installarlo?

psykopear
15-05-2007, 22:07
Originariamente inviato da Tekemaja
Cioè. del tipo che hai scaricato un file tar.gz et similia e vuoi sapere come installarlo?

si proprio così
nel frattempo ho fatto un caos, nn so cosa ho fatto ma sono saltati sia aggiungi/rimuovi applicazioni sia Synaptic... e mo come faccio? aspe che riporto gli errori e vediamo se qualcuno mi può aiutare...

psykopear
15-05-2007, 22:11
ecco il report dell'errore, mi sa che non è una bella cosa....

E: La linea 49 in /etc/apt/sources.list (dist parse) non è corretta
E: Non è stato possibile leggere la lista delle sorgenti.
Correggere il problema nella configurazione dell'archivio.
E: _cache->open() failed, please report.

Tekemaja
15-05-2007, 22:19
A titolo di curiosità..ma che programma è?

Loading