PDA

Visualizza la versione completa : wxWidgets


manu86
14-05-2007, 23:38
salve a tutti..
stavo cercando di installare amule e ho scaricato il sorgente aMule-2.1.3 perchè con l'rpm dovevo scaricare un sacco di altri pacchetti...
quando arrivo a dargli ./configure ad un certo punto mi da un errore:

checking for wx-config... no
configure: error:
wxWidgets must be installed on your system but wx-config
script couldn't be found. Please check that wx-config is
in path or specified by --with-wx-config=path flag, the
directory where wxWidgets libraries are installed (returned
by 'wx-config --libs' command) is in LD_LIBRARY_PATH or
equivalent variable and wxWidgets version is 2.6.0 or above.

il pacchetto gtk ho visto sul centro di controllo che è installato...
credo di aver fatto casino con i driver io nell'installarli e poi nel levarli..
qualcuno ha idea di come posso fare per risolvere????

vortex87
14-05-2007, 23:41
Perchè non usi gli rpm? Gli strumenti della tua distribuzione dovrebbero preoccuparsi loro di scaricare tutto il necessario :stordita:

manu86
15-05-2007, 00:16
lo so...l'ho gia installato 2 o 3 volte e mi faceva ma questa volta non so come ma ho fatto casino..
fatto sta che non mi parte piu nemmeno con quelli...dato che ho gia reinstallato 2 o tre volte
vorei evitare di farlo ancora....
:bhò:

mykol
15-05-2007, 00:26
male, con linux non si reinstalla mai !

Come ti hanno consigliato, usa il packet manager della tua distro. Se ti chiede di installare anche altri files evidentemente sono necessari per il funzionamento ! Per rimettere tutto a posto bisognerebbe sapere esattamente cosa hai fatto ... A proposito, che distro usi ?

manu86
15-05-2007, 00:40
mandriva2007 2.6.17-5 credo........di preciso nn lo so... avevo trovato un rpm che sembrava non ne richiedessse altri l'avevo installato e sembrava facesse nel senso che in usr-bin c'era un file eseguibile gli davo il comando./amule e mi dava un paio di errori...poi mi sa che per soddisfare le dipendenze di altri pacchetti me lo disinstallava e da allora ho provato con il sorgente..
tutto qua :stordita:

sylvaticus
15-05-2007, 15:18
Ti servono le librerie grafiche wxWidgets che a sua volta vogliono le GTK.

Inoltre se installi da sorgente ti servono le librerie di sviluppo "-dev"...

In generale se il pachetto rpm ha un sacco di dipendenze un perchè c'è.... :rollo: :rollo:

undertaker84aa
15-05-2007, 15:34
Originariamente inviato da mykol
male, con linux non si reinstalla mai !


scusa mykol, non vorrei andare off topic faccio solo una domanda veloce...perchè dici che in linux è meglio non reinstallare mai?io con ubuntu sto provando un po di player audio a rotazione, per vedere quello che mi aggrada di piu,immagino che mi si potrebbe presentare l'occasione di reinstallarne qualcuno ma mi metti dei dubbi sulla bontà della cosa ora...:master:

vortex87
15-05-2007, 17:37
Originariamente inviato da undertaker84aa
scusa mykol, non vorrei andare off topic faccio solo una domanda veloce...perchè dici che in linux è meglio non reinstallare mai?io con ubuntu sto provando un po di player audio a rotazione, per vedere quello che mi aggrada di piu,immagino che mi si potrebbe presentare l'occasione di reinstallarne qualcuno ma mi metti dei dubbi sulla bontà della cosa ora...:master:

Credo intendesse che a differenza di Windows reinstallare un programma raramente risolve i problemi, non che non si possa :stordita:

undertaker84aa
15-05-2007, 17:51
Originariamente inviato da vortex87
Credo intendesse che a differenza di Windows reinstallare un programma raramente risolve i problemi, non che non si possa :stordita:

muchas gracias! :stordita:

Loading