PDA

Visualizza la versione completa : Debian mi ruba il pc!!


Tekemaja
17-05-2007, 14:07
Ho un problema che mi assila sin dai miei primi tentativi di passare a Linux:qualunque distro del mondo Debian (Elive Unsable esclusa) mi blocca mouse (di cui si muove solo il cursore che, però, non può cliccare su nulla) e tastiera, specie se apro applicazioni quali browser e, con i miei primi tentativi con Ubuntu, anche amule.
Sinora ho provato le seguenti:

Ubuntu Edgy- Feisty
Knoppix
Sidux
SimplyMepis 6.5
Elive Unstable
Debian Etch

La cosa più assurda è che non ho affatto periferiche particolari: solo una vetusta tastiera PS/2 senza marca nè miriadi di tasti programmabili, e un mouse Trust MI- 1200 PS/2 anch' esso banalissimo (ha finanche la canonica pallina sotto).
A cosa può essere dovuto tutto ciò?Possibile che il meraviglioso mondo Debian debba essermi precluso, specie ora che ho pure installato la nuova Debian Etch che tanto volevo testare (togliendomi pure lo sfizio di provare per la prima volta l'ambiente Xfce)?

sacarde
17-05-2007, 14:17
nessuna segnalazione nel log di xorg ?

se accedi in modalita testo, (init 1) la tastiera funziona ?

Tekemaja
17-05-2007, 14:23
Posso accedere alla partizione di Debian direttamente da qui, cioè da Mandriva Spring.. magari se il log di Xorg ha una destinazione specifica su hard disk (e tu me la dici) potrei eventualmente darci un occhiata.

Quanto alla modalità testo, non ho provato, ma considera che fin quando non apro i programmi di cui sopra, le periferiche in questione mi funzionano tranquillamente, di norma.

PS: considerando che questi problemi avvengono soprattutto quando mi affaccio alla rete (vedi browser e/o P2P) può, per caso, anche essere che Debian "litighi" col fatto che, pur usando un modem ethernet, l'incapsulamento del mio ISP Alice è un pppoA-VC Mux piuttosto che un pppoE?
Con mandriva e win xp ciò non mi pare assolutamente rappresenti un problema, ma con Debian e derivate...bò...

sacarde
17-05-2007, 14:52
/var/log/Xorg.0.log


p.s.
non ho ben capito...
il problema c'e' solo in certi casi ?

normalmente (localmente) tastiera e mouse funzionano ?

virus10
17-05-2007, 15:25
posta la sezione "input device" di /etc/X11/xorg.conf.

Tekemaja
17-05-2007, 15:28
Si, in linea generale usato localmente tutto funziona.
Comunque mi sa che nel log le ultime cose inerenti tastiera e mouse registrate sono semplicemente queste:

) Module GLcore: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.3
(II) GLX: Initialized MESA-PROXY GL provider for screen 0
(**) Option "CoreKeyboard"
(**) Generic Keyboard: Core Keyboard
(**) Option "Protocol" "standard"
(**) Generic Keyboard: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Generic Keyboard: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Generic Keyboard: XkbModel: "pc105"
(**) Option "XkbLayout" "it"
(**) Generic Keyboard: XkbLayout: "it"
(**) Option "CustomKeycodes" "off"
(**) Generic Keyboard: CustomKeycodes disabled
(**) Option "Protocol" "ImPS/2"
(**) Configured Mouse: Device: "/dev/input/mice"
(**) Configured Mouse: Protocol: "ImPS/2"
(**) Option "CorePointer"
(**) Configured Mouse: Core Pointer
(**) Option "Device" "/dev/input/mice"
(**) Option "Emulate3Buttons" "true"
(**) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Configured Mouse: ZAxisMapping: buttons 4 and 5
(**) Configured Mouse: Buttons: 9
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
xkb_keycodes { include "xfree86+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compatibility { include "complete" };
xkb_symbols { include "pc(pc105)+it" };
xkb_geometry { include "pc(pc105)" };
(II) Configured Mouse: ps2EnableDataReporting: succeeded
FreeFontPath: FPE "/usr/share/fonts/X11/misc" refcount is 2, should be 1; fixing.
(II) Open ACPI successful (/var/run/acpid.socket)
(II) APM registered successfully
(==) NV(0): Write-combining range (0xd0000000,0x2000000)
(**) NV(0): DPMS enabled
(==) RandR enabled
(EE) AIGLX: Screen 0 is not DRI capable
(II) GLX: Initialized MESA-PROXY GL provider for screen 0
xkb_keycodes { include "xfree86+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compatibility { include "complete" };
xkb_symbols { include "pc(pc105)+it" };
xkb_geometry { include "pc(pc105)" };
(II) Configured Mouse: ps2EnableDataReporting: succeeded
FreeFontPath: FPE "/usr/share/fonts/X11/misc" refcount is 2, should be 1; fixing.

Tekemaja
17-05-2007, 15:31
Per quanto riguarda l'imput device di Xorg.conf, invece, abbiamo questo:

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

E anche qui mi pare sia tutto a post, per quel che ne posso capire...

sacarde
17-05-2007, 15:34
questo errore:

(EE) AIGLX: Screen 0 is not DRI capable

lo metti a posto togliendo la relativa riga del file xorg.conf

mykol
17-05-2007, 15:39
copiare su Debian l'xorg di mandriva ?

Tekemaja
17-05-2007, 16:03
Uhm..guarda mykol, non ci avevo pensato.
Comunque, giusto per impratichirmi con i comandi da terminale, preferisco editare quello esistente con quest'ultimo, senonchè usando il comando kdesu kedit /percorso/nomefileda editare... mi esce questo:

[root@localhost log]# kdesu kedit Xorg.0.log
sh: kedit: command not found
kbuildsycoca running...
Launched ok, pid = 5907
[root@localhost log]#

Che comando uso dunque?Se usassi Kwrite mi darebbe anch 'esso errori.

Loading