PDA

Visualizza la versione completa : Mandriva si avvia solo in modalitÓ testuale!


yusizu
04-06-2007, 18:51
Ho creato unaltro post xkŔ sia pi¨ chiaro il problema che sto affrontando.

lo espongo:
ho smanettato un'intera giornata x configuarre postfix come server di posta (non solo locale) inquanto ho acquistato un dominio ed un servizio dns legato al mio ip fisso.

ora dopo una serie di smanettoni, riavvio il sistema e Mandriva 2006 si avvia solo in modalitÓ testuale;
ho provato a digitare startx ma dopo un breve tentativo di lanciare l'interfaccia grafica, ritorna in modalitÓ testo;
con mc ho eliminato qualche file grosso pensando che la root fosse piena e nn riusciva a caricare il bootloader, anche se Ŕ al 90%...xcui il problema nn Ŕ quello;

MI dareste una mano a risolvere questo problema?

grazie mille

P.S dimenticavo ho provato ad aggiornare la distro da dvd, finisco tutta la procedura senza alcun problema ma..nn ho risolto nulla!

mykol
04-06-2007, 19:16
quanto hai di spazio libero ?

Qual'Ŕ l'errore che ti da quando dai startx ?

prova ad entrare come root e vedere se si avvia o a dare startx da root oppure crea un altro utente dal centro di controllo ed avvialo da li per vedere..

Infine prova a rifare la configurazione video (per prudenza salvati il file /etc/X11/xorg.conf)

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

per rifare la configurazione dai mcc e poi invio. Poi segui il men¨. Scegli "Display" e metti i dati che chiede. Procurati i dati della scheda video, del monitor, mouse, ecc...

yusizu
04-06-2007, 19:55
Dopo aver ftto l'accesso come root ho dato "df"
rsultato:
Filesystem Dimem Usati Disp. Uso Montato su
/dev/hdc1 5,8G 4,8G 729MB 87% /
/dev/hdc6 31G 7G 24G 23% /home


lancio startx mi parte la schermata rossa, poi ritorna in modalitÓ testuale con il seguente errore:


......
The XKEYBOARD Keymap compiler (xkbcomp) reports:
> Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
> Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server

waiting for X server to shut down
[root@SERVER]#


questo Ŕ quanto, per la configurazione video avrei qualche timore..inoltre accertiamocci/vi che sia quello il problema...

grazie mile!

yusizu
04-06-2007, 22:36
pls up :(

andy caps
04-06-2007, 22:48
dipende da cosa hai fatto per configurare postfix
se non hai rimosso files di sistema riconfigurando con mcc come dice Mykol dovresti risolvere
in 2 minuti
poi dai startx e controlla che errori da piu in alto

:bh˛:

pessima idea quella di fare una home enorme ed una / piccola

altrimenti guarda i log

in /var/log/Xorg.0.log ci sono riportati tutti gli errori marcati con (EE)

cat /var/log/Xorg.0.log | grep EE te li elenca

yusizu
04-06-2007, 22:56
allora se lancio /var/log/Xorg.0.log mirestituisce:
-bash /var/log/Xorg.0.log permission denied

lancio:cat /var/log/Xorg.0.log | grep EE
ed ho:

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MT-SCREEN-SAVER

la partizione non l'ho decisa io Ŕ stata creata di default all'installazione della distro, avevo intensione di sistemarla anche perchŔ utilizzo quasi esclusivamente la partizione di root, avendo un accesso automatico come root...ma avevo timore di fare qualche cavolata.

questo Ŕ quanto ditemi un p˛ che posso fare per risistemare il tutto senza dover formattare.

La cosa strana Ŕ che neanche un'aggiornamento della distro ha risolto il problema

P.S forse qualche libreria, l'ho canecllata, poichŔ mi andava in crash kde, sinceramente nn ricrdo cosa... :confused:

andy caps
04-06-2007, 23:08
:bh˛: se hai rimosso cartelle di sistema non c'Ŕ molto da fargli


se sei connesso puoi provare ad installare fluxbox icewm o xfce4 e avviare uno di quelli

magari installando gdm e rimuovendo kdm

urpmi fluxbox installa fluxbox

urpme kdebase-kdm disinstalla kdm

ed urpmi gdm ti installa gdm per avviare fluxbox e vedere di sistemare

yusizu
04-06-2007, 23:13
Gent.mo Andy,
purtroppo non sono affatto esperto di linux,utilizzo questa distribuzione perchŔ mi serve come server web,
se sei cosý gentile da guidarmi....forsssse insieme riusciamo a fare qualcosa, ma non farmi fare cose complicate..giÓ solo alll'idea di disinstallare kde mi vengono i brividi....

ho una distro live knoppix in italiano..pensi che possiamo farci qualcosa??

altrimenti vediamo cosa si pu˛ fÓ, cmq la connessione ad internet Ŕ disponibile,certo da shell non ho modo di testarla ma dovrebbe funzionare...anche perchŔ il computer lo vedo in rete e posso accedere tranquillamente alle cartelle che avevo condiviso

andy caps
04-06-2007, 23:21
se hai la connessione urpmi fa tutto da se installando quelle cose

non Ŕ detto che ci sia da disintallare kde
io ti facevo disinstallare kdm che Ŕ il login manager e ti facevo installare gdm che Ŕ il login manager di gnome

se hai tolto qualche file di sistema o cartella non c'Ŕ niente da fargli :bh˛:


se il comando mcc non basta a ristemare la configurazione del desktop Ŕ preoccupante

in xorg non sembra ci siano errori

yusizu
04-06-2007, 23:28
magari pu˛servirti percapire il problema:

avvio linux,mi esce la schermata classica del pinguino, carica quasi completamente la barra, ad un certo punto lo schermo diventa rosso,(ovvero sta x accedere come root automaticamente)..poi per un attimo vedo una lista di FALLITO in rosso (Ŕ una frazione di secondo) e ualÓ entra in modalitÓ testuale.


...dimmi cortesemente che urpmi de vo fare che ci provo...a mali estremi, estremi...

grazie per ladisponibilitÓ

P.S se do un ctrl alt e can ho 3 FALLITO riferiti a POSTFIX, PROFTPD, STOPPING NFS locking

nn so se serve cmq...

Loading