PDA

Visualizza la versione completa : [Debian] Hard disk non rilevato in fase di installazione


Berello
15-06-2007, 23:28
Salve a tutti!
Ecco il mio problema: ho un computer con 2 hard disk SATA2 interni... Sul primo hard disk c'è Windows XP installato, sul secondo, avendo spazio a disposizione, volevo mettere Linux Debian (Etch), così ho preparato le partizioni che mi servono e ho avviato il computer col DVD di Debian. Arrivato al momento della scelta della partizione da usare, non posso raggiungere quella che ho creato, perché l'installazione mi permette di scegliere solamente le partizioni del primo hard disk (che sono già occupate e non posso usare).
In che modo posso far rilevare il secondo hard disk?
Premendo ALT+F2 posso usare una console virtuale, ma non so che comandi dare.

Nota: il primo hard disk è della stessa marca, dello stesso modello e della stessa capacità del secondo.
Le impostazioni per i due hard disk nel BIOS sono identiche, tranne che uno è "SATAII_BLUE" e l'altro (il secondo) è "SATAII_RED"... Ma questo credo che posso cambiarlo solo scollegando i due hard disks e scambiandoli di posto, cosa che dovrei evitare :master:

bereshit
15-06-2007, 23:38
hai un raid HW?

Berello
15-06-2007, 23:51
Non so cosa sia, sinceramente... (anzi, se me lo spieghi in breve mi fai un grande piacere, visto che ne sento spessissimo parlare)
Nel bios c'è scritto che il raid è disabilitato e su Windows il secondo hard disk funziona e bene.

bereshit
16-06-2007, 03:09
Nel bios c'è scritto che il raid è disabilitato e su Windows il secondo hard disk funziona e bene.


allora non è quello che ipotizzavo io

http://it.wikipedia.org/wiki/RAID

quando booti prova a passare i parametri

noapic nolapic

ma il secondo disco è partizionato? che opzione scegli quando devi formattare?
partizionamento manuale? o usa tutto il disco?

Berello
18-06-2007, 01:27
Grazie per le informazioni sul RAID, ho scoperto che era proprio quello che immaginavo/supponevo che fosse... :)

Ho provato a passare i parametri che mi hai suggerito (entrambi i parametri contemporaneamente), ma non è cambiato nulla.

Il secondo disco è partizionato: una prima partizione contenente dati vari, una seconda partizione FAT per lo scambio dati con Windows e poi lo spazio libero (non partizionato) che volevo dedicare a Linux.
Scelgo l'opzione "Partizionamento manuale", per cercare di inserire Linux nella partizione (ancora non formattata) che gli ho creato.

Comunque ho recuperato un po' di spazio vuoto sul primo hard disk e ho installato lì Linux (ormai lo userò così, tanto per me è quasi uguale), ma anche da questo sistema installato non riesco a vedere il secondo hard disk e quindi non si riesce a fare un mount, e mi piacerebbe risolvere.

Ho notato che il programma di installazione di Linux, quando mi fa scegliere la partizione da usare, indica l'hard disk come SCSI... Cosa significa ciò? Dovrebbe essere SATA2, così c'è scritto anche nel BIOS.

GunMan
18-06-2007, 02:07
i dischi sata, se non ricordo male, vengono "letti" come SCSI quindi quello non sarebbe un problema.

per quanto concerne il non vedere l'altro disco potresti postare l'output di fdisk


# fdisk -l

:ciauz:

Berello
18-06-2007, 02:56
Ho inserito il comando come amministratore ed ho ottenuto, mi pare, solamente voci riguardanti il primo hard disk.


Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 36171 290543526 7 HPFS/NTFS
/dev/sda2 36172 38793 21061215 83 Linux
/dev/sda3 38794 38913 963900 5 Extended
/dev/sda5 38794 38913 963868+ 82 Linux swap / Solaris

Guardando il "Disks manager" presente su Debian (dalla barra di avvio, scelgo "Desktop>Amministrazione>Disks") vedo 5 hard disks (???), il primo /dev/sda e l'ultimo /dev/sde, e il cdrom (/dev/hda).
Purtroppo però dei 5 hard disks, posso vedere solamente le proprietà del primo, che è quello contenente Windows XP (e adesso anche Linux), quindi lo stesso nominato da fdisk.
Gli altri 4 HD (l'ho capito solo ora) sono i lettori di schede (schede per macchinette fotografiche digitali).

GunMan
18-06-2007, 17:29
mi pare una situazione singolare, sembra che il secondo disco sata sia bellamente ignorato, domanda sicuramente sciocca, i controller sata sono sulla mainboard o stai usando un controller pci?


:ciauz:

Berello
19-06-2007, 02:00
Dovrebbero essere quelli della scheda madre.

Se posto la risposta di lspci può essere d'aiuto? Oppure c'è qualche altro comando che posso usare per capire cosa non va?

Grazie, a presto :)

GunMan
19-06-2007, 02:11
beh lspci può darci sicuramente informazioni sul chipset della scheda madre, non so quanto questo possa influire visto che l'altro disco sata è perfettamente visto.

comunque può tornare comodo avere informazioni in più, chissà che non ci sia qualche problema con i controller... anche se è strano su un kernel recente come quello di una debian etch.

:ciauz:

Loading