PDA

Visualizza la versione completa : [mandriva 2007 spring] installare QT4.2.3


mykol
28-06-2007, 00:43
Ciao,

per installare l'ultima versione di manslide mi servono le QT4.2.3. Come faccio a sapere quale versione ho installata ed eventualmente ad installarle ?

urpmi -y qt4 mi trova numerosi file, ma urpmi -y qt4.2.3 non ne trova, per cui penso che le dovrò installare a mano. Ci sono in RPM ? Altrimenti come le installo ?

Grazie

mykol
28-06-2007, 01:06
ho trovato in rpmfind.net le libqt4-devel-4.2.3-3.1mdv2007.1.i586.rpm. Saranno sufficienti ?

Ci sono anche le "static-devel" ma solo la versione libqt4-static-devel-4.1.4-9mdv2007.0.i586.rpm, ma è di una versione inferiore e solo per 2007.0. Ho provato ad installarlo, ma mi dice che è già tutto installato.

Cosa ne dite ?

kruskaiev
28-06-2007, 09:57
Quando hai le QT installate hai anche un comando che si chiama qtconfig-qt4.. che ti avvia una GUI in QT e nell'help ti dice la versione installata delle QT. (questo in Fedora perlomeno)..
Io ho installato i seguenti pacchetti in Fedora 7 (di cui la maggior parte sono inutili):


[checco@BL-work ~]$ rpm -qa | grep qt4
qt4-qsa-devel-1.2.2-4.fc7
qt4-sqlite-4.3.0-2.fc7
qt4-4.3.0-2.fc7
qt4-doc-4.3.0-2.fc7
qt4-qsa-1.2.2-4.fc7
qt4-devel-4.3.0-2.fc7
qt4-odbc-4.3.0-2.fc7
qt4-x11-4.3.0-2.fc7
qt4-mysql-4.3.0-2.fc7
qt4-postgresql-4.3.0-2.fc7

Fai attenzione.. non fare come me e installa la 4.2.3 che la release 4.3.0 ha dei bug che dovrebber correggere a momenti.

mykol
28-06-2007, 13:48
probabilmente dovrei averle già installate perchè ho lanciato manslide ed è partito.

Non ho ancora provato ad usarlo, però.

Loading