PDA

Visualizza la versione completa : [DELPHI] Combinazione CTRL+Spazio (Code Insight) non funzionante in D2007


Whitecrowsrain
28-06-2007, 23:30
Salve
sono da poco passato a delphi 2007 e ho un piccolo probblema con l'editor.
Ero abituato ad usare il completamento automatico sia degli oggetti che delle loro funzioni tramite la pressione dei tasti Ctrl+Space, ma con delphi2007 tale combinazione non da l'effetto desiderato.
Allora sono andato nella configurazione dell'IDE ed ho selezionato come Key Mappings quello di Default. Sono poi andato a vedere sulla guida di Delphi e cercando Keyboard mapping ho trovato alla voce shut curts (per il profilo default ):


Ctrl+space bar Code Completion pop-up window

Quindi non capisco perchè non funzioni, qualcuno sa darmiuna dritta?

Grazie mille! :)

alka
29-06-2007, 11:37
A me la combinazione di tasti CTRL+SPACE funziona benissimo. :master:

Sicuro che Code Insight sia abilitato nelle opzioni?

Cosa accade quando premi la combinazione di tasti?

Whitecrowsrain
29-06-2007, 11:59
Originariamente inviato da alka
A me la combinazione di tasti CTRL+SPACE funziona benissimo. :master:

Sicuro che Code Insight sia abilitato nelle opzioni?

Cosa accade quando premi la combinazione di tasti?

il bello è che non succede nulla!


siccome sono passato da delphi7 a delphi 2007 ho notato "qualche" differenza nella configurazione dell'editor.

Dove dovrebbe trovarsi in delphi2007 la scelta dei parametri per il code insight?
te lo chiedo perchè ora sto in ufficio e non ho sotto le mani il 2007 (ma il 7).
Comunque tra un'ora torno a casa e ti saprò dire meglio, ma mi sembrava di aver selezionato qualcosa del genere tra le opzioni.

alka
29-06-2007, 12:40
Originariamente inviato da Whitecrowsrain
siccome sono passato da delphi7 a delphi 2007 ho notato "qualche" differenza nella configurazione dell'editor.
Beh, se non hai usato una delle versioni precedenti intercorse tra la 7 e la 2007, noterai più di una differenza. :)


Originariamente inviato da Whitecrowsrain
Dove dovrebbe trovarsi in delphi2007 la scelta dei parametri per il code insight?

Nel menu Tools, voce Options direi.

Ad ogni modo, mi accerterei che non si fosse trattato di un caso, magari un malfunzionamento momentaneo: Code Insight è - come sempre - abilitato per default.

Ciao! :ciauz:

Whitecrowsrain
29-06-2007, 12:54
Originariamente inviato da alka
Beh, se non hai usato una delle versioni precedenti intercorse tra la 7 e la 2007, noterai più di una differenza. :)

si si, era una battuta la mia...è molto diverso e all'inizio non è facile orientarsi per uno che viene dal "vecchio" delphi..


Originariamente inviato da alka

Nel menu Tools, voce Options direi.

Ad ogni modo, mi accerterei che non si fosse trattato di un caso, magari un malfunzionamento momentaneo: Code Insight è - come sempre - abilitato per default.

Ciao! :ciauz:

non è un caso isolato.. è da quando che l'ho istallato che non funziona quella combinazione!

cmq il menù tools me lo sono scartabellato dalla testa ai piedi... ma non sono riuscito ancora a trovare la soluzione..
cmq tra pochi min torno a casa e contollo di nuovo!

Whitecrowsrain
29-06-2007, 13:29
ho controllato:
nell' option->editor option->code insight è tutto spuntato!
ho messo il delay a low... ma ctrl+space bar non funziona... cioè se scrivo il punto vicino ad un oggetto mi si apre la finestra dei suoi metodi/attributi, ma se clicco ctrl+space non fa nulla..ma perchè?

Whitecrowsrain
30-06-2007, 01:12
alkino non avresti la soluzione al mio problemino? :cry:

alka
30-06-2007, 16:05
Originariamente inviato da Whitecrowsrain
alkino non avresti la soluzione al mio problemino? :cry:
Non ho più risposto poiché, francamente, non saprei cosa suggerirti: la mia copia di Delphi 2007 funziona correttamente (non avevo problemi nemmeno con la beta, per ciò che riguarda il nostro caso), quindi non saprei a cosa può essere dovuto il difetto che riscontri.

Magari si tratta di un'incompatibilità strana con qualsivoglia scheda video, non saprei...

Elenca eventualmente le caratteristiche hardware della tua macchina, magari è possibile fare qualche accertamento a riguardo. :bhò:

Ciao! :ciauz:

P.S.: "alkino"? :biifu:

Whitecrowsrain
30-06-2007, 22:26
Originariamente inviato da alka
Non ho più risposto poiché, francamente, non saprei cosa suggerirti: la mia copia di Delphi 2007 funziona correttamente (non avevo problemi nemmeno con la beta, per ciò che riguarda il nostro caso), quindi non saprei a cosa può essere dovuto il difetto che riscontri.

Magari si tratta di un'incompatibilità strana con qualsivoglia scheda video, non saprei...

Elenca eventualmente le caratteristiche hardware della tua macchina, magari è possibile fare qualche accertamento a riguardo. :bhò:


ho in AMD Athlon64 3200+, 1GB di RAM, HD 160GB, Nvidia GF8800 GTS 320MB (lo so è sprecata per questo amd ma quando vedrò che la situazione HW si stabilizzerà cambierò!!)

questa confingurazione potrebbe dare qualche problema?

cmq è tanto strano, perchè è l'unica combinazione che non mi funziona (ed è una delle poche alla quale sono MOLTO AFFEZZIONATO per ovvi motivi), sai dove posso trovare un file di configurazione delle shut curts e magari editarlo?


Originariamente inviato da alka
Ciao! :ciauz:

P.S.: "alkino"? :biifu:

bhe mi sono affezzionato a te che mi rispondi sempre ed in maniera esaustiva!
Ma non ti far strane idee ok? :malol: (ok chiudo velocemente questo OT)

Loading