PDA

Visualizza la versione completa : debian non carica modulo bttv all'avvio


emamarro
03-07-2007, 19:49
Non so per quale motivo ma per vedere la tv con la mia pinnacle devo ricaricare il modulo:
rmmod bttv tuner tvaudio
modprobe bttv card=39

Tutte le volte che riavvio il computer,"etch" si scorda questa preferenza nonostante che:

1) abbia installato bttv con modconf
2) in /etc/modprobe.d/bttv presente " options bttv card=39 tuner=0 "
che sono le opzioni della mia scheda

Com' possibile che tutti gli altri moduli sono caricati correttamente ad eccezione di bttv?
Ho letto qua e la nei forum che un probema comune ma non ho trovato soluzione..
Grazie per un aiuto
Emanuele

@debian:~$ lsmod | grep bttv
bttv 159732 0
video_buf 23012 1 bttv
firmware_class 9600 1 bttv
ir_common 27780 1 bttv
compat_ioctl32 1472 1 bttv
btcx_risc 4776 1 bttv
tveeprom 13840 1 bttv
videodev 21120 1 bttv
v4l2_common 20448 3 tuner,bttv,videodev
i2c_algo_bit 8424 2 bttv,nvidiafb
i2c_core 19680 7 tvaudio,tuner,bttv,tveeprom,nvidiafb,i2c_algo_bit, i2c_i801

francofait
03-07-2007, 19:53
Il comando modprobe vale per la sola sessione di lavoro in corso , se vuoi che il driver ti venga caricato al boot devi inserirlo in /etc/modules , con un qualunque editor di testo e privilegi admin .

emamarro
03-07-2007, 20:03
grazie per la risposta ma c'era gi anche li,era il primo posto dove avevo controllato.
Comunque mi hanno sempre detto che con debian usando modconf il sistema carica il modulo automaticamente all'avvio e per sempre.O mi sbaglio? :master:



# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

loop
tuner
tvaudio
bttv
tuner
tvaudio
videodev

Alkaid
04-07-2007, 15:45
Originariamente inviato da emamarro
Non so per quale motivo ma per vedere la tv con la mia pinnacle devo ricaricare il modulo:
rmmod bttv tuner tvaudio
modprobe bttv card=39

Tutte le volte che riavvio il computer,"etch" si scorda questa preferenza nonostante che:

1) abbia installato bttv con modconf
2) in /etc/modprobe.d/bttv presente " options bttv card=39 tuner=0 "
che sono le opzioni della mia scheda

Com' possibile che tutti gli altri moduli sono caricati correttamente ad eccezione di bttv?
Ho letto qua e la nei forum che un probema comune ma non ho trovato soluzione..
Grazie per un aiuto
Emanuele

@debian:~$ lsmod | grep bttv
bttv 159732 0
video_buf 23012 1 bttv
firmware_class 9600 1 bttv
ir_common 27780 1 bttv
compat_ioctl32 1472 1 bttv
btcx_risc 4776 1 bttv
tveeprom 13840 1 bttv
videodev 21120 1 bttv
v4l2_common 20448 3 tuner,bttv,videodev
i2c_algo_bit 8424 2 bttv,nvidiafb
i2c_core 19680 7 tvaudio,tuner,bttv,tveeprom,nvidiafb,i2c_algo_bit, i2c_i801

Anch'io avevo questo problema, ho risolto creando uno script avviatv, ti fccio un copia/incolla:
modprobe -r bt878
modprobe -r bttv
modprobe bttv card=78 tuner=1

Poi qusto script puoi anche fartelo avviare in automatico. :ciauz:

emamarro
05-07-2007, 16:37
grazie1000 :ciauz:

Loading