PDA

Visualizza la versione completa : problemi con la connessione Debian 4.0


scram
12-07-2007, 19:32
Salve a tutti, vi espongo in breve il mio problema, ho appena finito di installare Debian 4.0, installazione standard, ha configurato il DHCP ma non ha riconosciuto i mirror (ne ftp.debian.org ne fastweb.debian.it) a parte questo e andato tutto a buon fine, tuttavia appena riavvio il sistema ed apro un terminale per impostre la connessione la bash non riconosce i comandi relativi alla rete, ne pppoeconf ne pon\poff ne plog, un iconcia al limite destro dello schermo mi segnala tuttavia che la connessione e gia stata cablata ma se provo ad avviare epiphany o a pingare un host qualsiasi mi risultano sempre unknown host.

sacarde
12-07-2007, 20:34
controlla /etc/resolv.conf

scram
13-07-2007, 15:56
Ho controllato il file, se non sbaglio contiene gli IP ai quali il DNS si connette per primo, ho installato ppp con tutti i suoi file di configurazione, ho creato una connessione e con il comando plog ho visualizzato le informazini a riguardo, tuttavia la connessione continua ad esistere solo a livello teorico, ho aggiunto l' IP del DNS che mi dava plog al file /etc/resolv.conf tuttavia ancora niente, inoltre quando adesso provo a lanciare un comando relativo alla connessione mi dice che non riesce a trovare l' opzione /dev/modem in pppd (che invece e presente).

mykol
13-07-2007, 16:39
in /etc/resolv.conf devi avere questo

nameserver 212.216.112.112
nameserver 212.216.172.62

Non serve altro (al limite i nameserver del tuo provider, ma questi vanno bene con tutti).

scram
14-07-2007, 01:10
allora, ho editato il file con i parametri che mi hai passato, tuttavia se provo a pingare www.google.it o ad avviare epiphany non succede niente, inoltre al termine della sessione il file cancella i cambiamenti che gli ho fatto

andy caps
14-07-2007, 01:36
se hai un router prova con il comando

route add default gw 192.168.1.1 se questo l'ip del router
mettendo almeno un dns


echo "nameserver 212.216.112.112" >> /etc/resolv.conf

da terminale di root

apt-get install pppoeconf se non trova il comando

scram
14-07-2007, 19:34
Neanche questo funziona, vi posto alcune info sulla mia connessione sperando che possano aiutarvi:


giulia:/home/jacopo# echo "nameserver 212.216.112.112" >> /etc/resolv.conf
giulia:/home/jacopo# ping http://www.google.it
ping: unknown host http://www.google.it
giulia:/home/jacopo# ifconfig
eth0 Link encap:Ethernet HWaddr 00:13:46:31:85:06
inet addr:192.168.1.8 Bcast:255.255.255.255 Mask:255.255.255.224
inet6 addr: fe80::213:46ff:fe31:8506/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:218 errors:0 dropped:0 overruns:0 frame:0
TX packets:227 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:15758 (15.3 KiB) TX bytes:16514 (16.1 KiB)
Interrupt:169 Base address:0xcc00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:560 (560.0 b) TX bytes:560 (560.0 b)

ppp0 Link encap:Point-to-Point Protocol
inet addr:82.53.176.152 P-t-P:192.168.100.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:19 errors:0 dropped:0 overruns:0 frame:0
TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:1357 (1.3 KiB) TX bytes:54 (54.0 b)

giulia:/home/jacopo# plog
Jul 4 14:21:31 giulia pppd[3759]: Using interface ppp1
Jul 4 14:21:31 giulia pppd[3759]: Connect: ppp1 <--> eth0
Jul 4 14:21:31 giulia pppd[3759]: Remote message: Authentication failed
Jul 4 14:21:31 giulia pppd[3759]: PAP authentication failed
Jul 4 14:21:31 giulia pppd[3759]: Connection terminated.
Jul 4 14:21:31 giulia pppd[3759]: Exit.
giulia:/home/jacopo# pon
/usr/sbin/pppd: In file /etc/ppp/peers/provider: unrecognized option '/dev/modem'


grazie, attendo risposte.

andy caps
14-07-2007, 22:44
un router o un modem questo ??

probabilmente sbagla gateway

dai il comando route -n e cancella il gateway che mette da se

route -n nella colonna del gateway mette i valori e puoi rimuoverli con ad esempio

route del default gw 192.168.1.8 se mette il valore 192.168.1.8


poi se sai il gateway puoi rimetterlo con il comando sopra route add . . . .
oppure prova dhcp eth0

o pppoeconf


echo "nameserver 212.216.112.112" >> /etc/resolv.conf dallo comunque se hai telecom come provider

mykol
14-07-2007, 22:45
ma usi un modem od un router ?

scram
15-07-2007, 00:08
come hai visto dal file che ho postato echo l' ho dato ugualmente, comunque utilizzo un modem Telecom con interfaccia ethernet che rileva correttamente, le altre distro che ho provato non mi hanno mai dato problemi simili. Come faccio a scoprire il gateway?

Loading